summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-08-15 07:54:06 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-08-15 07:54:06 +0000
commit5f7b754fbefc5e93cdb84d1b804736355ef7a744 (patch)
treec998b54f819c104e103fc8bd9d5131801a98ee2d /dev-lang/erlang
parentFix "range striding over charsets" error; bug #188112. (diff)
downloadgentoo-2-5f7b754fbefc5e93cdb84d1b804736355ef7a744.tar.gz
gentoo-2-5f7b754fbefc5e93cdb84d1b804736355ef7a744.tar.bz2
gentoo-2-5f7b754fbefc5e93cdb84d1b804736355ef7a744.zip
clean up; let erl binary use several CPUs if USE=smp is set. Reported by astro@spaceboyz.net on bug 188858; don't install license file; add a lot of quotes around variables; fix Emacs support file to use require and not load-library
(Portage version: 2.1.2.11)
Diffstat (limited to 'dev-lang/erlang')
-rw-r--r--dev-lang/erlang/ChangeLog12
-rw-r--r--dev-lang/erlang/erlang-11.2.1.ebuild142
-rw-r--r--dev-lang/erlang/erlang-11.2.5-r1.ebuild (renamed from dev-lang/erlang/erlang-11.2.4-r1.ebuild)55
-rw-r--r--dev-lang/erlang/files/10.2.6-manpage-emacs-gentoo.patch31
-rw-r--r--dev-lang/erlang/files/50erlang-gentoo.el2
-rw-r--r--dev-lang/erlang/files/digest-erlang-11.2.19
-rw-r--r--dev-lang/erlang/files/digest-erlang-11.2.4-r19
-rw-r--r--dev-lang/erlang/files/digest-erlang-11.2.5-r19
8 files changed, 49 insertions, 220 deletions
diff --git a/dev-lang/erlang/ChangeLog b/dev-lang/erlang/ChangeLog
index b4f24d539da3..d1087ddbe1b7 100644
--- a/dev-lang/erlang/ChangeLog
+++ b/dev-lang/erlang/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-lang/erlang
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.68 2007/08/06 14:46:05 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.69 2007/08/15 07:54:06 opfer Exp $
+
+*erlang-11.2.5-r1 (15 Aug 2007)
+
+ 15 Aug 2007; Christian Faulhammer <opfer@gentoo.org>
+ files/50erlang-gentoo.el, -files/10.2.6-manpage-emacs-gentoo.patch,
+ -erlang-11.2.1.ebuild, -erlang-11.2.4-r1.ebuild, +erlang-11.2.5-r1.ebuild:
+ clean up; let erl binary use several CPUs if USE=smp is set. Reported by
+ astro@spaceboyz.net on bug 188858; don't install license file; add a lot of
+ quotes around variables; fix Emacs support file to use require and not
+ load-library
06 Aug 2007; Roy Marples <uberlord@gentoo.org>
+files/erlang-11.2.5-gethostbyname.patch, erlang-11.2.5.ebuild:
diff --git a/dev-lang/erlang/erlang-11.2.1.ebuild b/dev-lang/erlang/erlang-11.2.1.ebuild
deleted file mode 100644
index 2e4cd943e2b3..000000000000
--- a/dev-lang/erlang/erlang-11.2.1.ebuild
+++ /dev/null
@@ -1,142 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-11.2.1.ebuild,v 1.11 2007/01/31 14:28:59 genone Exp $
-
-inherit eutils multilib flag-o-matic elisp-common versionator
-
-# NOTE: When bumping you need to adjust the *_VER strings in
-# src_install() to honour newer versions in the package (they
-# are maintained separately upstream).
-# As High Performance Erlang (HiPE) messes around a lot with
-# assembler, it breaks hardened and some normal systems, so it has
-# been disabled. Try with newer versions though.
-# If you need symlinks for binaries please tell one of the
-# maintainersor open up a bug.
-
-#erlang uses a really weird versioning scheme which caused quite a few problems already
-#Thus we do a slight modification converting all letters to digits to make it more sane (see e.g. #26420)
-#the next line selects the right source.
-MY_PV="R$(get_major_version)B-$(get_version_component_range 3)"
-
-# ATTN!! Take care when processing the C, etc version!
-MY_P=otp_src_${MY_PV}
-
-DESCRIPTION="Erlang programming language, runtime environment, and large collection of libraries"
-HOMEPAGE="http://www.erlang.org/"
-SRC_URI="http://www.erlang.org/download/${MY_P}.tar.gz
- doc? ( http://erlang.org/download/otp_doc_man_${MY_PV}.tar.gz
- http://erlang.org/download/otp_doc_html_${MY_PV}.tar.gz )"
-# Not yet available for 11.2.1
-# http://developer.sipphone.com/ejabberd/erlang_epoll_patch/otp_src_${MY_PV}_epoll.patch"
-
-LICENSE="EPL"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ppc sparc x86"
-IUSE="doc emacs java odbc ssl tk"
-
-RDEPEND=">=dev-lang/perl-5.6.1
- ssl? ( >=dev-libs/openssl-0.9.7d )
- emacs? ( virtual/emacs )
- java? ( >=virtual/jdk-1.2 )
- odbc? ( dev-db/unixODBC )"
-DEPEND="${RDEPEND}
- tk? ( dev-lang/tk )"
-
-S=${WORKDIR}/${MY_P}
-
-SITEFILE=50erlang-gentoo.el
-
-src_unpack() {
- ## fix compilation on hardened systems, see bug #154338
- filter-flags "-fstack-protector"
- filter-flags "-fstack-protector-all"
-
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${PN}-10.2.6-export-TARGET.patch"
- epatch "${FILESDIR}/10.2.6-manpage-emacs-gentoo.patch"
- use odbc || sed -i 's: odbc : :' lib/Makefile
-# epatch "${DISTDIR}"/otp_src_${MY_PV}_epoll.patch
-
- # bug 151612
- einfo "fixing hardcoded GLIBC_MINOR value dependency on signal handling (#151612)"
- sed -i "s/__GLIBC_MINOR__\ ==\ 3/__GLIBC_MINOR__\ \>=\ 3/g" \
- ${S}/erts/emulator/hipe/hipe_x86_signal.c
-}
-
-src_compile() {
- use java || export JAVAC=false
- ## disable High Performance Erlang (HiPE) to avoid a lot of
- ## problems on hardened, bug #154338
- econf \
- --disable-hipe \
- --enable-threads \
- $(use_with ssl) \
- || die
- make || die
-
- if use emacs ; then
- pushd lib/tools/emacs
- elisp-compile *.el
- popd
- fi
-}
-
-src_install() {
- local ERL_LIBDIR=/usr/$(get_libdir)/erlang
- local ERL_INTERFACE_VER=3.5.5.1
- local ERL_ERTS_VER=5.5.1
-
- make INSTALL_PREFIX="${D}" install || die
- dodoc AUTHORS EPLICENCE README
-
- dosym ${ERL_LIBDIR}/bin/erl /usr/bin/erl
- dosym ${ERL_LIBDIR}/bin/erlc /usr/bin/erlc
- dosym ${ERL_LIBDIR}/bin/ecc /usr/bin/ecc
- dosym ${ERL_LIBDIR}/bin/elink /usr/bin/elink
- dosym ${ERL_LIBDIR}/bin/ear /usr/bin/ear
- dosym ${ERL_LIBDIR}/bin/escript /usr/bin/escript
- dosym ${ERL_LIBDIR}/lib/erl_interface-${ERL_INTERFACE_VER}/bin/erl_call /usr/bin/erl_call
- dosym ${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam /usr/bin/beam
-
- ## Remove ${D} from the following files
- dosed ${ERL_LIBDIR}/bin/erl
- dosed ${ERL_LIBDIR}/bin/start
- cd "${D}"/${ERL_LIBDIR}/erts-${ERL_ERTS_VER}
- grep -rle "${D}" "${D}"/${ERL_LIBDIR}/erts-${ERL_ERTS_VER} | xargs sed -i -e "s:${D}::g"
-
- ## Clean up the no longer needed files
- rm "${D}"/${ERL_LIBDIR}/Install
-
- if use doc ; then
- for file in "${WORKDIR}"/man/man*/*.[1-9]; do
- # Avoid namespace collisions
- local newfile=${file}erl
- cp $file $newfile
- # Man page processing tools expect a capitalized "SEE ALSO" section
- # header
- sed -i -e 's,\.SH See Also,\.SH SEE ALSO,g' $newfile
- doman ${newfile}
- done
- dohtml -A README,erl,hrl,c,h,kwc,info -r "${WORKDIR}"/doc "${WORKDIR}"/lib "${WORKDIR}"/erts-*
- fi
-
- if use emacs ; then
- pushd "${S}"
- elisp-install erlang lib/tools/emacs/*.{el,elc}
- elisp-site-file-install "${FILESDIR}"/${SITEFILE}
- popd
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
- elog
- elog "If you need a symlink to one of erlang's binaries,"
- elog "please open a bug and tell the maintainers."
- elog
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-lang/erlang/erlang-11.2.4-r1.ebuild b/dev-lang/erlang/erlang-11.2.5-r1.ebuild
index a2a74a930ce5..289f702999b1 100644
--- a/dev-lang/erlang/erlang-11.2.4-r1.ebuild
+++ b/dev-lang/erlang/erlang-11.2.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-11.2.4-r1.ebuild,v 1.1 2007/05/21 06:27:20 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-11.2.5-r1.ebuild,v 1.1 2007/08/15 07:54:06 opfer Exp $
inherit elisp-common eutils flag-o-matic multilib versionator
@@ -25,7 +25,7 @@ SRC_URI="http://www.erlang.org/download/${MY_P}.tar.gz
LICENSE="EPL"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="doc emacs hipe java kpoll odbc smp ssl tk"
RDEPEND=">=dev-lang/perl-5.6.1
@@ -40,16 +40,6 @@ S="${WORKDIR}/${MY_P}"
SITEFILE=50erlang-gentoo.el
-pkg_setup() {
- if use hipe; then
- ewarn
- ewarn "You enabled High performance Erlang. Be aware that this extension"
- ewarn "can break the compilation in many ways, especially on hardened systems."
- ewarn "Don't cry, don't file bugs, just disable it!"
- ewarn
- fi
-}
-
src_unpack() {
## fix compilation on hardened systems, see bug #154338
filter-flags "-fstack-protector"
@@ -60,10 +50,17 @@ src_unpack() {
# needed for amd64
epatch "${FILESDIR}/${PN}-10.2.6-export-TARGET.patch"
+ # needed for FreeBSD
+ epatch "${FILESDIR}/${PN}-11.2.5-gethostbyname.patch"
use odbc || sed -i 's: odbc : :' lib/Makefile
- # delete internal copy of zlib, so the system one is used, see bug #178996
- rm "${S}/erts/emulator/zlib/zconf.h" "${S}/erts/emulator/zlib/zlib.h"
+ if use hipe; then
+ ewarn
+ ewarn "You enabled High performance Erlang. Be aware that this extension"
+ ewarn "can break the compilation in many ways, especially on hardened systems."
+ ewarn "Don't cry, don't file bugs, just disable it!"
+ ewarn
+ fi
}
src_compile() {
@@ -95,28 +92,28 @@ src_install() {
local ERL_ERTS_VER=$(extract_version erts VSN)
emake -j1 INSTALL_PREFIX="${D}" install || die "install failed"
- dodoc AUTHORS EPLICENCE README
+ dodoc AUTHORS README
- dosym ${ERL_LIBDIR}/bin/erl /usr/bin/erl
- dosym ${ERL_LIBDIR}/bin/erlc /usr/bin/erlc
- dosym ${ERL_LIBDIR}/bin/ear /usr/bin/ear
- dosym ${ERL_LIBDIR}/bin/escript /usr/bin/escript
+ dosym "${ERL_LIBDIR}/bin/erl" /usr/bin/erl
+ dosym "${ERL_LIBDIR}/bin/erlc" /usr/bin/erlc
+ dosym "${ERL_LIBDIR}/bin/ear" /usr/bin/ear
+ dosym "${ERL_LIBDIR}/bin/escript" /usr/bin/escript
dosym \
- ${ERL_LIBDIR}/lib/erl_interface-${ERL_INTERFACE_VER}/bin/erl_call \
+ "${ERL_LIBDIR}/lib/erl_interface-${ERL_INTERFACE_VER}/bin/erl_call" \
/usr/bin/erl_call
- dosym ${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam /usr/bin/beam
+ dosym "${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam" /usr/bin/beam
## Remove ${D} from the following files
- dosed ${ERL_LIBDIR}/bin/erl
- dosed ${ERL_LIBDIR}/bin/start
- grep -rle "${D}" "${D}"/${ERL_LIBDIR}/erts-${ERL_ERTS_VER} | xargs sed -i -e "s:${D}::g"
+ dosed "${ERL_LIBDIR}/bin/erl"
+ dosed "${ERL_LIBDIR}/bin/start"
+ grep -rle "${D}" "${D}/${ERL_LIBDIR}/erts-${ERL_ERTS_VER}" | xargs sed -i -e "s:${D}::g"
## Clean up the no longer needed files
- rm "${D}"/${ERL_LIBDIR}/Install
+ rm "${D}/${ERL_LIBDIR}/Install"
if use doc ; then
for i in "${WORKDIR}"/man/man* ; do
- dodir /usr/share/${i##${WORKDIR}}erl
+ dodir "/usr/share/${i##${WORKDIR}}erl"
done
for file in "${WORKDIR}"/man/man*/*.[1-9]; do
# Avoid namespace collisions
@@ -138,6 +135,10 @@ src_install() {
elisp-site-file-install "${FILESDIR}"/${SITEFILE}
popd
fi
+
+ # prepare erl for SMP, fixes bug #188112
+ use smp && sed -i -e 's:\(exec.*erlexec\):\1 -smp:' \
+ "${D}/${ERL_LIBDIR}/bin/erl"
}
pkg_postinst() {
@@ -146,7 +147,7 @@ pkg_postinst() {
elog "If you need a symlink to one of erlang's binaries,"
elog "please open a bug and tell the maintainers."
elog
- elog "Gentoo's versioning scheme differs from the author's, so please refer to this version as R11B-4"
+ elog "Gentoo's versioning scheme differs from the author's, so please refer to this version as R11B-5"
elog
}
diff --git a/dev-lang/erlang/files/10.2.6-manpage-emacs-gentoo.patch b/dev-lang/erlang/files/10.2.6-manpage-emacs-gentoo.patch
deleted file mode 100644
index a5183d480cd6..000000000000
--- a/dev-lang/erlang/files/10.2.6-manpage-emacs-gentoo.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff -ur otp_src_R10B-6.orig/lib/tools/emacs/erlang.el otp_src_R10B-6/lib/tools/emacs/erlang.el
---- otp_src_R10B-6.orig/lib/tools/emacs/erlang.el 2004-09-30 02:05:50.000000000 -0500
-+++ otp_src_R10B-6/lib/tools/emacs/erlang.el 2005-07-18 13:52:13.000000000 -0500
-@@ -2518,7 +2518,7 @@
-
- (defun erlang-man-make-menu-item (file)
- "Create a menu item containing the name of the man page."
-- (and (string-match ".*/\\([^/]+\\)\\.[^.]$" file)
-+ (and (string-match ".*/\\([^/]+\\)\\.[0-9]erl\\.gz$" file)
- (let ((page (substring file (match-beginning 1) (match-end 1))))
- (list (capitalize page)
- (list 'lambda '()
-@@ -2529,7 +2529,7 @@
-
- (defun erlang-man-get-files (dir)
- "Return files in directory DIR."
-- (directory-files dir t ".*\\.[0-9]\\'"))
-+ (directory-files dir t ".*\\.[0-9]erl\\.gz\\'"))
-
-
- (defun erlang-man-module (&optional module)
-@@ -2690,7 +2690,7 @@
- (error nil))
- (if file
- (let ((process-environment (copy-sequence process-environment)))
-- (if (string-match "\\(.*\\)/man[^/]*/\\([^/]+\\)\\.[^.]$" file)
-+ (if (string-match "\\(.*\\)/man[^/]*/\\([^/]+\\)\\.[0-9]erl.gz$" file)
- (let ((dir (substring file (match-beginning 1) (match-end 1)))
- (page (substring file (match-beginning 2) (match-end 2))))
- (if (fboundp 'setenv)
-Only in otp_src_R10B-6/lib/tools/emacs: erlang.el~
diff --git a/dev-lang/erlang/files/50erlang-gentoo.el b/dev-lang/erlang/files/50erlang-gentoo.el
index 468726a6d158..ddc486c08e86 100644
--- a/dev-lang/erlang/files/50erlang-gentoo.el
+++ b/dev-lang/erlang/files/50erlang-gentoo.el
@@ -1,5 +1,5 @@
;;; erlang site-lisp configuration
(add-to-list 'load-path "@SITELISP@")
-(load-library "erlang-start")
+(require "erlang-start")
(setq erlang-root-dir "/usr/share")
diff --git a/dev-lang/erlang/files/digest-erlang-11.2.1 b/dev-lang/erlang/files/digest-erlang-11.2.1
deleted file mode 100644
index bc3b32cdaa3c..000000000000
--- a/dev-lang/erlang/files/digest-erlang-11.2.1
+++ /dev/null
@@ -1,9 +0,0 @@
-MD5 f5d3b25821f6d0763defd09f1dd4f51f otp_doc_html_R11B-1.tar.gz 4717809
-RMD160 2a7425f55245b12037a02082ace85411c04c5bb6 otp_doc_html_R11B-1.tar.gz 4717809
-SHA256 225212891e2290d0ea21e489445113d7f79ad51e4b3e3e4f0042f8876383a7bc otp_doc_html_R11B-1.tar.gz 4717809
-MD5 dbd2d3da878fed7474b7a9aa03e13c7d otp_doc_man_R11B-1.tar.gz 627132
-RMD160 666899dedc72f22387d478ffe4a1f313c57bdb01 otp_doc_man_R11B-1.tar.gz 627132
-SHA256 706e7da589cddee06b9d0a24a09e2105ae719bbfb8b6a08fe55ae45d5dbf4bd6 otp_doc_man_R11B-1.tar.gz 627132
-MD5 1fe3707d9bed898bc51444cb529fdd79 otp_src_R11B-1.tar.gz 11144896
-RMD160 db658f8221c4226f52c88ff56d2f68afbe47bac2 otp_src_R11B-1.tar.gz 11144896
-SHA256 d5a8530dfee0b2348c4ad0107409fa73ac3233f31e2300ece625a2abd9eb4da7 otp_src_R11B-1.tar.gz 11144896
diff --git a/dev-lang/erlang/files/digest-erlang-11.2.4-r1 b/dev-lang/erlang/files/digest-erlang-11.2.4-r1
deleted file mode 100644
index 8a23b314578e..000000000000
--- a/dev-lang/erlang/files/digest-erlang-11.2.4-r1
+++ /dev/null
@@ -1,9 +0,0 @@
-MD5 187cd55de8866a278ed963664819404d otp_doc_html_R11B-4.tar.gz 4902864
-RMD160 36d8ed3e0523f651f57caa8588f12f0500344f0e otp_doc_html_R11B-4.tar.gz 4902864
-SHA256 fa1f313a0d3f79239ee2930159288419c6c4348d095cf58557ff799712d3a60f otp_doc_html_R11B-4.tar.gz 4902864
-MD5 cc041ceebc4a6615073d8d7e88495610 otp_doc_man_R11B-4.tar.gz 712928
-RMD160 ba006631a99757c65ff4955650485e213d6904b9 otp_doc_man_R11B-4.tar.gz 712928
-SHA256 5852d7d9b7f09f3dda0261fe51c52025eacbdae258a984994b1a2407a065450e otp_doc_man_R11B-4.tar.gz 712928
-MD5 649e6f057e6996f92c8496161d754d8d otp_src_R11B-4.tar.gz 11720279
-RMD160 53969dd0f1637e9ac784f38d6ec9c01b7986a9cd otp_src_R11B-4.tar.gz 11720279
-SHA256 6928f44b67982aa8e00a2b053ecc78437fc70e19a2b0131c8f1ee86f02009337 otp_src_R11B-4.tar.gz 11720279
diff --git a/dev-lang/erlang/files/digest-erlang-11.2.5-r1 b/dev-lang/erlang/files/digest-erlang-11.2.5-r1
new file mode 100644
index 000000000000..77aa33e4a391
--- /dev/null
+++ b/dev-lang/erlang/files/digest-erlang-11.2.5-r1
@@ -0,0 +1,9 @@
+MD5 6a40146d855f98d024682cd24e9bb5bc otp_doc_html_R11B-5.tar.gz 4968176
+RMD160 73f8056b66f3bc6ec6b93c3c3dbfdf47074f8974 otp_doc_html_R11B-5.tar.gz 4968176
+SHA256 7dea67980b958ffebf7a94f3d94bd9c874e041f4f5ee574c56aab62c54a71d28 otp_doc_html_R11B-5.tar.gz 4968176
+MD5 5c387162ae6d255f525d72a91481d135 otp_doc_man_R11B-5.tar.gz 725858
+RMD160 62d200be6143183a17f5263b7341ec40afe298c7 otp_doc_man_R11B-5.tar.gz 725858
+SHA256 ab364af6e9db473d2bc5c0646a9b70989b858953ca9c053b78a509960a4f9caa otp_doc_man_R11B-5.tar.gz 725858
+MD5 96acec41da87d6ee0ef18e1aab36ffdd otp_src_R11B-5.tar.gz 38332865
+RMD160 67eac12a891df0e8d46b383ea0997f9de3aa6ac6 otp_src_R11B-5.tar.gz 38332865
+SHA256 d41fdfba40f86a50e04b7226ae5cc4581072fad26d14be5e1ca06603813bb175 otp_src_R11B-5.tar.gz 38332865