summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-09-06 06:50:37 +0000
committerUlrich Müller <ulm@gentoo.org>2008-09-06 06:50:37 +0000
commit39b7fe08755e4a3a97a62e61ebf59f8bab1e5ec5 (patch)
tree22d7c100001bebda62314d741fe72e1a42c645f5 /dev-lang/gforth/gforth-0.6.2-r1.ebuild
parentApply fix by kouyu for missing return value #236654. (diff)
downloadgentoo-2-39b7fe08755e4a3a97a62e61ebf59f8bab1e5ec5.tar.gz
gentoo-2-39b7fe08755e4a3a97a62e61ebf59f8bab1e5ec5.tar.bz2
gentoo-2-39b7fe08755e4a3a97a62e61ebf59f8bab1e5ec5.zip
Use elisp-compile instead of elisp-comp, bug 235576. Fix compile failure with USE=emacs, bug 227523 comment 2.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'dev-lang/gforth/gforth-0.6.2-r1.ebuild')
-rw-r--r--dev-lang/gforth/gforth-0.6.2-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-lang/gforth/gforth-0.6.2-r1.ebuild b/dev-lang/gforth/gforth-0.6.2-r1.ebuild
index 6f79e7675c68..d3e9c454a65a 100644
--- a/dev-lang/gforth/gforth-0.6.2-r1.ebuild
+++ b/dev-lang/gforth/gforth-0.6.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/gforth-0.6.2-r1.ebuild,v 1.5 2008/03/17 15:56:08 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/gforth-0.6.2-r1.ebuild,v 1.6 2008/09/06 06:50:36 ulm Exp $
inherit elisp-common eutils toolchain-funcs flag-o-matic
@@ -55,7 +55,7 @@ src_compile() {
|| die "econf failed"
make || die
if use emacs; then
- elisp-comp *.el || die
+ elisp-compile *.el || die
fi
}
@@ -71,8 +71,8 @@ src_install() {
dodoc AUTHORS BUGS ChangeLog NEWS* README* ToDo doc/glossaries.doc doc/*.ps
if use emacs; then
- elisp-install ${PN} *.el *.elc
- elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ elisp-install ${PN} *.el *.elc || die
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE} || die
fi
}