summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-10-14 18:36:56 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-10-14 18:36:56 +0000
commitb73d35f749a9a881504ac3d7dd263447ce93ca4c (patch)
treebd378c9a3b0e942caa6a52cafd25c95f76af34ac /dev-lang/gforth/gforth-0.6.2.ebuild
parentfixes 31089 (diff)
downloadgentoo-2-b73d35f749a9a881504ac3d7dd263447ce93ca4c.tar.gz
gentoo-2-b73d35f749a9a881504ac3d7dd263447ce93ca4c.tar.bz2
gentoo-2-b73d35f749a9a881504ac3d7dd263447ce93ca4c.zip
fixes 31089
Diffstat (limited to 'dev-lang/gforth/gforth-0.6.2.ebuild')
-rw-r--r--dev-lang/gforth/gforth-0.6.2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-lang/gforth/gforth-0.6.2.ebuild b/dev-lang/gforth/gforth-0.6.2.ebuild
new file mode 100644
index 000000000000..d6a89851229e
--- /dev/null
+++ b/dev-lang/gforth/gforth-0.6.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/gforth-0.6.2.ebuild,v 1.1 2003/10/14 18:36:54 mkennedy Exp $
+
+IUSE="emacs"
+
+inherit elisp-common
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU Forth is a fast and portable implementation of the ANSI Forth language"
+HOMEPAGE="http://www.gnu.org/software/gforth"
+SRC_URI="http://www.complang.tuwien.ac.at/forth/gforth//${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/glibc
+ emacs? ( virtual/emacs )"
+
+SITEFILE=50gforth-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/gforth.el-gentoo.patch || die
+}
+
+src_compile() {
+ econf CC="gcc -fno-reorder-blocks -fno-inline" --enable-force-reg
+ make || die
+ use emacs && emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+}
+
+src_install () {
+ make install libdir=${D}/usr/lib \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ datadir=${D}/usr/share \
+ bindir=${D}/usr/bin \
+ install || die
+
+ dodoc AUTHORS BUGS COPYING* ChangeLog NEWS* README* ToDo doc/glossaries.doc doc/*.ps
+
+ if use emacs; then
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}