summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-04-03 08:34:05 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-04-03 08:34:05 +0000
commite0f6365f8cadca76e26ed6eb97874f4afa9f0dc3 (patch)
treeae60d81ac0138182089294964519bdaad80a0278 /dev-lang/gnu-smalltalk
parent~ppc marked (diff)
downloadgentoo-2-e0f6365f8cadca76e26ed6eb97874f4afa9f0dc3.tar.gz
gentoo-2-e0f6365f8cadca76e26ed6eb97874f4afa9f0dc3.tar.bz2
gentoo-2-e0f6365f8cadca76e26ed6eb97874f4afa9f0dc3.zip
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-lang/gnu-smalltalk')
-rw-r--r--dev-lang/gnu-smalltalk/ChangeLog7
-rw-r--r--dev-lang/gnu-smalltalk/files/50gnu-smalltalk-gentoo.el3
-rw-r--r--dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.10.ebuild11
3 files changed, 17 insertions, 4 deletions
diff --git a/dev-lang/gnu-smalltalk/ChangeLog b/dev-lang/gnu-smalltalk/ChangeLog
index 4a98ae19996b..fb8663ba4801 100644
--- a/dev-lang/gnu-smalltalk/ChangeLog
+++ b/dev-lang/gnu-smalltalk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/gnu-smalltalk
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/ChangeLog,v 1.5 2005/03/31 19:07:40 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/ChangeLog,v 1.6 2005/04/03 08:34:05 mkennedy Exp $
+
+ 03 Apr 2005; Matthew Kennedy <mkennedy@gentoo.org>
+ files/50gnu-smalltalk-gentoo.el, gnu-smalltalk-2.1.10.ebuild:
+ Correct messy Emacs Lisp installation; Include autoload for Emacs
+ interactive function: smalltalk-mode.
31 Mar 2005; Matthew Kennedy <mkennedy@gentoo.org>
gnu-smalltalk-2.1.10.ebuild:
diff --git a/dev-lang/gnu-smalltalk/files/50gnu-smalltalk-gentoo.el b/dev-lang/gnu-smalltalk/files/50gnu-smalltalk-gentoo.el
index 1915d5c15d97..074204d47dfd 100644
--- a/dev-lang/gnu-smalltalk/files/50gnu-smalltalk-gentoo.el
+++ b/dev-lang/gnu-smalltalk/files/50gnu-smalltalk-gentoo.el
@@ -2,4 +2,5 @@
;;; gnu-smalltalk site-lisp configuration
(add-to-list 'load-path "@SITELISP@")
-(add-to-list 'auto-mode-alist '("\\.st\\'" . smalltalk-mode)) \ No newline at end of file
+(autoload 'smalltalk-mode "smalltalk-mode" "Autoload for smalltalk-mode" t)
+(add-to-list 'auto-mode-alist '("\\.st\\'" . smalltalk-mode))
diff --git a/dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.10.ebuild b/dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.10.ebuild
index 6778370dbbae..87760b58b7bf 100644
--- a/dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.10.ebuild
+++ b/dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.10.ebuild,v 1.2 2005/03/31 19:07:40 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.10.ebuild,v 1.3 2005/04/03 08:34:05 mkennedy Exp $
inherit elisp-common flag-o-matic eutils gcc
@@ -52,6 +52,9 @@ src_compile() {
${myconf} \
|| die
emake || die "emake failed"
+ if use emacs; then
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+ fi
}
src_install() {
@@ -60,7 +63,11 @@ src_install() {
${D}/usr/include/snprintfv \
${D}/usr/share/aclocal/snprintfv.m4
dodoc AUTHORS COPYING* ChangeLog NEWS PATCHES README THANKS TODO
- use emacs && elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ rm -rf ${D}/var
+ if use emacs; then
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ fi
}
pkg_postinst() {