summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-11-04 12:28:39 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-11-04 12:28:39 +0000
commit6d0710f745645c36e8a234a9f4332832f67a5593 (patch)
tree39b0915d2df60a5291b36c2c96bddc69c38693ac /dev-lang/jwasm
parentDEPEND on dev-lang/python-exec. (diff)
downloadgentoo-2-6d0710f745645c36e8a234a9f4332832f67a5593.tar.gz
gentoo-2-6d0710f745645c36e8a234a9f4332832f67a5593.tar.bz2
gentoo-2-6d0710f745645c36e8a234a9f4332832f67a5593.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-lang/jwasm')
-rw-r--r--dev-lang/jwasm/ChangeLog8
-rw-r--r--dev-lang/jwasm/files/jwasm-2.11-types-test.patch58
-rw-r--r--dev-lang/jwasm/jwasm-2.11.ebuild40
3 files changed, 105 insertions, 1 deletions
diff --git a/dev-lang/jwasm/ChangeLog b/dev-lang/jwasm/ChangeLog
index b7ad57fbf1c6..96d3c816fe22 100644
--- a/dev-lang/jwasm/ChangeLog
+++ b/dev-lang/jwasm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/jwasm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/jwasm/ChangeLog,v 1.2 2013/05/16 09:31:44 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/jwasm/ChangeLog,v 1.3 2013/11/04 12:28:39 slyfox Exp $
+
+*jwasm-2.11 (04 Nov 2013)
+
+ 04 Nov 2013; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/jwasm-2.11-types-test.patch, +jwasm-2.11.ebuild:
+ Version bump.
*jwasm-2.10-r1 (16 May 2013)
diff --git a/dev-lang/jwasm/files/jwasm-2.11-types-test.patch b/dev-lang/jwasm/files/jwasm-2.11-types-test.patch
new file mode 100644
index 000000000000..047d1d005510
--- /dev/null
+++ b/dev-lang/jwasm/files/jwasm-2.11-types-test.patch
@@ -0,0 +1,58 @@
+From b19339d4356efbd9b49f73e67ed7c09b9dad4b75 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Thu, 16 May 2013 12:24:17 +0300
+Subject: [PATCH 1/2] types: add sanity tests for used sizes
+
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+---
+ GccUnix.mak | 2 +-
+ checks.c | 26 ++++++++++++++++++++++++++
+ 2 files changed, 27 insertions(+), 1 deletion(-)
+ create mode 100644 checks.c
+
+diff --git a/gccmod.inc b/gccmod.inc
+index 70f388a..86cb2bf 100644
+--- a/gccmod.inc
++++ b/gccmod.inc
+@@ -6,6 +6,7 @@ $(OUTD)/atofloat.o \
+ $(OUTD)/backptch.o \
+ $(OUTD)/bin.o \
+ $(OUTD)/branch.o \
++$(OUTD)/checks.o \
+ $(OUTD)/cmdline.o \
+ $(OUTD)/codegen.o \
+ $(OUTD)/coff.o \
+diff --git a/checks.c b/checks.c
+new file mode 100644
+index 0000000..af8630f
+--- /dev/null
++++ b/checks.c
+@@ -0,0 +1,26 @@
++/****************************************************************************
++*
++* This code is Public Domain.
++*
++* ========================================================================
++*
++* Description: make sure "inttype.h" filelds are of the desired size.
++*
++****************************************************************************/
++
++#include "inttype.h"
++
++/* fails to compile if type sizes are of unexpected size */
++static void validate_inttype_sizes()
++{
++/* try to create */
++#define T_IS_SIZE(__type, __expected_size, __test_name) \
++ char __test_name[2 * (sizeof (__type) == (__expected_size)) - 1];
++
++ T_IS_SIZE(uint_8, 1, size_of_uint_8_must_be_1_byte);
++ T_IS_SIZE(uint_16, 2, size_of_uint_16_must_be_2_bytes);
++ T_IS_SIZE(uint_32, 4, size_of_uint_32_must_be_4_bytes);
++ T_IS_SIZE(uint_64, 8, size_of_uint_64_must_be_8_bytes);
++
++#undef T_IS_SIZE
++}
+--
+1.8.2.1
diff --git a/dev-lang/jwasm/jwasm-2.11.ebuild b/dev-lang/jwasm/jwasm-2.11.ebuild
new file mode 100644
index 000000000000..bf4ed70d393b
--- /dev/null
+++ b/dev-lang/jwasm/jwasm-2.11.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/jwasm/jwasm-2.11.ebuild,v 1.1 2013/11/04 12:28:39 slyfox Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs versionator
+
+# 2.10 -> 210s
+MY_PN=JWasm
+MY_PV="$(delete_version_separator 1)s"
+MY_P="${MY_PN}${MY_PV}"
+
+DESCRIPTION="MASM-compatible TASM-similar assembler (fork of Wasm)"
+HOMEPAGE="http://www.japheth.de/JWasm.html"
+SRC_URI="http://www.japheth.de/Download/${MY_PN}/${MY_P}.zip"
+LICENSE="Watcom-1.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=""
+DEPEND=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-types-test.patch
+ # don't strip binary
+ sed -i GccUnix.mak -e 's/ -s / /g' || die
+}
+
+src_compile() {
+ emake -f GccUnix.mak CC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dobin GccUnixR/jwasm
+ dodoc *.txt Doc/*.txt
+}