summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2005-05-06 14:28:48 +0000
committerPeter Johanson <latexer@gentoo.org>2005-05-06 14:28:48 +0000
commit4a23f91088f86c9da83e3a2df0f6f56c8ef9d32d (patch)
tree7d31b4bc9c7cf27fc4c633e167987fad4561e70c /dev-lang/mono
parentclosing bug #91686 (diff)
downloadgentoo-2-4a23f91088f86c9da83e3a2df0f6f56c8ef9d32d.tar.gz
gentoo-2-4a23f91088f86c9da83e3a2df0f6f56c8ef9d32d.tar.bz2
gentoo-2-4a23f91088f86c9da83e3a2df0f6f56c8ef9d32d.zip
Force tls=__thread on amd64. See bug #83770.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'dev-lang/mono')
-rw-r--r--dev-lang/mono/ChangeLog5
-rw-r--r--dev-lang/mono/Manifest2
-rw-r--r--dev-lang/mono/mono-1.1.7.ebuild13
3 files changed, 14 insertions, 6 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index 2b13e548d382..7624107da1e4 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/mono
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.43 2005/05/05 02:48:31 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.44 2005/05/06 14:28:48 latexer Exp $
+
+ 06 May 2005; Peter Johanson <latexer@gentoo.org> mono-1.1.7.ebuild:
+ Force tls=__thread on amd64. See bug #83770.
*mono-1.1.7 (05 May 2005)
diff --git a/dev-lang/mono/Manifest b/dev-lang/mono/Manifest
index 9a74ea6130c7..7c3960c208a9 100644
--- a/dev-lang/mono/Manifest
+++ b/dev-lang/mono/Manifest
@@ -6,7 +6,7 @@ MD5 7df1ece1ffd1bacb0be1d2a46737f42f mono-1.1.4.ebuild 1827
MD5 fe6279ea5449f9f4067f543dce346af8 mono-1.1.6.ebuild 2314
MD5 c0d9ab33a90b8efb79b94fd948df3cc2 ChangeLog 16123
MD5 76b314cc7b7b79b298dd4889dff8c9cd metadata.xml 159
-MD5 23eaab79089c2954e057b9e1c24509b2 mono-1.1.7.ebuild 2076
+MD5 acf164190d40801b2de058697b331ee5 mono-1.1.7.ebuild 2155
MD5 e8acd8bc997d82f676be5cf2057d3d25 files/dotnet.conf 570
MD5 6e11372f48bd32e76012be8aae54e594 files/dotnet.init 1031
MD5 d7752110175a6157ea42e6528c791fbb files/mono-1.1.5-pathfix.diff 648
diff --git a/dev-lang/mono/mono-1.1.7.ebuild b/dev-lang/mono/mono-1.1.7.ebuild
index fb75927ac000..dc1a6cd7819f 100644
--- a/dev-lang/mono/mono-1.1.7.ebuild
+++ b/dev-lang/mono/mono-1.1.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.7.ebuild,v 1.1 2005/05/05 02:48:32 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.7.ebuild,v 1.2 2005/05/06 14:28:48 latexer Exp $
inherit eutils mono flag-o-matic
@@ -54,18 +54,23 @@ src_compile() {
strip-flags
local myconf="--with-preview=yes"
- if use nptl && have_NPTL
+ # Force __thread on amd64. See bug #83770
+ if use amd64
then
myconf="${myconf} --with-tls=__thread"
else
- myconf="${myconf} --with-tls=pthread"
+ if use nptl && have_NPTL
+ then
+ myconf="${myconf} --with-tls=__thread"
+ else
+ myconf="${myconf} --with-tls=pthread"
+ fi
fi
econf ${myconf} $(use_with icu) || die
emake -j1 || die "MONO compilation failure"
}
-
src_install() {
make DESTDIR=${D} install || die