summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2006-06-18 14:06:51 +0000
committerLars Weiler <pylon@gentoo.org>2006-06-18 14:06:51 +0000
commit38003ba8b7c18dd518b9aaa8a6cf3a22eddd99b0 (patch)
treec7c17384c4370f5029fedb5306a79ced96136a99 /dev-lang/nqc
parentInitial commit; thanks to all contributors in Bug #89257. (diff)
downloadgentoo-2-38003ba8b7c18dd518b9aaa8a6cf3a22eddd99b0.tar.gz
gentoo-2-38003ba8b7c18dd518b9aaa8a6cf3a22eddd99b0.tar.bz2
gentoo-2-38003ba8b7c18dd518b9aaa8a6cf3a22eddd99b0.zip
Version bump; thanks to all contributors in bug #89257.
(Portage version: 2.1.1_pre1)
Diffstat (limited to 'dev-lang/nqc')
-rw-r--r--dev-lang/nqc/ChangeLog10
-rw-r--r--dev-lang/nqc/files/digest-nqc-3.1_p43
-rw-r--r--dev-lang/nqc/files/nqc-3.1_p4-amd64.patch12
-rw-r--r--dev-lang/nqc/files/nqc-3.1_p4-usb.patch31
-rw-r--r--dev-lang/nqc/metadata.xml8
-rw-r--r--dev-lang/nqc/nqc-2.5.1.ebuild4
-rw-r--r--dev-lang/nqc/nqc-3.1_p4.ebuild53
7 files changed, 117 insertions, 4 deletions
diff --git a/dev-lang/nqc/ChangeLog b/dev-lang/nqc/ChangeLog
index dad9f643265c..85b8390306b5 100644
--- a/dev-lang/nqc/ChangeLog
+++ b/dev-lang/nqc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/nqc
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqc/ChangeLog,v 1.9 2005/12/14 00:59:32 griffon26 Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqc/ChangeLog,v 1.10 2006/06/18 14:06:51 pylon Exp $
+
+*nqc-3.1_p4 (18 Jun 2006)
+
+ 18 Jun 2006; Lars Weiler <pylon@gentoo.org> +files/nqc-3.1_p4-amd64.patch,
+ +files/nqc-3.1_p4-usb.patch, +metadata.xml, +nqc-3.1_p4.ebuild:
+ Version bump; thanks to all contributors in bug #89257.
14 Dec 2005; Maurice van der Pot <griffon26@gentoo.org>
+files/nqc-2.5.1-gcc34-fix.patch, nqc-2.5.1.ebuild:
diff --git a/dev-lang/nqc/files/digest-nqc-3.1_p4 b/dev-lang/nqc/files/digest-nqc-3.1_p4
new file mode 100644
index 000000000000..3883e13011fd
--- /dev/null
+++ b/dev-lang/nqc/files/digest-nqc-3.1_p4
@@ -0,0 +1,3 @@
+MD5 f7868445a25615ad82e6e63bf16aef3c nqc-3.1.r4.tgz 334211
+RMD160 b251210efc52022f1d4d97d9c02c06d4251b3666 nqc-3.1.r4.tgz 334211
+SHA256 e40d179783ef1fa492e6804b99f202c7d61c6bda476ddbe2936c8956eaafd629 nqc-3.1.r4.tgz 334211
diff --git a/dev-lang/nqc/files/nqc-3.1_p4-amd64.patch b/dev-lang/nqc/files/nqc-3.1_p4-amd64.patch
new file mode 100644
index 000000000000..cca6b7fa0df7
--- /dev/null
+++ b/dev-lang/nqc/files/nqc-3.1_p4-amd64.patch
@@ -0,0 +1,12 @@
+diff -Naur nqc-3.1.r4.orig/compiler/Error.h nqc-3.1.r4/compiler/Error.h
+--- nqc-3.1.r4.orig/compiler/Error.h 2005-03-16 17:52:44.000000000 +0000
++++ nqc-3.1.r4/compiler/Error.h 2006-05-08 06:25:30.000000000 +0000
+@@ -118,7 +118,7 @@
+ };
+
+ Error(ErrorCode code, int data=0) : fCode(code), fData(data) {}
+- Error(ErrorCode code, const char *s) : fCode(code), fData((int)s) {}
++ Error(ErrorCode code, const char *s) : fCode(code), fData((long)s) {}
+
+ // raising errors
+ void Raise(const LexLocation *loc) const; // raise error at specified location
diff --git a/dev-lang/nqc/files/nqc-3.1_p4-usb.patch b/dev-lang/nqc/files/nqc-3.1_p4-usb.patch
new file mode 100644
index 000000000000..d69df483195e
--- /dev/null
+++ b/dev-lang/nqc/files/nqc-3.1_p4-usb.patch
@@ -0,0 +1,31 @@
+--- Makefile.old 2005-08-24 17:46:58.000000000 -0500
++++ Makefile 2005-08-24 17:48:16.000000000 -0500
+@@ -53,7 +53,7 @@
+
+
+ # installation information
+-PREFIX?=/usr/local
++PREFIX?=/usr/
+ BINDIR?=${PREFIX}/bin
+ MANDIR?=${PREFIX}/man/man1
+ MANEXT?=1
+@@ -69,7 +69,7 @@
+ #CFLAGS = -pipe -Iplatform -Ircxlib -Inqc -Icompiler -Wall -Wstrict-prototypes -Wmissing-prototypes
+ CFLAGS += -Iplatform -Ircxlib -Inqc -Icompiler -Wall
+
+-USBOBJ = rcxlib/RCX_USBTowerPipe_none.o
++#USBOBJ = rcxlib/RCX_USBTowerPipe_none.o
+
+
+ #
+@@ -86,8 +86,8 @@
+ ifneq (,$(strip $(findstring $(OSTYPE), Linux)))
+ # Linux
+ # uncomment this next line if you have the USB tower library installed
+-# USBOBJ = rcxlib/RCX_USBTowerPipe_linux.o
+- CFLAGS += -I/usr/local/include/LegoUSB -Wno-deprecated
++ USBOBJ = rcxlib/RCX_USBTowerPipe_linux.o
++ CFLAGS += -I/usr/include/LegoUSB -Wno-deprecated
+ else
+ ifneq (,$(findstring $(OSTYPE), SunOS))
+ # Solaris
diff --git a/dev-lang/nqc/metadata.xml b/dev-lang/nqc/metadata.xml
new file mode 100644
index 000000000000..66e0c3df3934
--- /dev/null
+++ b/dev-lang/nqc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>pylon@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-lang/nqc/nqc-2.5.1.ebuild b/dev-lang/nqc/nqc-2.5.1.ebuild
index 8be23a076cc8..f44e92bb764c 100644
--- a/dev-lang/nqc/nqc-2.5.1.ebuild
+++ b/dev-lang/nqc/nqc-2.5.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqc/nqc-2.5.1.ebuild,v 1.10 2005/12/14 00:59:32 griffon26 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqc/nqc-2.5.1.ebuild,v 1.11 2006/06/18 14:06:51 pylon Exp $
inherit eutils
diff --git a/dev-lang/nqc/nqc-3.1_p4.ebuild b/dev-lang/nqc/nqc-3.1_p4.ebuild
new file mode 100644
index 000000000000..c621c7540b3f
--- /dev/null
+++ b/dev-lang/nqc/nqc-3.1_p4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqc/nqc-3.1_p4.ebuild,v 1.1 2006/06/18 14:06:51 pylon Exp $
+
+inherit eutils
+
+DESCRIPTION="Not Quite C - C-like compiler for Lego Mindstorms"
+SRC_URI="http://bricxcc.sourceforge.net/nqc/release/${P/_p/.r}.tgz"
+HOMEPAGE="http://bricxcc.sourceforge.net/nqc/"
+
+S=${WORKDIR}/${P/_p/.r}
+
+SLOT="0"
+LICENSE="MPL-1.0"
+KEYWORDS="~x86 ~amd64"
+IUSE="usb"
+
+DEPEND="virtual/libc
+ usb? ( dev-libs/legousbtower )"
+
+src_compile()
+{
+ if use usb; then
+ epatch ${FILESDIR}/${P}-usb.patch
+ fi
+ if use amd64; then
+ epatch ${FILESDIR}/${P}-amd64.patch
+ fi
+ sed -i -e 's/PREFIX?\=\/usr\/local/PREFIX?\=\/usr/' Makefile
+ emake || die
+}
+
+src_install() {
+ dobin bin/*
+ mv nqc-man-2.1r1-0.man nqc.1
+ doman nqc.1
+ dodoc history.txt readme.txt scout.txt test.nqc
+}
+
+pkg_postinst() {
+ einfo "To change the default serial name for nqc (/dev/ttyS0) set"
+ einfo "the environment variable RCX_PORT or use the nqc command line"
+ einfo "option -S to specify your serial port."
+ if use usb; then
+ einfo
+ einfo "You have enabled USB support. To use usb on the"
+ einfo "command line use the -Susb command line option"
+ else
+ einfo
+ einfo "You have not enabled usb support and will be unable"
+ einfo "to use the usb IR tower. To enable USB use the usb use flag"
+ fi
+}