summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-03-08 04:30:26 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-03-08 04:30:26 +0000
commit7af56ec6a715d7e31f54349cc507fe49a2943e99 (patch)
tree0d091313e16aa062ac11a2657d1a065ea0e48a66 /dev-lang/nqp
parentAdjust patch from previous commit so that we don't break the wire protocol. (diff)
downloadgentoo-2-7af56ec6a715d7e31f54349cc507fe49a2943e99.tar.gz
gentoo-2-7af56ec6a715d7e31f54349cc507fe49a2943e99.tar.bz2
gentoo-2-7af56ec6a715d7e31f54349cc507fe49a2943e99.zip
Bump
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/nqp')
-rw-r--r--dev-lang/nqp/ChangeLog7
-rw-r--r--dev-lang/nqp/nqp-2012.02.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-lang/nqp/ChangeLog b/dev-lang/nqp/ChangeLog
index 3425c9587c41..b22ba89f583b 100644
--- a/dev-lang/nqp/ChangeLog
+++ b/dev-lang/nqp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/nqp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/ChangeLog,v 1.4 2012/02/16 07:15:38 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/ChangeLog,v 1.5 2012/03/08 04:30:26 patrick Exp $
+
+*nqp-2012.02 (08 Mar 2012)
+
+ 08 Mar 2012; Patrick Lauer <patrick@gentoo.org> +nqp-2012.02.ebuild:
+ Bump
*nqp-2012.01 (16 Feb 2012)
diff --git a/dev-lang/nqp/nqp-2012.02.ebuild b/dev-lang/nqp/nqp-2012.02.ebuild
new file mode 100644
index 000000000000..77ba3273cdbf
--- /dev/null
+++ b/dev-lang/nqp/nqp-2012.02.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/nqp-2012.02.ebuild,v 1.1 2012/03/08 04:30:26 patrick Exp $
+
+EAPI=3
+
+inherit eutils multilib
+
+PARROT_VERSION="3.9.0"
+
+DESCRIPTION="Not Quite Perl, a Perl 6 bootstrapping compiler"
+HOMEPAGE="http://rakudo.org/"
+SRC_URI="http://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/parrot-${PARROT_VERSION}[unicode]"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+src_prepare() {
+ cd "${WORKDIR}"
+ ln -s * "${S}" || die
+ cd "${S}"
+ echo "${PV}" > VERSION
+}
+
+src_configure() {
+ perl Configure.pl || die
+}
+
+src_compile() {
+ emake -j1 || die
+}
+
+src_test() {
+ emake -j1 test || die
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install || die
+
+ dodoc CREDITS README || die
+
+ if use doc; then
+ dodoc docs/* || die
+ fi
+}