summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2010-01-10 22:04:16 +0000
committerAlex Legler <a3li@gentoo.org>2010-01-10 22:04:16 +0000
commit5fd89f68402f3b24a975d645e95addc4d5089904 (patch)
treeb1d42236fa0aee72cc455d0e56e1fb7e66a4a7f2 /dev-lang/ruby
parentextensions_option should be local variable. (diff)
downloadgentoo-2-5fd89f68402f3b24a975d645e95addc4d5089904.tar.gz
gentoo-2-5fd89f68402f3b24a975d645e95addc4d5089904.tar.bz2
gentoo-2-5fd89f68402f3b24a975d645e95addc4d5089904.zip
Version bump (1.8.6), security bug 300468. Remove unneded vulnerable version. The new ebuild also has the fix for bug 168939.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/ruby')
-rw-r--r--dev-lang/ruby/ChangeLog9
-rw-r--r--dev-lang/ruby/ruby-1.8.6_p388.ebuild (renamed from dev-lang/ruby/ruby-1.8.6_p383.ebuild)19
2 files changed, 18 insertions, 10 deletions
diff --git a/dev-lang/ruby/ChangeLog b/dev-lang/ruby/ChangeLog
index 9c5661b817b4..a319fccf486a 100644
--- a/dev-lang/ruby/ChangeLog
+++ b/dev-lang/ruby/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/ruby
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.434 2010/01/10 17:48:30 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.435 2010/01/10 22:04:16 a3li Exp $
+
+*ruby-1.8.6_p388 (10 Jan 2010)
+
+ 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
+ +ruby-1.8.6_p388.ebuild:
+ Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
+ version. The new ebuild also has the fix for bug 168939.
*ruby-1.8.7_p249 (10 Jan 2010)
diff --git a/dev-lang/ruby/ruby-1.8.6_p383.ebuild b/dev-lang/ruby/ruby-1.8.6_p388.ebuild
index 2e12be28fdb0..90a49a8e3a79 100644
--- a/dev-lang/ruby/ruby-1.8.6_p383.ebuild
+++ b/dev-lang/ruby/ruby-1.8.6_p388.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.6_p383.ebuild,v 1.1 2009/08/20 09:09:50 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.6_p388.ebuild,v 1.1 2010/01/10 22:04:16 a3li Exp $
EAPI=1
inherit autotools eutils flag-o-matic multilib versionator
@@ -14,7 +14,7 @@ MY_SUFFIX=$(delete_version_separator 1 ${SLOT})
DESCRIPTION="An object-oriented scripting language"
HOMEPAGE="http://www.ruby-lang.org/"
SRC_URI="mirror://ruby/${SLOT}/${MY_P}.tar.bz2
-http://dev.a3li.info/gentoo/distfiles/${PN}-patches-${PV}.tar.bz2"
+http://dev.a3li.li/gentoo/distfiles/${PN}-patches-${PV}.tar.bz2"
LICENSE="|| ( Ruby GPL-2 )"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
@@ -26,7 +26,7 @@ RDEPEND="
ssl? ( dev-libs/openssl )
socks5? ( >=net-proxy/dante-1.1.13 )
tk? ( dev-lang/tk )
- app-admin/eselect-ruby
+ >=app-admin/eselect-ruby-20091225
!=dev-lang/ruby-cvs-${SLOT}*
!<dev-ruby/rdoc-2
!dev-ruby/rexml"
@@ -59,7 +59,7 @@ src_unpack() {
cd "${S}"
EPATCH_FORCE="yes" EPATCH_SUFFIX="patch" \
- epatch "${WORKDIR}/patches-${PV}"
+ epatch "${WORKDIR}/patches-${PV}"
# Fix a hardcoded lib path in configure script
sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
@@ -88,11 +88,14 @@ src_compile() {
append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
fi
+ # ipv6 hack, bug 168939. Needs --enable-ipv6.
+ use ipv6 || myconf="--with-lookup-order-hack=INET"
+
econf --program-suffix=$MY_SUFFIX --enable-shared \
$(use_enable socks5 socks) \
$(use_enable doc install-doc) \
$(use_enable threads pthread) \
- $(use_enable ipv6) \
+ --enable-ipv6 \
$(use_enable debug) \
$(use_with berkdb dbm) \
$(use_with gdbm) \
@@ -173,7 +176,5 @@ pkg_postinst() {
}
pkg_postrm() {
- if [[ ! -n $(readlink "${ROOT}"usr/bin/ruby) ]] ; then
- eselect ruby set ruby${MY_SUFFIX}
- fi
+ eselect ruby cleanup
}