summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-12-22 09:17:37 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-12-22 09:17:37 +0000
commitaa4732dfbe52d07cf00616577eff76faa68ff9bd (patch)
tree20081569ab16076272ea250468f454ca25ba7207 /dev-lang/snobol/snobol-0.99.4.ebuild
parentinitial commit, ebuild by robbat2@gentoo.org, inspired by cleaning my room an... (diff)
downloadgentoo-2-aa4732dfbe52d07cf00616577eff76faa68ff9bd.tar.gz
gentoo-2-aa4732dfbe52d07cf00616577eff76faa68ff9bd.tar.bz2
gentoo-2-aa4732dfbe52d07cf00616577eff76faa68ff9bd.zip
initial commit, ebuild by robbat2@gentoo.org, inspired by cleaning my room and finding a manual for this damn thing, circa 1968.
Diffstat (limited to 'dev-lang/snobol/snobol-0.99.4.ebuild')
-rw-r--r--dev-lang/snobol/snobol-0.99.4.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-lang/snobol/snobol-0.99.4.ebuild b/dev-lang/snobol/snobol-0.99.4.ebuild
new file mode 100644
index 000000000000..9caddd3b2e44
--- /dev/null
+++ b/dev-lang/snobol/snobol-0.99.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/snobol/snobol-0.99.4.ebuild,v 1.1 2003/12/22 09:17:30 robbat2 Exp $
+
+DESCRIPTION="Phil Budne's port of Macro SNOBOL4 in C, for modern machines"
+HOMEPAGE="http://www.snobol4.org/csnobol4/"
+SRC_URI="mirror://snobol4/${P}.tar.gz"
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="sys-devel/gcc
+ sys-devel/m4"
+RDEPEND=""
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ sed '/autoconf/s:autoconf:./autoconf:g' -i ${S}/configure
+ echo "OPT=${CFLAGS}" >${S}/local-config
+ echo "ADD_CPPFLAGS(-DUSE_STDARG_H)" >>${S}/local-config
+ echo "BINDEST=/usr/bin/snobol4" >>${S}/local-config
+ echo "MANDEST=/usr/share/man/man4/snobol4.1" >>${S}/local-config
+ echo "SNOLIB_DIR=/usr/lib/snobol4" >>${S}/local-config
+}
+
+src_compile() {
+ # WARNING
+ # The configure script is NOT what you expect
+ emake || die "emake failed"
+ emake doc/snobol4.1 || die "emake doc/snobol4.1 failed"
+}
+
+src_install() {
+ into /usr
+ newbin xsnobol4 snobol4
+ dodir /usr/lib/snobol4
+ insinto /usr/lib/snobol4
+ doins snolib.a snolib/bq.sno
+
+ doman doc/*.1
+ dohtml doc/*.html
+ rm doc/*.html
+ dodoc doc/*.ps doc/*.doc
+}