summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-03 01:33:00 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-03 01:33:00 +0000
commit45bebae12c501c4892b292befe41da30a910f016 (patch)
tree0fd09dac8ca5b9e66cb8fe6d0c5a1f3f912ff4cb /dev-lang/tcl
parentarm/hppa/ia64/s390/sh stable (diff)
downloadgentoo-2-45bebae12c501c4892b292befe41da30a910f016.tar.gz
gentoo-2-45bebae12c501c4892b292befe41da30a910f016.tar.bz2
gentoo-2-45bebae12c501c4892b292befe41da30a910f016.zip
Fix nls breakage #120133 by J.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'dev-lang/tcl')
-rw-r--r--dev-lang/tcl/ChangeLog7
-rw-r--r--dev-lang/tcl/files/tcl-configure-LANG.patch41
-rw-r--r--dev-lang/tcl/tcl-8.4.11-r1.ebuild9
-rw-r--r--dev-lang/tcl/tcl-8.4.11.ebuild10
-rw-r--r--dev-lang/tcl/tcl-8.4.9.ebuild10
5 files changed, 71 insertions, 6 deletions
diff --git a/dev-lang/tcl/ChangeLog b/dev-lang/tcl/ChangeLog
index 9663b2e60a6c..54cffa664161 100644
--- a/dev-lang/tcl/ChangeLog
+++ b/dev-lang/tcl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/tcl
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.61 2006/01/18 20:15:30 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.62 2006/02/03 01:33:00 vapier Exp $
+
+ 03 Feb 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/tcl-configure-LANG.patch, tcl-8.4.9.ebuild, tcl-8.4.11.ebuild,
+ tcl-8.4.11-r1.ebuild:
+ Fix nls breakage #120133 by J.
18 Jan 2006; Simon Stelling <blubb@gentoo.org> tcl-8.4.11-r1.ebuild:
add missing multilib inherit
diff --git a/dev-lang/tcl/files/tcl-configure-LANG.patch b/dev-lang/tcl/files/tcl-configure-LANG.patch
new file mode 100644
index 000000000000..3ef76ef911c0
--- /dev/null
+++ b/dev-lang/tcl/files/tcl-configure-LANG.patch
@@ -0,0 +1,41 @@
+The LANG vars aren't reset early enough so when sed tries to use [a-zA-Z] in
+option parsing, it may break.
+
+http://bugs.gentoo.org/103483
+
+--- configure
++++ configure
+@@ -54,6 +54,16 @@
+ infodir='${prefix}/info'
+ mandir='${prefix}/man'
+
++# NLS nuisances.
++# Only set these to C if already set. These must not be set unconditionally
++# because not all systems understand e.g. LANG=C (notably SCO).
++# Fixing LC_MESSAGES prevents Solaris sh from translating var values in `set'!
++# Non-C LC_CTYPE values break the ctype check.
++if test "${LANG+set}" = set; then LANG=C; export LANG; fi
++if test "${LC_ALL+set}" = set; then LC_ALL=C; export LC_ALL; fi
++if test "${LC_MESSAGES+set}" = set; then LC_MESSAGES=C; export LC_MESSAGES; fi
++if test "${LC_CTYPE+set}" = set; then LC_CTYPE=C; export LC_CTYPE; fi
++
+ # Initialize some other variables.
+ subdirs=
+ MFLAGS= MAKEFLAGS=
+@@ -452,16 +463,6 @@
+ esac
+ done
+
+-# NLS nuisances.
+-# Only set these to C if already set. These must not be set unconditionally
+-# because not all systems understand e.g. LANG=C (notably SCO).
+-# Fixing LC_MESSAGES prevents Solaris sh from translating var values in `set'!
+-# Non-C LC_CTYPE values break the ctype check.
+-if test "${LANG+set}" = set; then LANG=C; export LANG; fi
+-if test "${LC_ALL+set}" = set; then LC_ALL=C; export LC_ALL; fi
+-if test "${LC_MESSAGES+set}" = set; then LC_MESSAGES=C; export LC_MESSAGES; fi
+-if test "${LC_CTYPE+set}" = set; then LC_CTYPE=C; export LC_CTYPE; fi
+-
+ # confdefs.h avoids OS command line length limits that DEFS can exceed.
+ rm -rf conftest* confdefs.h
+ # AIX cpp loses on an empty file, so make sure it contains at least a newline.
diff --git a/dev-lang/tcl/tcl-8.4.11-r1.ebuild b/dev-lang/tcl/tcl-8.4.11-r1.ebuild
index 554222347310..64eaf93df92d 100644
--- a/dev-lang/tcl/tcl-8.4.11-r1.ebuild
+++ b/dev-lang/tcl/tcl-8.4.11-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.11-r1.ebuild,v 1.2 2006/01/18 20:15:30 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.11-r1.ebuild,v 1.3 2006/02/03 01:33:00 vapier Exp $
inherit eutils multilib
@@ -38,6 +38,13 @@ src_unpack() {
# bug 117744
sed -i -e "s/relid'/relid/" "${S}"/unix/{configure,tcl.m4} || die
+
+ local d
+ for d in */configure ; do
+ cd "${S}"/${d%%/*}
+ EPATCH_SINGLE_MSG="Patching nls cruft in ${d}" \
+ epatch "${FILESDIR}"/tcl-configure-LANG.patch
+ done
}
src_compile() {
diff --git a/dev-lang/tcl/tcl-8.4.11.ebuild b/dev-lang/tcl/tcl-8.4.11.ebuild
index 48c26dc3c45c..ea44baf00924 100644
--- a/dev-lang/tcl/tcl-8.4.11.ebuild
+++ b/dev-lang/tcl/tcl-8.4.11.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.11.ebuild,v 1.2 2005/07/02 15:25:52 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.11.ebuild,v 1.3 2006/02/03 01:33:00 vapier Exp $
inherit eutils
@@ -35,6 +35,12 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-multilib.patch
+ local d
+ for d in */configure ; do
+ cd "${S}"/${d%%/*}
+ EPATCH_SINGLE_MSG="Patching nls cruft in ${d}" \
+ epatch "${FILESDIR}"/tcl-configure-LANG.patch
+ done
}
src_compile() {
diff --git a/dev-lang/tcl/tcl-8.4.9.ebuild b/dev-lang/tcl/tcl-8.4.9.ebuild
index 3b33e703c0f0..3fd261aefa2c 100644
--- a/dev-lang/tcl/tcl-8.4.9.ebuild
+++ b/dev-lang/tcl/tcl-8.4.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.9.ebuild,v 1.11 2005/08/03 22:08:10 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.9.ebuild,v 1.12 2006/02/03 01:33:00 vapier Exp $
inherit eutils multilib
@@ -34,6 +34,12 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${PN}-8.4.6-multilib.patch
+ local d
+ for d in */configure ; do
+ cd "${S}"/${d%%/*}
+ EPATCH_SINGLE_MSG="Patching nls cruft in ${d}" \
+ epatch "${FILESDIR}"/tcl-configure-LANG.patch
+ done
}
src_compile() {