summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-10 09:37:35 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-10 09:37:35 +0000
commitbc72ab83682d8fa057f4ec2313e63f4f41e914d4 (patch)
tree930ad7fe6a40a96d78cd5222d565f23efdaf7d6b /dev-lang/tcl
parentAdd missing tzinfo to the test dependencies, bug 455036. (diff)
downloadgentoo-2-bc72ab83682d8fa057f4ec2313e63f4f41e914d4.tar.gz
gentoo-2-bc72ab83682d8fa057f4ec2313e63f4f41e914d4.tar.bz2
gentoo-2-bc72ab83682d8fa057f4ec2313e63f4f41e914d4.zip
dev-lang/tcl: Drop old fixes #280934
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'dev-lang/tcl')
-rw-r--r--dev-lang/tcl/ChangeLog6
-rw-r--r--dev-lang/tcl/tcl-8.4.19.ebuild119
-rw-r--r--dev-lang/tcl/tcl-8.5.11-r1.ebuild124
-rw-r--r--dev-lang/tcl/tcl-8.5.13.ebuild130
4 files changed, 5 insertions, 374 deletions
diff --git a/dev-lang/tcl/ChangeLog b/dev-lang/tcl/ChangeLog
index 965f3fa44c8d..a079f806d1f3 100644
--- a/dev-lang/tcl/ChangeLog
+++ b/dev-lang/tcl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/tcl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.168 2013/01/11 16:50:05 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.169 2013/02/10 09:37:35 jlec Exp $
+
+ 10 Feb 2013; Justin Lecher <jlec@gentoo.org> -tcl-8.4.19.ebuild,
+ -tcl-8.5.11-r1.ebuild, -tcl-8.5.13.ebuild:
+ Drop old fixes #280934
11 Jan 2013; Fabian Groffen <grobian@gentoo.org> tcl-8.6.0-r1.ebuild:
Fix CFLAGS fix not to leave a single s behind (in case of -Os)
diff --git a/dev-lang/tcl/tcl-8.4.19.ebuild b/dev-lang/tcl/tcl-8.4.19.ebuild
deleted file mode 100644
index b7b4826e2712..000000000000
--- a/dev-lang/tcl/tcl-8.4.19.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.19.ebuild,v 1.6 2012/12/05 08:51:01 ulm Exp $
-
-inherit autotools eutils multilib toolchain-funcs
-
-DESCRIPTION="Tool Command Language"
-HOMEPAGE="http://www.tcl.tk/"
-SRC_URI="mirror://sourceforge/tcl/${PN}${PV}-src.tar.gz"
-
-LICENSE="tcltk"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="debug threads"
-
-S="${WORKDIR}/${PN}${PV}"
-
-pkg_setup() {
- if use threads ; then
- ewarn ""
- ewarn "PLEASE NOTE: You are compiling ${P} with"
- ewarn "threading enabled."
- ewarn "Threading is not supported by all applications"
- ewarn "that compile against tcl. You use threading at"
- ewarn "your own discretion."
- ewarn ""
- epause 5
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-8.4.16-multilib.patch
-
- # Bug 125971
- epatch "${FILESDIR}"/${PN}-8.4.15-tclm4-soname.patch
- # cross-compile fix from buildroot.
- epatch "${FILESDIR}"/${PN}-8.4.9-strtod.patch
-
- local d
- for d in */configure ; do
- cd "${S}"/${d%%/*}
- EPATCH_SINGLE_MSG="Patching nls cruft in ${d}" \
- epatch "${FILESDIR}"/tcl-configure-LANG.patch
- done
-
- cd "${S}"/unix
- eautoreconf
-}
-
-src_compile() {
- tc-export CC
- local local_config_use=""
-
- if use threads ; then
- local_config_use="--enable-threads"
- fi
-
- cd "${S}"/unix
- econf \
- $(use_enable threads) \
- $(use_enable debug symbols)
- emake || die
-}
-
-src_install() {
- #short version number
- local v1
- v1=${PV%.*}
-
- cd "${S}"/unix
- S= emake DESTDIR="${D}" install || die
-
- # fix the tclConfig.sh to eliminate refs to the build directory
- local mylibdir=$(get_libdir) ; mylibdir=${mylibdir//\/}
- sed -i \
- -e "s,^TCL_BUILD_LIB_SPEC='-L.*/unix,TCL_BUILD_LIB_SPEC='-L$/usr/${mylibdir}," \
- -e "s,^TCL_SRC_DIR='.*',TCL_SRC_DIR='/usr/${mylibdir}/tcl${v1}/include'," \
- -e "s,^TCL_BUILD_STUB_LIB_SPEC='-L.*/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/${mylibdir}," \
- -e "s,^TCL_BUILD_STUB_LIB_PATH='.*/unix,TCL_BUILD_STUB_LIB_PATH='/usr/${mylibdir}," \
- -e "s,^TCL_LIB_FILE='libtcl${v1}..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl${v1}\$\{TCL_DBGX\}.so\"," \
- -e "s,^TCL_CC_SEARCH_FLAGS='\(.*\)',TCL_CC_SEARCH_FLAGS='\1:/usr/${mylibdir}'," \
- -e "s,^TCL_LD_SEARCH_FLAGS='\(.*\)',TCL_LD_SEARCH_FLAGS='\1:/usr/${mylibdir}'," \
- "${D}"/usr/${mylibdir}/tclConfig.sh || die
-
- # install private headers
- insinto /usr/${mylibdir}/tcl${v1}/include/unix
- doins "${S}"/unix/*.h || die
- insinto /usr/${mylibdir}/tcl${v1}/include/generic
- doins "${S}"/generic/*.h || die
- rm -f "${D}"/usr/${mylibdir}/tcl${v1}/include/generic/tcl.h
- rm -f "${D}"/usr/${mylibdir}/tcl${v1}/include/generic/tclDecls.h
- rm -f "${D}"/usr/${mylibdir}/tcl${v1}/include/generic/tclPlatDecls.h
-
- # install symlink for libraries
- if use debug ; then
- dosym libtcl${v1}g.so /usr/${mylibdir}/libtcl${v1}.so
- dosym libtclstub${v1}g.a /usr/${mylibdir}/libtclstub${v1}.a
- fi
- dosym libtcl${v1}.so /usr/${mylibdir}/libtcl.so
- dosym libtclstub${v1}.a /usr/${mylibdir}/libtclstub.a
-
- dosym tclsh${v1} /usr/bin/tclsh
-
- cd "${S}"
- dodoc ChangeLog* README changes
-}
-
-pkg_postinst() {
- ewarn
- ewarn "If you're upgrading from tcl-8.3, you must recompile the other"
- ewarn "packages on your system that link with tcl after the upgrade"
- ewarn "completes. To perform this action, please run revdep-rebuild"
- ewarn "in package app-portage/gentoolkit."
- ewarn "If you have dev-lang/tk and dev-tcltk/tclx installed you should"
- ewarn "upgrade them before this recompilation, too,"
- ewarn
-}
diff --git a/dev-lang/tcl/tcl-8.5.11-r1.ebuild b/dev-lang/tcl/tcl-8.5.11-r1.ebuild
deleted file mode 100644
index c97e31131acc..000000000000
--- a/dev-lang/tcl/tcl-8.5.11-r1.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.5.11-r1.ebuild,v 1.2 2012/12/05 08:51:01 ulm Exp $
-
-EAPI=4
-
-inherit versionator autotools eutils flag-o-matic multilib toolchain-funcs
-
-MY_P="${PN}${PV/_beta/b}"
-
-DESCRIPTION="Tool Command Language"
-HOMEPAGE="http://www.tcl.tk/"
-SRC_URI="mirror://sourceforge/tcl/${MY_P}-src.tar.gz"
-
-LICENSE="tcltk"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x86-solaris"
-IUSE="debug threads"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- if use threads ; then
- echo
- ewarn "PLEASE NOTE: You are compiling ${P} with"
- ewarn "threading enabled."
- ewarn "Threading is not supported by all applications"
- ewarn "that compile against tcl. You use threading at"
- ewarn "your own discretion."
- echo
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-8.5_alpha6-multilib.patch
-
- # Bug 125971
- epatch "${FILESDIR}"/${PN}-8.5_alpha6-tclm4-soname.patch
-
- # Bug 354067
- epatch "${FILESDIR}"/${PN}-8.5.9-gentoo-fbsd.patch
-
- cd "${S}"/unix
- eautoreconf
-}
-
-src_configure() {
- # workaround stack check issues, bug #280934
- if use hppa; then
- append-cflags "-DTCL_NO_STACK_CHECK=1"
- fi
-
- tc-export CC
-
- cd "${S}"/unix
- econf \
- $(use_enable threads) \
- $(use_enable debug symbols)
-}
-
-src_compile() {
- cd "${S}"/unix && emake
-}
-
-src_install() {
- #short version number
- local v1
- v1=${PV%.*}
-
- cd "${S}"/unix
- S= emake DESTDIR="${D}" install
-
- # fix the tclConfig.sh to eliminate refs to the build directory
- # and drop unnecessary -L inclusion to default system libdir
- local mylibdir=$(get_libdir) ; mylibdir=${mylibdir//\/}
- sed -i \
- -e "s,^TCL_BUILD_LIB_SPEC='-L.*/unix ,TCL_BUILD_LIB_SPEC='," \
- -e "s,^TCL_SRC_DIR='.*',TCL_SRC_DIR='${EPREFIX}/usr/${mylibdir}/tcl${v1}/include'," \
- -e "s,^TCL_BUILD_STUB_LIB_SPEC='-L.*/unix ,TCL_BUILD_STUB_LIB_SPEC='," \
- -e "s,^TCL_BUILD_STUB_LIB_PATH='.*/unix,TCL_BUILD_STUB_LIB_PATH='${EPREFIX}/usr/${mylibdir}," \
- -e "s,^TCL_LIB_FILE='libtcl${v1}..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl${v1}\$\{TCL_DBGX\}.so\"," \
- -e "s,^TCL_STUB_LIB_SPEC='-L${EPREFIX}/usr/${mylibdir} ,TCL_STUB_LIB_SPEC='," \
- -e "s,^TCL_LIB_SPEC='-L${EPREFIX}/usr/${mylibdir} ,TCL_LIB_SPEC='," \
- "${ED}"/usr/${mylibdir}/tclConfig.sh || die
- if [[ ${CHOST} != *-darwin* && ${CHOST} != *-mint* ]] ; then
- sed -i \
- -e "s,^TCL_CC_SEARCH_FLAGS='\(.*\)',TCL_CC_SEARCH_FLAGS='\1:${EPREFIX}/usr/${mylibdir}'," \
- -e "s,^TCL_LD_SEARCH_FLAGS='\(.*\)',TCL_LD_SEARCH_FLAGS='\1:${EPREFIX}/usr/${mylibdir}'," \
- "${ED}"/usr/${mylibdir}/tclConfig.sh || die
- fi
-
- # install private headers
- insinto /usr/${mylibdir}/tcl${v1}/include/unix
- doins "${S}"/unix/*.h
- insinto /usr/${mylibdir}/tcl${v1}/include/generic
- doins "${S}"/generic/*.h
- rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/tcl.h || die
- rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/tclDecls.h || die
- rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/tclPlatDecls.h || die
-
- # install symlink for libraries
- dosym libtcl${v1}$(get_libname) /usr/${mylibdir}/libtcl$(get_libname)
- dosym libtclstub${v1}.a /usr/${mylibdir}/libtclstub.a
-
- dosym tclsh${v1} /usr/bin/tclsh
-
- cd "${S}"
- dodoc ChangeLog* README changes
-}
-
-pkg_postinst() {
- for version in ${REPLACING_VERSIONS}; do
- if ! version_is_at_least 8.5 ${version}; then
- echo
- ewarn "You're upgrading from <dev-lang/tcl-8.5, you must recompile the other"
- ewarn "packages on your system that link with tcl after the upgrade"
- ewarn "completes. To perform this action, please run revdep-rebuild"
- ewarn "in package app-portage/gentoolkit."
- ewarn "If you have dev-lang/tk and dev-tcltk/tclx installed you should"
- ewarn "upgrade them before this recompilation, too,"
- echo
- fi
- done
-}
diff --git a/dev-lang/tcl/tcl-8.5.13.ebuild b/dev-lang/tcl/tcl-8.5.13.ebuild
deleted file mode 100644
index 23347333f53e..000000000000
--- a/dev-lang/tcl/tcl-8.5.13.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.5.13.ebuild,v 1.4 2012/12/05 08:51:01 ulm Exp $
-
-EAPI=4
-
-inherit versionator autotools eutils flag-o-matic multilib toolchain-funcs
-
-MY_P="${PN}${PV/_beta/b}"
-
-DESCRIPTION="Tool Command Language"
-HOMEPAGE="http://www.tcl.tk/"
-SRC_URI="mirror://sourceforge/tcl/${MY_P}-src.tar.gz"
-
-LICENSE="tcltk"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x86-solaris"
-IUSE="debug threads"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- if use threads ; then
- echo
- ewarn "PLEASE NOTE: You are compiling ${P} with"
- ewarn "threading enabled."
- ewarn "Threading is not supported by all applications"
- ewarn "that compile against tcl. You use threading at"
- ewarn "your own discretion."
- echo
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-8.5_alpha6-multilib.patch
-
- # Bug 125971
- epatch "${FILESDIR}"/${PN}-8.5.10-conf.patch
-
- # Bug 354067
- epatch "${FILESDIR}"/${PN}-8.5.9-gentoo-fbsd.patch
-
- epatch "${FILESDIR}"/${P}-autopath.patch
-
- cd "${S}"/unix
- eautoreconf
-}
-
-src_configure() {
- # workaround stack check issues, bug #280934
- if use hppa; then
- append-cflags "-DTCL_NO_STACK_CHECK=1"
- fi
-
- tc-export CC
-
- cd "${S}"/unix
- econf \
- $(use_enable threads) \
- $(use_enable debug symbols)
-}
-
-src_compile() {
- cd "${S}"/unix && emake
-}
-
-src_test() {
- cd "${S}"/unix && emake test
-}
-
-src_install() {
- #short version number
- local v1
- v1=${PV%.*}
-
- cd "${S}"/unix
- S= emake DESTDIR="${D}" install
-
- # fix the tclConfig.sh to eliminate refs to the build directory
- # and drop unnecessary -L inclusion to default system libdir
- local mylibdir=$(get_libdir) ; mylibdir=${mylibdir//\/}
- sed -i \
- -e "s,^TCL_BUILD_LIB_SPEC='-L.*/unix ,TCL_BUILD_LIB_SPEC='," \
- -e "s,^TCL_SRC_DIR='.*',TCL_SRC_DIR='${EPREFIX}/usr/${mylibdir}/tcl${v1}/include'," \
- -e "s,^TCL_BUILD_STUB_LIB_SPEC='-L.*/unix ,TCL_BUILD_STUB_LIB_SPEC='," \
- -e "s,^TCL_BUILD_STUB_LIB_PATH='.*/unix,TCL_BUILD_STUB_LIB_PATH='${EPREFIX}/usr/${mylibdir}," \
- -e "s,^TCL_LIB_FILE='libtcl${v1}..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl${v1}\$\{TCL_DBGX\}.so\"," \
- -e "s,^TCL_STUB_LIB_SPEC='-L${EPREFIX}/usr/${mylibdir} ,TCL_STUB_LIB_SPEC='," \
- -e "s,^TCL_LIB_SPEC='-L${EPREFIX}/usr/${mylibdir} ,TCL_LIB_SPEC='," \
- "${ED}"/usr/${mylibdir}/tclConfig.sh || die
- if [[ ${CHOST} != *-darwin* && ${CHOST} != *-mint* ]] ; then
- sed -i \
- -e "s,^TCL_CC_SEARCH_FLAGS='\(.*\)',TCL_CC_SEARCH_FLAGS='\1:${EPREFIX}/usr/${mylibdir}'," \
- -e "s,^TCL_LD_SEARCH_FLAGS='\(.*\)',TCL_LD_SEARCH_FLAGS='\1:${EPREFIX}/usr/${mylibdir}'," \
- "${ED}"/usr/${mylibdir}/tclConfig.sh || die
- fi
-
- # install private headers
- insinto /usr/${mylibdir}/tcl${v1}/include/unix
- doins "${S}"/unix/*.h
- insinto /usr/${mylibdir}/tcl${v1}/include/generic
- doins "${S}"/generic/*.h
- rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/tcl.h || die
- rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/tclDecls.h || die
- rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/tclPlatDecls.h || die
-
- # install symlink for libraries
- dosym libtcl${v1}$(get_libname) /usr/${mylibdir}/libtcl$(get_libname)
- dosym libtclstub${v1}.a /usr/${mylibdir}/libtclstub.a
-
- dosym tclsh${v1} /usr/bin/tclsh
-
- cd "${S}"
- dodoc ChangeLog* README changes
-}
-
-pkg_postinst() {
- for version in ${REPLACING_VERSIONS}; do
- if ! version_is_at_least 8.5 ${version}; then
- echo
- ewarn "You're upgrading from <dev-lang/tcl-8.5, you must recompile the other"
- ewarn "packages on your system that link with tcl after the upgrade"
- ewarn "completes. To perform this action, please run revdep-rebuild"
- ewarn "in package app-portage/gentoolkit."
- ewarn "If you have dev-lang/tk and dev-tcltk/tclx installed you should"
- ewarn "upgrade them before this recompilation, too,"
- echo
- fi
- done
-}