summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-01-07 14:20:28 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-01-07 14:20:28 +0000
commit84c2f47eacc905aacd7e4ab60a4ef3a3c0448898 (patch)
treec2f7c4789876513873453c18660ef94cf9c2fc3b /dev-lang/tk
parentBump for #297448 (diff)
downloadgentoo-2-84c2f47eacc905aacd7e4ab60a4ef3a3c0448898.tar.gz
gentoo-2-84c2f47eacc905aacd7e4ab60a4ef3a3c0448898.tar.bz2
gentoo-2-84c2f47eacc905aacd7e4ab60a4ef3a3c0448898.zip
Bump for #297448
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/tk')
-rw-r--r--dev-lang/tk/ChangeLog9
-rw-r--r--dev-lang/tk/tk-8.5.8.ebuild109
2 files changed, 116 insertions, 2 deletions
diff --git a/dev-lang/tk/ChangeLog b/dev-lang/tk/ChangeLog
index db092753e1e6..e1581c993636 100644
--- a/dev-lang/tk/ChangeLog
+++ b/dev-lang/tk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/tk
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.131 2009/10/07 15:33:02 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.132 2010/01/07 14:20:28 patrick Exp $
+
+*tk-8.5.8 (07 Jan 2010)
+
+ 07 Jan 2010; Patrick Lauer <patrick@gentoo.org> +tk-8.5.8.ebuild:
+ Bump for #297448
07 Oct 2009; Raúl Porcel <armin76@gentoo.org> tk-8.5.7.ebuild:
ia64/s390/sh/sparc stable wrt #280845
diff --git a/dev-lang/tk/tk-8.5.8.ebuild b/dev-lang/tk/tk-8.5.8.ebuild
new file mode 100644
index 000000000000..24ece4d99e00
--- /dev/null
+++ b/dev-lang/tk/tk-8.5.8.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.5.8.ebuild,v 1.1 2010/01/07 14:20:28 patrick Exp $
+
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=latest
+
+inherit autotools eutils multilib toolchain-funcs
+
+MY_P="${PN}${PV/_beta/b}"
+DESCRIPTION="Tk Widget Set"
+HOMEPAGE="http://www.tcl.tk/"
+SRC_URI="mirror://sourceforge/tcl/${MY_P}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug threads truetype"
+
+RDEPEND="x11-libs/libX11
+ ~dev-lang/tcl-${PV}"
+DEPEND="${RDEPEND}
+ truetype? ( x11-libs/libXft )
+ x11-libs/libXt
+ x11-proto/xproto"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use threads ; then
+ ewarn ""
+ ewarn "PLEASE NOTE: You are compiling ${P} with"
+ ewarn "threading enabled."
+ ewarn "Threading is not supported by all applications"
+ ewarn "that compile against tcl. You use threading at"
+ ewarn "your own discretion."
+ ewarn ""
+ epause 5
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-8.4.11-multilib.patch
+
+ # Bug 125971
+ epatch "${FILESDIR}"/${PN}-8.5_alpha6-tclm4-soname.patch
+
+ cd "${S}"/unix
+ eautoreconf
+}
+
+src_compile() {
+ tc-export CC
+ cd "${S}"/unix
+
+ local mylibdir=$(get_libdir) ; mylibdir=${mylibdir//\/}
+
+ econf \
+ --with-tcl=/usr/${mylibdir} \
+ $(use_enable threads) \
+ $(use_enable truetype xft) \
+ $(use_enable debug symbols) || die
+
+ emake || die
+}
+
+src_install() {
+ #short version number
+ local v1
+ v1=${PV%.*}
+
+ cd "${S}"/unix
+ S= emake DESTDIR="${D}" install || die
+
+ # normalize $S path, bug #280766 (pkgcore)
+ local nS="$(cd "${S}"; pwd)"
+
+ # fix the tkConfig.sh to eliminate refs to the build directory
+ local mylibdir=$(get_libdir) ; mylibdir=${mylibdir//\/}
+ sed -i \
+ -e "s,^\(TK_BUILD_LIB_SPEC='-L\)${nS}/unix,\1/usr/${mylibdir}," \
+ -e "s,^\(TK_SRC_DIR='\)${nS}',\1/usr/${mylibdir}/tk${v1}/include'," \
+ -e "s,^\(TK_BUILD_STUB_LIB_SPEC='-L\)${nS}/unix,\1/usr/${mylibdir}," \
+ -e "s,^\(TK_BUILD_STUB_LIB_PATH='\)${nS}/unix,\1/usr/${mylibdir}," \
+ -e "s,^\(TK_CC_SEARCH_FLAGS='.*\)',\1:/usr/${mylibdir}'," \
+ -e "s,^\(TK_LD_SEARCH_FLAGS='.*\)',\1:/usr/${mylibdir}'," \
+ "${D}"/usr/${mylibdir}/tkConfig.sh || die
+
+ # install private headers
+ insinto /usr/${mylibdir}/tk${v1}/include/unix
+ doins "${S}"/unix/*.h || die
+ insinto /usr/${mylibdir}/tk${v1}/include/generic
+ doins "${S}"/generic/*.h || die
+ rm -f "${D}"/usr/${mylibdir}/tk${v1}/include/generic/tk.h
+ rm -f "${D}"/usr/${mylibdir}/tk${v1}/include/generic/tkDecls.h
+ rm -f "${D}"/usr/${mylibdir}/tk${v1}/include/generic/tkPlatDecls.h
+
+ # install symlink for libraries
+ #dosym libtk${v1}.a /usr/${mylibdir}/libtk.a
+ dosym libtk${v1}.so /usr/${mylibdir}/libtk.so
+ dosym libtkstub${v1}.a /usr/${mylibdir}/libtkstub.a
+
+ dosym wish${v1} /usr/bin/wish
+
+ cd "${S}"
+ dodoc ChangeLog* README changes
+}