summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-28 06:06:49 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-28 06:06:49 +0000
commit712f5c74a28a9af402670952c0d9b14fd7a1c968 (patch)
tree4aab4117b1391a8056c7661fd9eeb1e91986884a /dev-lang/tolua
parentdont use $CC (diff)
downloadgentoo-2-712f5c74a28a9af402670952c0d9b14fd7a1c968.tar.gz
gentoo-2-712f5c74a28a9af402670952c0d9b14fd7a1c968.tar.bz2
gentoo-2-712f5c74a28a9af402670952c0d9b14fd7a1c968.zip
dont use $CC
Diffstat (limited to 'dev-lang/tolua')
-rw-r--r--dev-lang/tolua/tolua-5.0.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-lang/tolua/tolua-5.0.ebuild b/dev-lang/tolua/tolua-5.0.ebuild
index dfc53eb2511e..b066995a9101 100644
--- a/dev-lang/tolua/tolua-5.0.ebuild
+++ b/dev-lang/tolua/tolua-5.0.ebuild
@@ -1,14 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tolua/tolua-5.0.ebuild,v 1.4 2004/04/19 02:05:56 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tolua/tolua-5.0.ebuild,v 1.5 2004/04/28 06:06:49 vapier Exp $
+
+inherit gcc
DESCRIPTION="a tool that simplifies the integration of C/C++ code with Lua"
HOMEPAGE="http://www.tecgraf.puc-rio.br/~celes/tolua/"
SRC_URI="ftp://ftp.tecgraf.puc-rio.br/pub/users/celes/tolua/${P}.tar.gz"
-KEYWORDS="x86 ~sparc"
LICENSE="as-is"
SLOT="0"
+KEYWORDS="x86 ~sparc"
IUSE=""
DEPEND=">=sys-apps/sed-4"
@@ -18,7 +20,7 @@ src_unpack() {
cd ${S}
sed -i \
- -e "/^CC=/ s/=.*/=${CC}/" \
+ -e "/^CC=/ s/=.*/=$(gcc-getCC)/" \
-e "/^LUA=/ s:=.*:=/usr:" \
-e 's/^\(LIB=.*\)/\1 -ldl/' \
-e "s:-O2:${CFLAGS}:" config || \
@@ -33,7 +35,7 @@ src_compile() {
}
src_install() {
- dobin bin/tolua
+ dobin bin/tolua || die
dolib.a lib/libtolua.a
insinto /usr/include
doins include/tolua.h