summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2010-11-12 11:41:39 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2010-11-12 11:41:39 +0000
commit09a1d23996fb02020ac6232b228c1cc8d994f82a (patch)
tree7fb1de86639d55f7339288e323466ebe0748c56e /dev-lang/v8
parentadd some extra ensures it's aqbanking 4 we are merging, propably unnecessary... (diff)
downloadgentoo-2-09a1d23996fb02020ac6232b228c1cc8d994f82a.tar.gz
gentoo-2-09a1d23996fb02020ac6232b228c1cc8d994f82a.tar.bz2
gentoo-2-09a1d23996fb02020ac6232b228c1cc8d994f82a.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'dev-lang/v8')
-rw-r--r--dev-lang/v8/ChangeLog7
-rw-r--r--dev-lang/v8/v8-2.4.9.13.ebuild79
2 files changed, 85 insertions, 1 deletions
diff --git a/dev-lang/v8/ChangeLog b/dev-lang/v8/ChangeLog
index 367cc4614f94..98a85318b00b 100644
--- a/dev-lang/v8/ChangeLog
+++ b/dev-lang/v8/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/v8
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.12 2010/11/11 11:06:41 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.13 2010/11/12 11:41:39 phajdan.jr Exp $
+
+*v8-2.4.9.13 (12 Nov 2010)
+
+ 12 Nov 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> +v8-2.4.9.13.ebuild:
+ Version bump.
11 Nov 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> v8-2.5.4.ebuild:
Switch from svn checkout to a tarball.
diff --git a/dev-lang/v8/v8-2.4.9.13.ebuild b/dev-lang/v8/v8-2.4.9.13.ebuild
new file mode 100644
index 000000000000..b8628a56de23
--- /dev/null
+++ b/dev-lang/v8/v8-2.4.9.13.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-2.4.9.13.ebuild,v 1.1 2010/11/12 11:41:39 phajdan.jr Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic multilib scons-utils toolchain-funcs
+
+DESCRIPTION="Google's open source JavaScript engine"
+HOMEPAGE="http://code.google.com/p/v8"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="readline"
+
+RDEPEND="readline? ( >=sys-libs/readline-6.1 )"
+DEPEND="${RDEPEND}"
+
+EXTRA_ESCONS="library=shared soname=on importenv=\"LINKFLAGS\""
+
+pkg_setup() {
+ tc-export AR CC CXX RANLIB
+
+ # Make the build respect LDFLAGS.
+ export LINKFLAGS="${LDFLAGS}"
+}
+
+src_prepare() {
+ # Stop -Werror from breaking the build.
+ epatch "${FILESDIR}"/${PN}-no-werror-r0.patch
+
+ # Respect the user's CFLAGS, including the optimization level.
+ epatch "${FILESDIR}"/${PN}-no-O3-r0.patch
+
+ # Remove a test that is known to fail:
+ # http://groups.google.com/group/v8-users/browse_thread/thread/b8a3f42b5aa18d06
+ rm test/mjsunit/debug-script.js || die
+}
+
+src_configure() {
+ # GCC issues multiple warnings about strict-aliasing issues in v8 code.
+ append-flags -fno-strict-aliasing
+}
+
+src_compile() {
+ local myconf=""
+
+ # Use target arch detection logic from bug #296917.
+ local myarch="$ABI"
+ [[ $myarch = "" ]] && myarch="$ARCH"
+
+ if [[ $myarch = amd64 ]] ; then
+ myconf+=" arch=x64"
+ elif [[ $myarch = x86 ]] ; then
+ myconf+=" arch=ia32"
+ else
+ die "Failed to determine target arch, got '$myarch'."
+ fi
+
+ escons $(use_scons readline console readline dumb) ${myconf} . || die
+}
+
+src_install() {
+ insinto /usr
+ doins -r include || die
+
+ dobin d8 || die
+
+ dolib libv8-${PV}.so || die
+ dosym libv8-${PV}.so /usr/$(get_libdir)/libv8.so || die
+
+ dodoc AUTHORS ChangeLog || die
+}
+
+src_test() {
+ tools/test.py --no-build -p dots --shell d8 || die
+}