summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2010-10-31 09:26:32 +0000
committerOle Markus With <olemarkus@gentoo.org>2010-10-31 09:26:32 +0000
commit0b1d1dc4df225fe6cb4e981ab9cb2e69d5dd058f (patch)
tree0bced5a420e11b5f316cde3448369d74eb888211 /dev-lang
parentVersion bump (diff)
downloadgentoo-2-0b1d1dc4df225fe6cb4e981ab9cb2e69d5dd058f.tar.gz
gentoo-2-0b1d1dc4df225fe6cb4e981ab9cb2e69d5dd058f.tar.bz2
gentoo-2-0b1d1dc4df225fe6cb4e981ab9cb2e69d5dd058f.zip
Fixed a QA issue related to nonexisting SAPIs
(Portage version: 2.1.9.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/php/ChangeLog5
-rw-r--r--dev-lang/php/files/eblits/pkg_postinst-v2.eblit10
2 files changed, 10 insertions, 5 deletions
diff --git a/dev-lang/php/ChangeLog b/dev-lang/php/ChangeLog
index 74d119aad786..f35cd2292364 100644
--- a/dev-lang/php/ChangeLog
+++ b/dev-lang/php/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/php
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.429 2010/10/30 21:41:10 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.430 2010/10/31 09:26:32 olemarkus Exp $
+
+ 31 Oct 2010; <olemarkus@gentoo.org> files/eblits/pkg_postinst-v2.eblit:
+ Fixed a QA issue related to nonexisting SAPIs
30 Oct 2010; <olemarkus@gentoo.org> files/eblits/pkg_postinst-v2.eblit,
php-5.2.14-r1.ebuild, files/eblits/src_install-v2.eblit,
diff --git a/dev-lang/php/files/eblits/pkg_postinst-v2.eblit b/dev-lang/php/files/eblits/pkg_postinst-v2.eblit
index f2c2a14da09b..f6ecdf319627 100644
--- a/dev-lang/php/files/eblits/pkg_postinst-v2.eblit
+++ b/dev-lang/php/files/eblits/pkg_postinst-v2.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/pkg_postinst-v2.eblit,v 1.4 2010/10/30 21:41:10 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/pkg_postinst-v2.eblit,v 1.5 2010/10/31 09:26:32 olemarkus Exp $
eblit-php-pkg_postinst() {
# Output some general info to the user
@@ -12,14 +12,16 @@ eblit-php-pkg_postinst() {
# Create the symlinks for php
- local m modules="cli apache2 fpm cgi"
- for m in $modules; do
+ for m in ${SAPI}; do
+ [[ ${m} == 'embed' ]] && continue;
if use $m ; then
local ci=$(eselect php show $m)
if [[ -z $ci ]]; then
eselect php set $m php${SLOT}
+ einfo "Switched ${m} to use php:${SLOT}"
+ einfo
elif [[ $ci != "php${SLOT}" ]] ; then
- elog "To switch $m to use php-${SLOT}, run"
+ elog "To switch $m to use php:${SLOT}, run"
elog " eselect php set $m php${SLOT}"
elog
fi