summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-02 18:21:49 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-02 18:21:49 +0000
commit0bb7dbd67ae23869585f5fef4e7d904dc1ffd7ec (patch)
tree5380407e4f8a3025923bf7bb107af057d9384231 /dev-lang
parentVersion bump. (diff)
downloadgentoo-2-0bb7dbd67ae23869585f5fef4e7d904dc1ffd7ec.tar.gz
gentoo-2-0bb7dbd67ae23869585f5fef4e7d904dc1ffd7ec.tar.bz2
gentoo-2-0bb7dbd67ae23869585f5fef4e7d904dc1ffd7ec.zip
Stop renaming python-config wrt bug #445592. Keep a symlink for compatibility.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog7
-rw-r--r--dev-lang/python/python-2.5.4-r5.ebuild5
-rw-r--r--dev-lang/python/python-2.6.8-r1.ebuild5
-rw-r--r--dev-lang/python/python-2.7.3-r3.ebuild5
-rw-r--r--dev-lang/python/python-3.1.5-r1.ebuild5
-rw-r--r--dev-lang/python/python-3.2.3-r2.ebuild5
-rw-r--r--dev-lang/python/python-3.3.0-r1.ebuild5
7 files changed, 24 insertions, 13 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index ab4b5df32d25..5efb63f78a59 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.624 2012/12/01 09:56:06 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.625 2012/12/02 18:21:49 mgorny Exp $
+
+ 02 Dec 2012; Michał Górny <mgorny@gentoo.org> python-2.5.4-r5.ebuild,
+ python-2.6.8-r1.ebuild, python-2.7.3-r3.ebuild, python-3.1.5-r1.ebuild,
+ python-3.2.3-r2.ebuild, python-3.3.0-r1.ebuild:
+ Stop renaming python-config wrt bug #445592. Keep a symlink for compatibility.
01 Dec 2012; Michał Górny <mgorny@gentoo.org> python-2.5.4-r5.ebuild,
python-2.6.8-r1.ebuild, python-2.7.3-r3.ebuild, python-3.1.5-r1.ebuild,
diff --git a/dev-lang/python/python-2.5.4-r5.ebuild b/dev-lang/python/python-2.5.4-r5.ebuild
index 2f9e0048fe6d..071474c5b7e6 100644
--- a/dev-lang/python/python-2.5.4-r5.ebuild
+++ b/dev-lang/python/python-2.5.4-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r5.ebuild,v 1.3 2012/12/01 09:56:06 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r5.ebuild,v 1.4 2012/12/02 18:21:49 mgorny Exp $
EAPI="1"
@@ -243,7 +243,8 @@ src_install() {
emake DESTDIR="${D}" altinstall maninstall || die "emake altinstall maninstall failed"
- mv "${ED}usr/bin/python${SLOT}-config" "${ED}usr/bin/python-config-${SLOT}"
+ # Backwards compat with Gentoo divergence.
+ dosym python${SLOT}-config /usr/bin/python-config-${SLOT} || die
# Fix collisions between different slots of Python.
mv "${ED}usr/bin/pydoc" "${ED}usr/bin/pydoc${SLOT}"
diff --git a/dev-lang/python/python-2.6.8-r1.ebuild b/dev-lang/python/python-2.6.8-r1.ebuild
index 951bb2ca9f0c..36e99317f5cd 100644
--- a/dev-lang/python/python-2.6.8-r1.ebuild
+++ b/dev-lang/python/python-2.6.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.8-r1.ebuild,v 1.3 2012/12/01 09:56:06 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.8-r1.ebuild,v 1.4 2012/12/02 18:21:49 mgorny Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -240,7 +240,8 @@ src_install() {
emake DESTDIR="${D}" altinstall maninstall || die "emake altinstall maninstall failed"
- mv "${ED}usr/bin/python${SLOT}-config" "${ED}usr/bin/python-config-${SLOT}"
+ # Backwards compat with Gentoo divergence.
+ dosym python${SLOT}-config /usr/bin/python-config-${SLOT} || die
# Fix collisions between different slots of Python.
mv "${ED}usr/bin/2to3" "${ED}usr/bin/2to3-${SLOT}"
diff --git a/dev-lang/python/python-2.7.3-r3.ebuild b/dev-lang/python/python-2.7.3-r3.ebuild
index 361a8e630e53..274b3578b315 100644
--- a/dev-lang/python/python-2.7.3-r3.ebuild
+++ b/dev-lang/python/python-2.7.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.3-r3.ebuild,v 1.3 2012/12/01 09:56:06 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.3-r3.ebuild,v 1.4 2012/12/02 18:21:49 mgorny Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -256,7 +256,8 @@ src_install() {
sed -e "s/\(LDFLAGS=\).*/\1/" -i "${libdir}/config/Makefile" || die "sed failed"
- mv "${ED}usr/bin/python${SLOT}-config" "${ED}usr/bin/python-config-${SLOT}"
+ # Backwards compat with Gentoo divergence.
+ dosym python${SLOT}-config /usr/bin/python-config-${SLOT} || die
# Fix collisions between different slots of Python.
mv "${ED}usr/bin/2to3" "${ED}usr/bin/2to3-${SLOT}"
diff --git a/dev-lang/python/python-3.1.5-r1.ebuild b/dev-lang/python/python-3.1.5-r1.ebuild
index f06675a5f83b..969e599a81c9 100644
--- a/dev-lang/python/python-3.1.5-r1.ebuild
+++ b/dev-lang/python/python-3.1.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.5-r1.ebuild,v 1.3 2012/12/01 09:56:06 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.5-r1.ebuild,v 1.4 2012/12/02 18:21:49 mgorny Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -218,7 +218,8 @@ src_install() {
emake DESTDIR="${D}" altinstall || die "emake altinstall failed"
- mv "${ED}usr/bin/python${SLOT}-config" "${ED}usr/bin/python-config-${SLOT}"
+ # Backwards compat with Gentoo divergence.
+ dosym python${SLOT}-config /usr/bin/python-config-${SLOT} || die
# Fix collisions between different slots of Python.
mv "${ED}usr/bin/2to3" "${ED}usr/bin/2to3-${SLOT}"
diff --git a/dev-lang/python/python-3.2.3-r2.ebuild b/dev-lang/python/python-3.2.3-r2.ebuild
index 93ee8dfc0965..535288998551 100644
--- a/dev-lang/python/python-3.2.3-r2.ebuild
+++ b/dev-lang/python/python-3.2.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.3-r2.ebuild,v 1.3 2012/12/01 09:56:06 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.3-r2.ebuild,v 1.4 2012/12/02 18:21:49 mgorny Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -234,7 +234,8 @@ src_install() {
-e "s/\(PY_LDFLAGS=\).*/\1/" \
-i "${libdir}/config-${SLOT}/Makefile" || die "sed failed"
- mv "${ED}usr/bin/python${SLOT}-config" "${ED}usr/bin/python-config-${SLOT}"
+ # Backwards compat with Gentoo divergence.
+ dosym python${SLOT}-config /usr/bin/python-config-${SLOT} || die
# Fix collisions between different slots of Python.
rm -f "${ED}usr/$(get_libdir)/libpython3.so"
diff --git a/dev-lang/python/python-3.3.0-r1.ebuild b/dev-lang/python/python-3.3.0-r1.ebuild
index 060dd8197a31..0687729bb3d6 100644
--- a/dev-lang/python/python-3.3.0-r1.ebuild
+++ b/dev-lang/python/python-3.3.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.3.0-r1.ebuild,v 1.3 2012/12/01 09:56:06 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.3.0-r1.ebuild,v 1.4 2012/12/02 18:21:49 mgorny Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -224,7 +224,8 @@ src_install() {
-e "s/\(PY_LDFLAGS=\).*/\1/" \
-i "${libdir}/config-${SLOT}/Makefile" || die "sed failed"
- mv "${ED}usr/bin/python${SLOT}-config" "${ED}usr/bin/python-config-${SLOT}"
+ # Backwards compat with Gentoo divergence.
+ dosym python${SLOT}-config /usr/bin/python-config-${SLOT} || die
# Fix collisions between different slots of Python.
rm -f "${ED}usr/$(get_libdir)/libpython3.so"