summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2014-10-18 12:50:48 +0000
committerJauhien Piatlicki <jauhien@gentoo.org>2014-10-18 12:50:48 +0000
commit2820178c8fd0dbfa47b6d574d75249ae990a9b27 (patch)
tree92d6445a841eb07b38aced97cd3eaf6dd406e2db /dev-lang
parentversion bump, switch to new eselect version (diff)
downloadgentoo-2-2820178c8fd0dbfa47b6d574d75249ae990a9b27.tar.gz
gentoo-2-2820178c8fd0dbfa47b6d574d75249ae990a9b27.tar.bz2
gentoo-2-2820178c8fd0dbfa47b6d574d75249ae990a9b27.zip
initila import from the rust overlay
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 0xB2EFA1D4)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust-bin/ChangeLog11
-rw-r--r--dev-lang/rust-bin/files/rust-bin-0.12.0-no-ldconfig.patch23
-rw-r--r--dev-lang/rust-bin/metadata.xml8
-rw-r--r--dev-lang/rust-bin/rust-bin-0.12.0.ebuild77
-rw-r--r--dev-lang/rust-bin/rust-bin-999.ebuild81
5 files changed, 200 insertions, 0 deletions
diff --git a/dev-lang/rust-bin/ChangeLog b/dev-lang/rust-bin/ChangeLog
new file mode 100644
index 000000000000..01f45657d733
--- /dev/null
+++ b/dev-lang/rust-bin/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-lang/rust-bin
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust-bin/ChangeLog,v 1.1 2014/10/18 12:50:48 jauhien Exp $
+
+*rust-bin-999 (18 Oct 2014)
+*rust-bin-0.12.0 (18 Oct 2014)
+
+ 18 Oct 2014; Jauhien Piatlicki <jauhien@gentoo.org>
+ +files/rust-bin-0.12.0-no-ldconfig.patch, +metadata.xml,
+ +rust-bin-0.12.0.ebuild, +rust-bin-999.ebuild:
+ initila import from the rust overlay
diff --git a/dev-lang/rust-bin/files/rust-bin-0.12.0-no-ldconfig.patch b/dev-lang/rust-bin/files/rust-bin-0.12.0-no-ldconfig.patch
new file mode 100644
index 000000000000..d4c5fd8d1be8
--- /dev/null
+++ b/dev-lang/rust-bin/files/rust-bin-0.12.0-no-ldconfig.patch
@@ -0,0 +1,23 @@
+Remove ldconfig(1) execution to prevent the installation script from accessing
+outside of a sandbox.
+
+--- install.sh
++++ install.sh
+@@ -466,17 +466,6 @@ while read p; do
+ # The manifest lists all files to install
+ done < "${CFG_SRC_DIR}/${CFG_LIBDIR_RELATIVE}/rustlib/manifest.in"
+
+-# Run ldconfig to make dynamic libraries available to the linker
+-if [ "$CFG_OSTYPE" = "Linux" ]
+- then
+- ldconfig
+- if [ $? -ne 0 ]
+- then
+- warn "failed to run ldconfig."
+- warn "this may happen when not installing as root and may be fine"
+- fi
+-fi
+-
+ # Sanity check: can we run the installed binaries?
+ #
+ # As with the verification above, make sure the right LD_LIBRARY_PATH-equivalent
diff --git a/dev-lang/rust-bin/metadata.xml b/dev-lang/rust-bin/metadata.xml
new file mode 100644
index 000000000000..0b7db932cfa4
--- /dev/null
+++ b/dev-lang/rust-bin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jauhien@gentoo.org</email>
+ <name>Jauhien Piatlicki</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-lang/rust-bin/rust-bin-0.12.0.ebuild b/dev-lang/rust-bin/rust-bin-0.12.0.ebuild
new file mode 100644
index 000000000000..531dd377f703
--- /dev/null
+++ b/dev-lang/rust-bin/rust-bin-0.12.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust-bin/rust-bin-0.12.0.ebuild,v 1.1 2014/10/18 12:50:48 jauhien Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Systems programming language from Mozilla"
+HOMEPAGE="http://www.rust-lang.org/"
+SRC_URI="amd64? ( http://static.rust-lang.org/dist/rust-${PV}-x86_64-unknown-linux-gnu.tar.gz )
+ x86? ( http://static.rust-lang.org/dist/rust-${PV}-i686-unknown-linux-gnu.tar.gz )"
+
+LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="emacs vim-syntax zsh-completion"
+
+DEPEND=">=app-admin/eselect-rust-0.2_pre20141011
+ !dev-lang/rust:0
+"
+RDEPEND="${DEPEND}
+ emacs? ( >=app-emacs/rust-mode-${PV} )
+ vim-syntax? ( >=app-vim/rust-mode-${PV} )
+ zsh-completion? ( >=app-shells/rust-zshcomp-${PV} )
+"
+
+src_unpack() {
+ default
+
+ local postfix
+ use amd64 && postfix=x86_64-unknown-linux-gnu
+ use x86 && postfix=i686-unknown-linux-gnu
+ mv "${WORKDIR}/rust-${PV}-${postfix}" "${S}" || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.12.0-no-ldconfig.patch"
+}
+
+src_install() {
+ ./install.sh \
+ --disable-verify \
+ --prefix="${D}/opt/${P}" \
+ --mandir="${D}/usr/share/${P}/man"
+
+ local rustc=rustc-bin-${PV}
+ local rustdoc=rustdoc-bin-${PV}
+
+ mv "${D}/opt/${P}/bin/rustc" "${D}/opt/${P}/bin/${rustc}" || die
+ mv "${D}/opt/${P}/bin/rustdoc" "${D}/opt/${P}/bin/${rustdoc}" || die
+ dosym "/opt/${P}/bin/${rustc}" "/usr/bin/${rustc}"
+ dosym "/opt/${P}/bin/${rustdoc}" "/usr/bin/${rustdoc}"
+
+ cat <<-EOF > "${T}"/50${P}
+ LDPATH="/opt/${P}/lib"
+ MANPATH="/usr/share/${P}/man"
+ EOF
+ doenvd "${T}"/50${P}
+
+ dodir /etc/env.d/rust
+ touch "${D}/etc/env.d/rust/provider-${P}" || die
+}
+
+pkg_postinst() {
+ eselect rust update --if-unset
+
+ elog "Rust uses slots now, use 'eselect rust list'"
+ elog "and 'eselect rust set' to list and set rust version."
+ elog "For more information see 'eselect rust help'"
+ elog "and http://wiki.gentoo.org/wiki/Project:Eselect/User_guide"
+}
+
+pkg_postrm() {
+ eselect rust unset --if-invalid
+}
diff --git a/dev-lang/rust-bin/rust-bin-999.ebuild b/dev-lang/rust-bin/rust-bin-999.ebuild
new file mode 100644
index 000000000000..35f36cd89b4d
--- /dev/null
+++ b/dev-lang/rust-bin/rust-bin-999.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust-bin/rust-bin-999.ebuild,v 1.1 2014/10/18 12:50:48 jauhien Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Systems programming language from Mozilla"
+HOMEPAGE="http://www.rust-lang.org/"
+MY_SRC_URI="http://static.rust-lang.org/dist/rust-nightly"
+
+LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+
+IUSE="emacs vim-syntax zsh-completion"
+
+CDEPEND=">=app-admin/eselect-rust-0.2_pre20141011
+ !dev-lang/rust:0
+"
+DEPEND="${CDEPEND}
+ net-misc/wget
+"
+RDEPEND="${CDEPEND}
+ emacs? ( >=app-emacs/rust-mode-${PV} )
+ vim-syntax? ( >=app-vim/rust-mode-${PV} )
+ zsh-completion? ( >=app-shells/rust-zshcomp-${PV} )
+"
+
+src_unpack() {
+ local postfix
+ use amd64 && postfix=x86_64-unknown-linux-gnu
+ use x86 && postfix=i686-unknown-linux-gnu
+
+ wget "${MY_SRC_URI}-${postfix}.tar.gz" || die
+ unpack ./"rust-nightly-${postfix}.tar.gz"
+
+ mv "${WORKDIR}/rust-nightly-${postfix}" "${S}" || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.12.0-no-ldconfig.patch"
+}
+
+src_install() {
+ ./install.sh \
+ --disable-verify \
+ --prefix="${D}/opt/${P}" \
+ --mandir="${D}/usr/share/${P}/man"
+
+ local rustc=rustc-bin-${PV}
+ local rustdoc=rustdoc-bin-${PV}
+
+ mv "${D}/opt/${P}/bin/rustc" "${D}/opt/${P}/bin/${rustc}" || die
+ mv "${D}/opt/${P}/bin/rustdoc" "${D}/opt/${P}/bin/${rustdoc}" || die
+ dosym "/opt/${P}/bin/${rustc}" "/usr/bin/${rustc}"
+ dosym "/opt/${P}/bin/${rustdoc}" "/usr/bin/${rustdoc}"
+
+ cat <<-EOF > "${T}"/50${P}
+ LDPATH="/opt/${P}/lib"
+ MANPATH="/usr/share/${P}/man"
+ EOF
+ doenvd "${T}"/50${P}
+
+ dodir /etc/env.d/rust
+ touch "${D}/etc/env.d/rust/provider-${P}" || die
+}
+
+pkg_postinst() {
+ eselect rust update --if-unset
+
+ elog "Rust uses slots now, use 'eselect rust list'"
+ elog "and 'eselect rust set' to list and set rust version."
+ elog "For more information see 'eselect rust help'"
+ elog "and http://wiki.gentoo.org/wiki/Project:Eselect/User_guide"
+}
+
+pkg_postrm() {
+ eselect rust unset --if-invalid
+}