summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-05-11 18:45:24 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-05-11 18:45:24 +0000
commit2f0ccb296958adbd816ab4ac8e3f4a7cc2393fe8 (patch)
treeb13a69ac34f7a7b2ab15ec8f38d9bcffebb37736 /dev-lang
parentVersion bump. (diff)
downloadgentoo-2-2f0ccb296958adbd816ab4ac8e3f4a7cc2393fe8.tar.gz
gentoo-2-2f0ccb296958adbd816ab4ac8e3f4a7cc2393fe8.tar.bz2
gentoo-2-2f0ccb296958adbd816ab4ac8e3f4a7cc2393fe8.zip
minor fix for last commit
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/yasm/yasm-9999.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-lang/yasm/yasm-9999.ebuild b/dev-lang/yasm/yasm-9999.ebuild
index a533443bf04b..eae985967e46 100644
--- a/dev-lang/yasm/yasm-9999.ebuild
+++ b/dev-lang/yasm/yasm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-9999.ebuild,v 1.4 2013/05/11 18:42:04 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-9999.ebuild,v 1.5 2013/05/11 18:45:24 ssuominen Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -40,13 +40,17 @@ src_prepare() {
sed -i -e '1c\#!/usr/bin/env sh' YASM-VERSION-GEN.sh || die
eautoreconf
- if [[ ${PV} == 9999* ]] ; then
+ if [[ ${PV} == 9999* ]]; then
./modules/arch/x86/gen_x86_insn.py || die
fi
}
src_configure() {
- python_export_best
+ if [[ ${PV} == 9999* ]]; then
+ python_export_best
+ else
+ use python && python_export_best
+ fi
econf \
--disable-warnerror \