summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-02-25 07:25:48 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-02-25 07:25:48 +0000
commit3449f8efeeba2b28e1fbaed1c56601d316df73d1 (patch)
tree62016b22660ce7c5305f18d156fd726464585430 /dev-lang
parentold (diff)
downloadgentoo-2-3449f8efeeba2b28e1fbaed1c56601d316df73d1.tar.gz
gentoo-2-3449f8efeeba2b28e1fbaed1c56601d316df73d1.tar.bz2
gentoo-2-3449f8efeeba2b28e1fbaed1c56601d316df73d1.zip
Big cleanup, 1.8 stable
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/R/ChangeLog7
-rw-r--r--dev-lang/R/R-1.4.1-r1.ebuild89
-rw-r--r--dev-lang/R/R-1.4.1.ebuild88
-rw-r--r--dev-lang/R/R-1.5.1.ebuild102
-rw-r--r--dev-lang/R/R-1.6.1.ebuild96
-rw-r--r--dev-lang/R/R-1.6.2.ebuild96
-rw-r--r--dev-lang/R/R-1.7.0.ebuild96
-rw-r--r--dev-lang/R/R-1.7.1.ebuild96
-rw-r--r--dev-lang/R/R-1.8.0.ebuild6
-rw-r--r--dev-lang/R/files/R-1.5.1-tcltk.diff12
-rw-r--r--dev-lang/R/files/digest-R-1.4.11
-rw-r--r--dev-lang/R/files/digest-R-1.4.1-r11
-rw-r--r--dev-lang/R/files/digest-R-1.5.11
-rw-r--r--dev-lang/R/files/digest-R-1.6.11
-rw-r--r--dev-lang/R/files/digest-R-1.6.21
-rw-r--r--dev-lang/R/files/digest-R-1.7.01
-rw-r--r--dev-lang/R/files/digest-R-1.7.11
17 files changed, 9 insertions, 686 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index 5018df4be8de..f7069ea6e8e0 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/R
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.14 2004/02/17 10:05:24 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.15 2004/02/25 07:25:48 phosphan Exp $
+
+ 25 Feb 2004; Patrick Kursawe <phosphan@gentoo.org> R-1.4.1-r1.ebuild,
+ R-1.4.1.ebuild, R-1.5.1.ebuild, R-1.6.1.ebuild, R-1.6.2.ebuild,
+ R-1.7.0.ebuild, R-1.7.1.ebuild, R-1.8.0.ebuild, files/R-1.5.1-tcltk.diff:
+ Big cleanup, marking 1.8.0 as stable
*R-1.8.1 (17 Feb 2004)
diff --git a/dev-lang/R/R-1.4.1-r1.ebuild b/dev-lang/R/R-1.4.1-r1.ebuild
deleted file mode 100644
index 2bcd79db4bc2..000000000000
--- a/dev-lang/R/R-1.4.1-r1.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.4.1-r1.ebuild,v 1.12 2004/02/22 19:56:19 agriffis Exp $
-
-IUSE="atlas X tcltk gnome"
-
-S=${WORKDIR}/${P}
-
-DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
-
-SRC_URI="http://cran.r-project.org/src/base/${P}.tgz"
-
- #There are daily release patches, don't know how to utilize these
- #"ftp://ftp.stat.math.ethz.ch/Software/${PN}/${PN}-release.diff.gz"
-
-HOMEPAGE="http://www.r-project.org/"
-
-DEPEND="virtual/glibc
- >=dev-lang/perl-5.6.1-r3
- >=sys-libs/readline-4.1-r3
- >=sys-libs/zlib-1.1.3-r2
- >=media-libs/jpeg-6b-r2
- >=media-libs/libpng-1.2.1
- atlas? ( dev-libs/atlas )
- X? ( virtual/x11 )
- tcltk? ( dev-lang/tk )
- gnome? ( >=gnome-base/gnome-libs-1.4.1.4 )"
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="x86 sparc"
-
-
-src_compile() {
-
- local myconf="--enable-R-profiling --enable-R-shlib --with-readline"
-
- #Eventually, we will want to take into account that a user may have
- #an alternate or additional blas libraries,
- #i.e. USE variable blas and and virtual/blas
- use atlas || myconf="${myconf} --without-blas" #default enabled
-
- use X || myconf="${myconf} --without-x" #default enabled
-
- if use tcltk; then
- #configure needs to find the files tclConfig.sh and tkConfig.sh
- myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib --with-tk-config=/usr/lib"
- else
- myconf="${myconf} --without-tcltk"
- fi
-
- use gnome && myconf="${myconf} --with-gnome" #default disabled
-
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} || die "./configure failed"
-
- emake || die "Parallel Make Failed"
-
-}
-
-src_install () {
-
- make \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die "Installation Failed"
-
- #fix the R wrapper script to have the correct R_HOME_DIR
- #sed regexp borrowed from included debian rules
- cp ${D}/usr/bin/R ${S}/bin/R.orig
- sed -e '/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/lib/R:' \
- ${S}/bin/R.orig > ${D}/usr/bin/R
-
- dodoc AUTHORS BUGS COPYING* ChangeLog FAQ INSTALL *NEWS README \
- RESOURCES THANKS VERSION Y2K
-
- #Add rudimentary menu entry if gnome
- if use gnome; then
- insinto /usr/share/gnome/apps/Applications
- doins ${FILESDIR}/R.desktop
- insinto /usr/share/pixmaps
- doins ${FILESDIR}/R-logo.png
- fi
-
-}
diff --git a/dev-lang/R/R-1.4.1.ebuild b/dev-lang/R/R-1.4.1.ebuild
deleted file mode 100644
index 2d4ecc4c9ef6..000000000000
--- a/dev-lang/R/R-1.4.1.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.4.1.ebuild,v 1.12 2004/02/22 19:56:19 agriffis Exp $
-
-IUSE="atlas X tcltk gnome"
-
-S=${WORKDIR}/${P}
-
-DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
-
-SRC_URI="http://cran.r-project.org/src/base/${P}.tgz"
-
- #There are daily release patches, don't know how to utilize these
- #"ftp://ftp.stat.math.ethz.ch/Software/${PN}/${PN}-release.diff.gz"
-
-HOMEPAGE="http://www.r-project.org/"
-
-DEPEND="virtual/glibc
- >=dev-lang/perl-5.6.1-r3
- >=sys-libs/readline-4.1-r3
- >=sys-libs/zlib-1.1.3-r2
- >=media-libs/jpeg-6b-r2
- >=media-libs/libpng-1.0.12
- atlas? ( dev-libs/atlas )
- X? ( virtual/x11 )
- tcltk? ( dev-lang/tk )
- gnome? ( >=gnome-base/gnome-libs-1.4.1.4 )"
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="x86 sparc"
-
-src_compile() {
-
- local myconf="--enable-R-profiling --enable-R-shlib --with-readline"
-
- #Eventually, we will want to take into account that a user may have
- #an alternate or additional blas libraries,
- #i.e. USE variable blas and and virtual/blas
- use atlas || myconf="${myconf} --without-blas" #default enabled
-
- use X || myconf="${myconf} --without-x" #default enabled
-
- if use tcltk; then
- #configure needs to find the files tclConfig.sh and tkConfig.sh
- myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib --with-tk-config=/usr/lib"
- else
- myconf="${myconf} --without-tcltk"
- fi
-
- use gnome && myconf="${myconf} --with-gnome" #default disabled
-
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} || die "./configure failed"
-
- emake || die "Parallel Make Failed"
-
-}
-
-src_install () {
-
- make \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die "Installation Failed"
-
- #fix the R wrapper script to have the correct R_HOME_DIR
- #sed regexp borrowed from included debian rules
- cp ${D}/usr/bin/R ${S}/bin/R.orig
- sed -e '/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/lib/R:' \
- ${S}/bin/R.orig > ${D}/usr/bin/R
-
- dodoc AUTHORS BUGS COPYING* ChangeLog FAQ INSTALL *NEWS README \
- RESOURCES THANKS VERSION Y2K
-
- #Add rudimentary menu entry if gnome
- if use gnome; then
- insinto /usr/share/gnome/apps/Applications
- doins ${FILESDIR}/R.desktop
- insinto /usr/share/pixmaps
- doins ${FILESDIR}/R-logo.png
- fi
-
-}
diff --git a/dev-lang/R/R-1.5.1.ebuild b/dev-lang/R/R-1.5.1.ebuild
deleted file mode 100644
index 9b956d98dc05..000000000000
--- a/dev-lang/R/R-1.5.1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.5.1.ebuild,v 1.11 2004/02/22 19:56:19 agriffis Exp $
-
-IUSE="atlas X tcltk gnome"
-
-S=${WORKDIR}/${P}
-
-DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
-
-SRC_URI="http://cran.r-project.org/src/base/${P}.tgz"
-
- #There are daily release patches, don't know how to utilize these
- #"ftp://ftp.stat.math.ethz.ch/Software/${PN}/${PN}-release.diff.gz"
-
-HOMEPAGE="http://www.r-project.org/"
-
-DEPEND="virtual/glibc
- >=dev-lang/perl-5.6.1-r3
- >=sys-libs/readline-4.1-r3
- >=sys-libs/zlib-1.1.3-r2
- >=media-libs/jpeg-6b-r2
- >=media-libs/libpng-1.2.1
- atlas? ( dev-libs/atlas )
- X? ( virtual/x11 )
- tcltk? ( dev-lang/tk )
- gnome? ( >=gnome-base/gnome-libs-1.4.1.4 )"
-SLOT="0"
-LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="x86 sparc"
-
-
-src_unpack() {
- unpack ${A}
- patch -d ${S} -p1 < ${FILESDIR}/R-1.5.1-tcltk.diff
-}
-
-src_compile() {
-
- local myconf="--enable-R-profiling --enable-R-shlib --with-readline"
-
- #Eventually, we will want to take into account that a user may have
- #an alternate or additional blas libraries,
- #i.e. USE variable blas and and virtual/blas
- use atlas || myconf="${myconf} --without-blas" #default enabled
-
- use X || myconf="${myconf} --without-x" #default enabled
-
- if use tcltk; then
- #configure needs to find the files tclConfig.sh and tkConfig.sh
- myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib --with-tk-config=/usr/lib"
- else
- myconf="${myconf} --without-tcltk"
- fi
-
- use gnome && myconf="${myconf} --with-gnome" #default disabled
-
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} || die "./configure failed"
-
- make || die
-
-}
-
-src_install () {
-
- make \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die "Installation Failed"
-
- #fix the R wrapper script to have the correct R_HOME_DIR
- #sed regexp borrowed from included debian rules
- cp ${D}/usr/lib/R/bin/R ${S}/bin/R.orig
- sed -e '/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/lib/R:' \
- ${S}/bin/R.orig > ${D}/usr/lib/R/bin/R
-
- #R installs two identical wrappers under /usr/bin and /usr/lib/R/bin/
- #the 2nd one is corrected by above sed, for the 1st
- #I'll just symlink it into /usr/bin
- cd ${D}/usr/bin/
- rm R
- dosym ../lib/R/bin/R /usr/bin/R
- cd ${S}
-
- dodoc AUTHORS BUGS COPYING* ChangeLog FAQ INSTALL *NEWS README \
- RESOURCES THANKS VERSION Y2K
-
- #Add rudimentary menu entry if gnome
- if use gnome; then
- insinto /usr/share/gnome/apps/Applications
- doins ${FILESDIR}/R.desktop
- insinto /usr/share/pixmaps
- doins ${FILESDIR}/R-logo.png
- fi
-
-}
diff --git a/dev-lang/R/R-1.6.1.ebuild b/dev-lang/R/R-1.6.1.ebuild
deleted file mode 100644
index 435a01bd0e97..000000000000
--- a/dev-lang/R/R-1.6.1.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.6.1.ebuild,v 1.4 2003/03/11 21:11:45 seemant Exp $
-
-IUSE="atlas X tcltk gnome"
-
-S=${WORKDIR}/${P}
-
-DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
-
-SRC_URI="http://cran.r-project.org/src/base/${P}.tgz"
-
- #There are daily release patches, don't know how to utilize these
- #"ftp://ftp.stat.math.ethz.ch/Software/${PN}/${PN}-release.diff.gz"
-
-HOMEPAGE="http://www.r-project.org/"
-
-DEPEND="virtual/glibc
- >=dev-lang/perl-5.6.1-r3
- >=sys-libs/readline-4.1-r3
- >=sys-libs/zlib-1.1.3-r2
- >=media-libs/jpeg-6b-r2
- >=media-libs/libpng-1.2.1
- atlas? ( dev-libs/atlas )
- X? ( virtual/x11 )
- tcltk? ( dev-lang/tk )
- gnome? ( >=gnome-base/gnome-libs-1.4.1.4 )"
-SLOT="0"
-LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="x86 ~sparc"
-
-src_compile() {
-
- local myconf="--enable-R-profiling --enable-R-shlib --with-readline"
-
- #Eventually, we will want to take into account that a user may have
- #an alternate or additional blas libraries,
- #i.e. USE variable blas and and virtual/blas
- use atlas || myconf="${myconf} --without-blas" #default enabled
-
- use X || myconf="${myconf} --without-x" #default enabled
-
- if use tcltk; then
- #configure needs to find the files tclConfig.sh and tkConfig.sh
- myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib --with-tk-config=/usr/lib"
- else
- myconf="${myconf} --without-tcltk"
- fi
-
- use gnome && myconf="${myconf} --with-gnome" #default disabled
-
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} || die "./configure failed"
-
- make || die
-
-}
-
-src_install () {
-
- make \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die "Installation Failed"
-
- #fix the R wrapper script to have the correct R_HOME_DIR
- #sed regexp borrowed from included debian rules
- cp ${D}/usr/lib/R/bin/R ${S}/bin/R.orig
- sed -e '/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/lib/R:' \
- ${S}/bin/R.orig > ${D}/usr/lib/R/bin/R
-
- #R installs two identical wrappers under /usr/bin and /usr/lib/R/bin/
- #the 2nd one is corrected by above sed, for the 1st
- #I'll just symlink it into /usr/bin
- cd ${D}/usr/bin/
- rm R
- dosym ../lib/R/bin/R /usr/bin/R
- cd ${S}
-
- dodoc AUTHORS BUGS COPYING* ChangeLog FAQ INSTALL *NEWS README \
- RESOURCES THANKS VERSION Y2K
-
- #Add rudimentary menu entry if gnome
- if use gnome; then
- insinto /usr/share/gnome/apps/Applications
- doins ${FILESDIR}/R.desktop
- insinto /usr/share/pixmaps
- doins ${FILESDIR}/R-logo.png
- fi
-
-}
diff --git a/dev-lang/R/R-1.6.2.ebuild b/dev-lang/R/R-1.6.2.ebuild
deleted file mode 100644
index a88a1ad7e5ba..000000000000
--- a/dev-lang/R/R-1.6.2.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.6.2.ebuild,v 1.1 2003/04/12 15:06:56 g2boojum Exp $
-
-IUSE="atlas X tcltk gnome"
-
-S=${WORKDIR}/${P}
-
-DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
-
-SRC_URI="http://cran.r-project.org/src/base/${P}.tgz"
-
- #There are daily release patches, don't know how to utilize these
- #"ftp://ftp.stat.math.ethz.ch/Software/${PN}/${PN}-release.diff.gz"
-
-HOMEPAGE="http://www.r-project.org/"
-
-DEPEND="virtual/glibc
- >=dev-lang/perl-5.6.1-r3
- >=sys-libs/readline-4.1-r3
- >=sys-libs/zlib-1.1.3-r2
- >=media-libs/jpeg-6b-r2
- >=media-libs/libpng-1.2.1
- atlas? ( dev-libs/atlas )
- X? ( virtual/x11 )
- tcltk? ( dev-lang/tk )
- gnome? ( >=gnome-base/gnome-libs-1.4.1.4 )"
-SLOT="0"
-LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="~x86 ~sparc"
-
-src_compile() {
-
- local myconf="--enable-R-profiling --enable-R-shlib --with-readline"
-
- #Eventually, we will want to take into account that a user may have
- #an alternate or additional blas libraries,
- #i.e. USE variable blas and and virtual/blas
- use atlas || myconf="${myconf} --without-blas" #default enabled
-
- use X || myconf="${myconf} --without-x" #default enabled
-
- if use tcltk; then
- #configure needs to find the files tclConfig.sh and tkConfig.sh
- myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib --with-tk-config=/usr/lib"
- else
- myconf="${myconf} --without-tcltk"
- fi
-
- use gnome && myconf="${myconf} --with-gnome" #default disabled
-
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} || die "./configure failed"
-
- make || die
-
-}
-
-src_install () {
-
- make \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die "Installation Failed"
-
- #fix the R wrapper script to have the correct R_HOME_DIR
- #sed regexp borrowed from included debian rules
- cp ${D}/usr/lib/R/bin/R ${S}/bin/R.orig
- sed -e '/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/lib/R:' \
- ${S}/bin/R.orig > ${D}/usr/lib/R/bin/R
-
- #R installs two identical wrappers under /usr/bin and /usr/lib/R/bin/
- #the 2nd one is corrected by above sed, for the 1st
- #I'll just symlink it into /usr/bin
- cd ${D}/usr/bin/
- rm R
- dosym ../lib/R/bin/R /usr/bin/R
- cd ${S}
-
- dodoc AUTHORS BUGS COPYING* ChangeLog FAQ INSTALL *NEWS README \
- RESOURCES THANKS VERSION Y2K
-
- #Add rudimentary menu entry if gnome
- if use gnome; then
- insinto /usr/share/gnome/apps/Applications
- doins ${FILESDIR}/R.desktop
- insinto /usr/share/pixmaps
- doins ${FILESDIR}/R-logo.png
- fi
-
-}
diff --git a/dev-lang/R/R-1.7.0.ebuild b/dev-lang/R/R-1.7.0.ebuild
deleted file mode 100644
index 4c34ac0717bf..000000000000
--- a/dev-lang/R/R-1.7.0.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.7.0.ebuild,v 1.1 2003/05/29 19:33:11 g2boojum Exp $
-
-IUSE="atlas X tcltk gnome"
-
-S=${WORKDIR}/${P}
-
-DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
-
-SRC_URI="http://cran.r-project.org/src/base/${P}.tgz"
-
- #There are daily release patches, don't know how to utilize these
- #"ftp://ftp.stat.math.ethz.ch/Software/${PN}/${PN}-release.diff.gz"
-
-HOMEPAGE="http://www.r-project.org/"
-
-DEPEND="virtual/glibc
- >=dev-lang/perl-5.6.1-r3
- >=sys-libs/readline-4.1-r3
- >=sys-libs/zlib-1.1.3-r2
- >=media-libs/jpeg-6b-r2
- >=media-libs/libpng-1.2.1
- atlas? ( dev-libs/atlas )
- X? ( virtual/x11 )
- tcltk? ( dev-lang/tk )
- gnome? ( >=gnome-base/gnome-libs-1.4.1.4 )"
-SLOT="0"
-LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="~x86 ~sparc"
-
-src_compile() {
-
- local myconf="--enable-R-profiling --enable-R-shlib --with-readline"
-
- #Eventually, we will want to take into account that a user may have
- #an alternate or additional blas libraries,
- #i.e. USE variable blas and and virtual/blas
- use atlas || myconf="${myconf} --without-blas" #default enabled
-
- use X || myconf="${myconf} --without-x" #default enabled
-
- if use tcltk; then
- #configure needs to find the files tclConfig.sh and tkConfig.sh
- myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib --with-tk-config=/usr/lib"
- else
- myconf="${myconf} --without-tcltk"
- fi
-
- use gnome && myconf="${myconf} --with-gnome" #default disabled
-
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} || die "./configure failed"
-
- make || die
-
-}
-
-src_install () {
-
- make \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die "Installation Failed"
-
- #fix the R wrapper script to have the correct R_HOME_DIR
- #sed regexp borrowed from included debian rules
- cp ${D}/usr/lib/R/bin/R ${S}/bin/R.orig
- sed -e '/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/lib/R:' \
- ${S}/bin/R.orig > ${D}/usr/lib/R/bin/R
-
- #R installs two identical wrappers under /usr/bin and /usr/lib/R/bin/
- #the 2nd one is corrected by above sed, for the 1st
- #I'll just symlink it into /usr/bin
- cd ${D}/usr/bin/
- rm R
- dosym ../lib/R/bin/R /usr/bin/R
- cd ${S}
-
- dodoc AUTHORS BUGS COPYING* ChangeLog FAQ INSTALL *NEWS README \
- RESOURCES THANKS VERSION Y2K
-
- #Add rudimentary menu entry if gnome
- if use gnome; then
- insinto /usr/share/gnome/apps/Applications
- doins ${FILESDIR}/R.desktop
- insinto /usr/share/pixmaps
- doins ${FILESDIR}/R-logo.png
- fi
-
-}
diff --git a/dev-lang/R/R-1.7.1.ebuild b/dev-lang/R/R-1.7.1.ebuild
deleted file mode 100644
index ef729bcefc16..000000000000
--- a/dev-lang/R/R-1.7.1.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.7.1.ebuild,v 1.1 2003/06/20 08:41:00 george Exp $
-
-IUSE="atlas X tcltk gnome"
-
-S=${WORKDIR}/${P}
-
-DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
-
-SRC_URI="http://cran.r-project.org/src/base/${P}.tgz"
-
- #There are daily release patches, don't know how to utilize these
- #"ftp://ftp.stat.math.ethz.ch/Software/${PN}/${PN}-release.diff.gz"
-
-HOMEPAGE="http://www.r-project.org/"
-
-DEPEND="virtual/glibc
- >=dev-lang/perl-5.6.1-r3
- >=sys-libs/readline-4.1-r3
- >=sys-libs/zlib-1.1.3-r2
- >=media-libs/jpeg-6b-r2
- >=media-libs/libpng-1.2.1
- atlas? ( dev-libs/atlas )
- X? ( virtual/x11 )
- tcltk? ( dev-lang/tk )
- gnome? ( >=gnome-base/gnome-libs-1.4.1.4 )"
-SLOT="0"
-LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="~x86 ~sparc"
-
-src_compile() {
-
- local myconf="--enable-R-profiling --enable-R-shlib --with-readline"
-
- #Eventually, we will want to take into account that a user may have
- #an alternate or additional blas libraries,
- #i.e. USE variable blas and and virtual/blas
- use atlas || myconf="${myconf} --without-blas" #default enabled
-
- use X || myconf="${myconf} --without-x" #default enabled
-
- if use tcltk; then
- #configure needs to find the files tclConfig.sh and tkConfig.sh
- myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib/tclConfig.sh --with-tk-config=/usr/lib/tclConfig.sh"
- else
- myconf="${myconf} --without-tcltk"
- fi
-
- use gnome && myconf="${myconf} --with-gnome" #default disabled
-
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} || die "./configure failed"
-
- make || die
-
-}
-
-src_install () {
-
- make \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die "Installation Failed"
-
- #fix the R wrapper script to have the correct R_HOME_DIR
- #sed regexp borrowed from included debian rules
- cp ${D}/usr/lib/R/bin/R ${S}/bin/R.orig
- sed -e '/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/lib/R:' \
- ${S}/bin/R.orig > ${D}/usr/lib/R/bin/R
-
- #R installs two identical wrappers under /usr/bin and /usr/lib/R/bin/
- #the 2nd one is corrected by above sed, for the 1st
- #I'll just symlink it into /usr/bin
- cd ${D}/usr/bin/
- rm R
- dosym ../lib/R/bin/R /usr/bin/R
- cd ${S}
-
- dodoc AUTHORS BUGS COPYING* ChangeLog FAQ INSTALL *NEWS README \
- RESOURCES THANKS VERSION Y2K
-
- #Add rudimentary menu entry if gnome
- if use gnome; then
- insinto /usr/share/gnome/apps/Applications
- doins ${FILESDIR}/R.desktop
- insinto /usr/share/pixmaps
- doins ${FILESDIR}/R-logo.png
- fi
-
-}
diff --git a/dev-lang/R/R-1.8.0.ebuild b/dev-lang/R/R-1.8.0.ebuild
index 00693092de52..c31818971db7 100644
--- a/dev-lang/R/R-1.8.0.ebuild
+++ b/dev-lang/R/R-1.8.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.8.0.ebuild,v 1.2 2003/10/21 14:59:28 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.8.0.ebuild,v 1.3 2004/02/25 07:25:48 phosphan Exp $
IUSE="atlas X tcltk gnome"
@@ -36,7 +36,7 @@ DEPEND="virtual/glibc
SLOT="0"
LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="~x86 ~sparc ~ppc"
+KEYWORDS="x86 sparc ppc"
src_compile() {
diff --git a/dev-lang/R/files/R-1.5.1-tcltk.diff b/dev-lang/R/files/R-1.5.1-tcltk.diff
deleted file mode 100644
index ddb68897113e..000000000000
--- a/dev-lang/R/files/R-1.5.1-tcltk.diff
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN R-1.5.1.orig/src/library/tcltk/src/tcltk.c R-1.5.1/src/library/tcltk/src/tcltk.c
---- R-1.5.1.orig/src/library/tcltk/src/tcltk.c Fri Jun 7 17:37:35 2002
-+++ R-1.5.1/src/library/tcltk/src/tcltk.c Mon Jun 17 16:09:04 2002
-@@ -239,7 +239,7 @@
-
- PROTECT(ans = allocVector(STRSXP, count));
- for (i = 0 ; i < count ; i++)
-- SET_STRING_ELT(ans, i, mkChar(Tcl_GetString(elem[i])));
-+ SET_STRING_ELT(ans, i, mkChar(Tcl_GetStringFromObj(elem[i], NULL)));
- UNPROTECT(1);
- return ans;
- }
diff --git a/dev-lang/R/files/digest-R-1.4.1 b/dev-lang/R/files/digest-R-1.4.1
deleted file mode 100644
index a75025244dd9..000000000000
--- a/dev-lang/R/files/digest-R-1.4.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 bf482598325347c7997477eb778552e8 R-1.4.1.tgz 5136906
diff --git a/dev-lang/R/files/digest-R-1.4.1-r1 b/dev-lang/R/files/digest-R-1.4.1-r1
deleted file mode 100644
index a75025244dd9..000000000000
--- a/dev-lang/R/files/digest-R-1.4.1-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 bf482598325347c7997477eb778552e8 R-1.4.1.tgz 5136906
diff --git a/dev-lang/R/files/digest-R-1.5.1 b/dev-lang/R/files/digest-R-1.5.1
deleted file mode 100644
index dead2d895589..000000000000
--- a/dev-lang/R/files/digest-R-1.5.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 5be01408b5354e35f4c02aa124c9ed77 R-1.5.1.tgz 5452320
diff --git a/dev-lang/R/files/digest-R-1.6.1 b/dev-lang/R/files/digest-R-1.6.1
deleted file mode 100644
index 28beb4902703..000000000000
--- a/dev-lang/R/files/digest-R-1.6.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 7c9b8e8582812448aedd0322bcc135eb R-1.6.1.tgz 8633830
diff --git a/dev-lang/R/files/digest-R-1.6.2 b/dev-lang/R/files/digest-R-1.6.2
deleted file mode 100644
index 6171452722f9..000000000000
--- a/dev-lang/R/files/digest-R-1.6.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 174e6280aa2f2102388ca9c7930b1843 R-1.6.2.tgz 8659106
diff --git a/dev-lang/R/files/digest-R-1.7.0 b/dev-lang/R/files/digest-R-1.7.0
deleted file mode 100644
index b8611896d1f4..000000000000
--- a/dev-lang/R/files/digest-R-1.7.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 292dbe4dc47e6b492ff72a62471654ca R-1.7.0.tgz 9236335
diff --git a/dev-lang/R/files/digest-R-1.7.1 b/dev-lang/R/files/digest-R-1.7.1
deleted file mode 100644
index b4ed98f1b201..000000000000
--- a/dev-lang/R/files/digest-R-1.7.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 833c2a9a62818211f2f9f0353ecd9bbd R-1.7.1.tgz 9378628