summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-09-04 10:08:32 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-09-04 10:08:32 +0000
commit4792d938cf5ad26720e4b461f67401c3687f9bbc (patch)
tree8053d3e572956d3f529f28a87a5bf0b49c320d31 /dev-lang
parentVersion bump, use new python-config (#488392 by mgorny), drop old. (diff)
downloadgentoo-2-4792d938cf5ad26720e4b461f67401c3687f9bbc.tar.gz
gentoo-2-4792d938cf5ad26720e4b461f67401c3687f9bbc.tar.bz2
gentoo-2-4792d938cf5ad26720e4b461f67401c3687f9bbc.zip
Version bump, fix bugs #414967, #426980 and #498032. Drop old and broken version
(Portage version: 2.2.12-r1/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/gforth/ChangeLog9
-rw-r--r--dev-lang/gforth/gforth-0.7.3.ebuild (renamed from dev-lang/gforth/gforth-0.7.0.ebuild)41
2 files changed, 27 insertions, 23 deletions
diff --git a/dev-lang/gforth/ChangeLog b/dev-lang/gforth/ChangeLog
index ce016e5d337e..cf4b69a1fcae 100644
--- a/dev-lang/gforth/ChangeLog
+++ b/dev-lang/gforth/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/gforth
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/ChangeLog,v 1.38 2014/09/02 15:30:17 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/ChangeLog,v 1.39 2014/09/04 10:08:32 pinkbyte Exp $
+
+*gforth-0.7.3 (04 Sep 2014)
+
+ 04 Sep 2014; Sergey Popov <pinkbyte@gentoo.org> -gforth-0.7.0.ebuild,
+ +gforth-0.7.3.ebuild:
+ Version bump, fix bugs #414967, #426980 and #498032. Drop old and broken
+ version
02 Sep 2014; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Carsten will take care of this
diff --git a/dev-lang/gforth/gforth-0.7.0.ebuild b/dev-lang/gforth/gforth-0.7.3.ebuild
index 902727f9f85c..c8d050da673c 100644
--- a/dev-lang/gforth/gforth-0.7.0.ebuild
+++ b/dev-lang/gforth/gforth-0.7.3.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/gforth-0.7.0.ebuild,v 1.10 2012/04/24 09:55:47 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/gforth-0.7.3.ebuild,v 1.1 2014/09/04 10:08:32 pinkbyte Exp $
-inherit elisp-common eutils toolchain-funcs flag-o-matic
+EAPI=5
+
+inherit elisp-common eutils
DESCRIPTION="GNU Forth is a fast and portable implementation of the ANSI Forth language"
HOMEPAGE="http://www.gnu.org/software/gforth"
@@ -10,47 +12,42 @@ SRC_URI="mirror://gnu/gforth/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="amd64 ppc x86 ~x86-fbsd ~x86-freebsd ~x86-linux ~ppc-macos ~sparc-solaris"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~x86-freebsd ~x86-linux ~ppc-macos ~sparc-solaris"
IUSE="emacs"
DEPEND="dev-libs/ffcall
emacs? ( virtual/emacs )"
-
RDEPEND="${DEPEND}"
-SITEFILE=50${PN}-gentoo.el
+SITEFILE="50${PN}-gentoo.el"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-make-elc.patch"
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.7.0-make-elc.patch"
+ epatch_user
}
-src_compile() {
- local myconf
-
+src_configure() {
# May want to add a USE flag for --enable-force-cdiv, if necessary
# At this point I do not know when that is appropriate, and I don't
# want to add an ebuild-specific USE flag without understanding.
+ econf \
+ --without-check \
+ $(use emacs || echo "--without-lispdir")
+}
- if ! use emacs; then
- myconf="--without-lispdir"
- fi
-
- econf ${myconf} || die "econf failed"
-
+src_compile() {
# Parallel make breaks here
emake -j1 || die "emake failed"
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install
dodoc AUTHORS BUGS ChangeLog NEWS* README* ToDo doc/glossaries.doc doc/*.ps
if use emacs; then
- elisp-install ${PN} gforth.el gforth.elc || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ elisp-install ${PN} gforth.el gforth.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
fi
}