summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-01-09 08:59:37 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-01-09 08:59:37 +0000
commit5d0d143134492e947b7d6e23f3bd6e44bc0a9f70 (patch)
tree1a375d4f7442bd9db379061c107eaf11e74455e4 /dev-lang
parentDrop KEYWORDS for archs that have unsatisfied dependencies, wrt bug #497476. (diff)
downloadgentoo-2-5d0d143134492e947b7d6e23f3bd6e44bc0a9f70.tar.gz
gentoo-2-5d0d143134492e947b7d6e23f3bd6e44bc0a9f70.tar.bz2
gentoo-2-5d0d143134492e947b7d6e23f3bd6e44bc0a9f70.zip
Hack up -9999 ebuild to have a chance of working with nqp
(Portage version: 2.2.8/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/moarvm/ChangeLog6
-rw-r--r--dev-lang/moarvm/files/Configure-9999.patch15
-rw-r--r--dev-lang/moarvm/moarvm-9999.ebuild8
3 files changed, 27 insertions, 2 deletions
diff --git a/dev-lang/moarvm/ChangeLog b/dev-lang/moarvm/ChangeLog
index 4c26c92fb3ab..f8466d8dda3d 100644
--- a/dev-lang/moarvm/ChangeLog
+++ b/dev-lang/moarvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/moarvm
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/moarvm/ChangeLog,v 1.5 2014/01/09 08:16:03 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/moarvm/ChangeLog,v 1.6 2014/01/09 08:59:37 patrick Exp $
+
+ 09 Jan 2014; Patrick Lauer <patrick@gentoo.org> +files/Configure-9999.patch,
+ moarvm-9999.ebuild:
+ Hack up -9999 ebuild to have a chance of working with nqp
*moarvm-9999 (09 Jan 2014)
diff --git a/dev-lang/moarvm/files/Configure-9999.patch b/dev-lang/moarvm/files/Configure-9999.patch
new file mode 100644
index 000000000000..85bbb5d81dac
--- /dev/null
+++ b/dev-lang/moarvm/files/Configure-9999.patch
@@ -0,0 +1,15 @@
+--- Configure.pl 2014-01-09 16:48:13.989620752 +0800
++++ Configure.pl.new 2014-01-09 16:49:41.217885279 +0800
+@@ -94,11 +94,7 @@
+ $VERSION = <$fh>;
+ close($fh);
+ }
+-# .git is a file and not a directory in submodule
+-if (-e '.git' && open(my $GIT, '-|', "git describe --tags")) {
+- $VERSION = <$GIT>;
+- close($GIT);
+-}
++
+ chomp $VERSION;
+ $config{version} = $VERSION;
+ $config{versionmajor} = $VERSION =~ /^(\d+)/ ? $1 : 0;
diff --git a/dev-lang/moarvm/moarvm-9999.ebuild b/dev-lang/moarvm/moarvm-9999.ebuild
index a45d1e34e9b7..84b8ecec590c 100644
--- a/dev-lang/moarvm/moarvm-9999.ebuild
+++ b/dev-lang/moarvm/moarvm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/moarvm/moarvm-9999.ebuild,v 1.1 2014/01/09 08:16:03 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/moarvm/moarvm-9999.ebuild,v 1.2 2014/01/09 08:59:37 patrick Exp $
EAPI=5
@@ -20,7 +20,13 @@ IUSE="doc"
RDEPEND=""
DEPEND="${RDEPEND}"
+src_prepare() {
+ epatch ${FILESDIR}/Configure-9999.patch || die
+}
+
src_configure() {
+ # this is quite badong, but wtf build system
+ echo "2013.10-145-gec52026" >> VERSION
perl Configure.pl --prefix="${D}/usr"|| die
}