summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Coie <rac@gentoo.org>2004-06-09 20:20:34 +0000
committerRobert Coie <rac@gentoo.org>2004-06-09 20:20:34 +0000
commit905bac5777ed9acc4d31f229cbf1d6122740aeed (patch)
tree7f0a5c00f00f99e38dc0577ffd47345e44d6dd61 /dev-lang
parentadded metadata.xml (Manifest recommit) (diff)
downloadgentoo-2-905bac5777ed9acc4d31f229cbf1d6122740aeed.tar.gz
gentoo-2-905bac5777ed9acc4d31f229cbf1d6122740aeed.tar.bz2
gentoo-2-905bac5777ed9acc4d31f229cbf1d6122740aeed.zip
bug 42665
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/perl/ChangeLog6
-rw-r--r--dev-lang/perl/files/perl-5.8.4-noksh.patch16
-rw-r--r--dev-lang/perl/perl-5.8.4.ebuild8
3 files changed, 28 insertions, 2 deletions
diff --git a/dev-lang/perl/ChangeLog b/dev-lang/perl/ChangeLog
index de5cb1b1a841..c14b8ce468d1 100644
--- a/dev-lang/perl/ChangeLog
+++ b/dev-lang/perl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/perl
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.63 2004/06/03 15:39:57 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.64 2004/06/09 20:20:34 rac Exp $
+
+ 09 Jun 2004; Robert Coie <rac@gentoo.org> +files/perl-5.8.4-noksh.patch,
+ perl-5.8.4.ebuild:
+ Add noksh.patch, bug 42665
03 Jun 2004; Aron Griffis <agriffis@gentoo.org> perl-5.8.2-r1.ebuild,
perl-5.8.3.ebuild, perl-5.8.4.ebuild:
diff --git a/dev-lang/perl/files/perl-5.8.4-noksh.patch b/dev-lang/perl/files/perl-5.8.4-noksh.patch
new file mode 100644
index 000000000000..4c33b3e71b33
--- /dev/null
+++ b/dev-lang/perl/files/perl-5.8.4-noksh.patch
@@ -0,0 +1,16 @@
+diff -burN perl-5.8.4.orig/Configure perl-5.8.4/Configure
+--- perl-5.8.4.orig/Configure 2004-04-01 05:48:18.000000000 -0800
++++ perl-5.8.4/Configure 2004-06-09 12:02:54.694172368 -0700
+@@ -164,6 +164,12 @@
+ ;;
+ esac
+
++# 2004.06.09 rac
++# having $newsh persist as ksh here is bad news if ksh doesn't really
++# exist. this causes us to toss away a perfectly good working test in
++# bash in favour of more exotic external options. see bug 42665.
++test -x "${newsh}" || unset newsh
++
+ : if needed set CDPATH to a harmless value that is not chatty
+ : avoid bash 2.02 problems with empty CDPATH.
+ case "$CDPATH" in
diff --git a/dev-lang/perl/perl-5.8.4.ebuild b/dev-lang/perl/perl-5.8.4.ebuild
index 258d50eee5fc..c12ff6aad2ca 100644
--- a/dev-lang/perl/perl-5.8.4.ebuild
+++ b/dev-lang/perl/perl-5.8.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.4.ebuild,v 1.9 2004/06/07 16:51:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.4.ebuild,v 1.10 2004/06/09 20:20:34 rac Exp $
inherit eutils flag-o-matic gcc
@@ -94,6 +94,12 @@ src_unpack() {
# counterproductive on a Gentoo system which has both a shared
# and static libperl, so effectively revert this here.
cd ${S}; epatch ${FILESDIR}/${P}-picdl.patch
+
+ # Configure makes an unwarranted assumption that /bin/ksh is a
+ # good shell. This patch makes it revert to using /bin/sh unless
+ # /bin/ksh really is executable. Should fix bug 42665.
+ # rac 2004.06.09
+ cd ${S}; epatch ${FILESDIR}/${P}-noksh.patch
}
src_compile() {