summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-09-11 09:57:37 +0000
committerUlrich Müller <ulm@gentoo.org>2010-09-11 09:57:37 +0000
commitcc9c7608646203af4d3a7bf38586e19fd2e5938e (patch)
treee8bb3ceccaf278761e9bda17eed2394758cdc9c9 /dev-lang
parentppc stable #329703 (diff)
downloadgentoo-2-cc9c7608646203af4d3a7bf38586e19fd2e5938e.tar.gz
gentoo-2-cc9c7608646203af4d3a7bf38586e19fd2e5938e.tar.bz2
gentoo-2-cc9c7608646203af4d3a7bf38586e19fd2e5938e.zip
Version bump, fixes build problem with gcc-4.4.
(Portage version: 2.2_rc71/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/c-intercal/ChangeLog10
-rw-r--r--dev-lang/c-intercal/c-intercal-28.65535.65534.0.ebuild77
2 files changed, 85 insertions, 2 deletions
diff --git a/dev-lang/c-intercal/ChangeLog b/dev-lang/c-intercal/ChangeLog
index 4e768aee80ad..b8bfca4deed0 100644
--- a/dev-lang/c-intercal/ChangeLog
+++ b/dev-lang/c-intercal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/c-intercal
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/c-intercal/ChangeLog,v 1.3 2009/03/18 11:14:38 ulm Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/c-intercal/ChangeLog,v 1.4 2010/09/11 09:57:37 ulm Exp $
+
+*c-intercal-28.65535.65534.0 (11 Sep 2010)
+
+ 11 Sep 2010; Ulrich Mueller <ulm@gentoo.org>
+ +c-intercal-28.65535.65534.0.ebuild:
+ Version bump, fixes build problem with gcc-4.4.
18 Mar 2009; Ulrich Mueller <ulm@gentoo.org> c-intercal-28.0-r1.ebuild:
Add pkg_postinst and pkg_postrm functions.
diff --git a/dev-lang/c-intercal/c-intercal-28.65535.65534.0.ebuild b/dev-lang/c-intercal/c-intercal-28.65535.65534.0.ebuild
new file mode 100644
index 000000000000..ef9f1daf3115
--- /dev/null
+++ b/dev-lang/c-intercal/c-intercal-28.65535.65534.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/c-intercal/c-intercal-28.65535.65534.0.ebuild,v 1.1 2010/09/11 09:57:37 ulm Exp $
+
+inherit elisp-common eutils multilib versionator
+
+# C-INTERCAL uses minor-major ordering of version components and
+# negative version numbers. We map version components -1, -2, ...
+# to 65535, 65534, ..., and subtract one from the next component.
+# For example, upstream version 0.28 is mapped to Gentoo version 28.0
+# and 0.-2.0.29 is mapped to 28.65535.65534.0.
+get_intercal_version() {
+ local i=.${1:-${PV}} j k c=0
+ while [[ ${i} ]]; do
+ (( k = ${i##*.} + c ))
+ (( (c = (k >= 32768)) && (k -= 65536) ))
+ i=${i%.*}
+ j=${j}.${k}
+ done
+ echo ${j#.}
+}
+
+MY_PV=$(get_intercal_version)
+DESCRIPTION="C-INTERCAL - INTERCAL to binary (via C) compiler"
+HOMEPAGE="http://c.intercal.org.uk"
+SRC_URI="http://overload.intercal.org.uk/c/ick-${MY_PV}.pax.gz"
+
+LICENSE="GPL-2 FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs examples"
+
+DEPEND="emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
+
+MY_PV2=${MY_PV%.${MY_PV##*.}}
+S="${WORKDIR}/ick-${MY_PV2##*.}.${MY_PV##*.}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_unpack() {
+ tar xzf "${DISTDIR}/${A}" || die "tar failed"
+}
+
+src_compile() {
+ econf
+ emake || die
+
+ if use emacs; then
+ elisp-compile etc/intercal.el || die
+ fi
+}
+
+src_install() {
+ # Thinks the directories exist, won't as this is done to a DESTDIR...
+ #dodir /usr/bin
+ #dodir /usr/$(get_libdir)
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc BUGS NEWS README doc/THEORY.txt
+
+ if use emacs; then
+ elisp-install ${PN} etc/intercal.{el,elc} || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r pit || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}