summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2007-01-23 09:47:09 +0000
committerMatti Bickel <mabi@gentoo.org>2007-01-23 09:47:09 +0000
commitddd31dfb9c8c99c5d797ed958f82179c5519e7fe (patch)
treee1564399463160078ef4e788a135746553c3e51b /dev-lang
parentx86 and amd64 stable, bug 162731 (diff)
downloadgentoo-2-ddd31dfb9c8c99c5d797ed958f82179c5519e7fe.tar.gz
gentoo-2-ddd31dfb9c8c99c5d797ed958f82179c5519e7fe.tar.bz2
gentoo-2-ddd31dfb9c8c99c5d797ed958f82179c5519e7fe.zip
Fixing make.patch
(Portage version: 2.1.1-r2)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/lua/ChangeLog5
-rw-r--r--dev-lang/lua/files/lua-5.1.1-make.patch14
2 files changed, 11 insertions, 8 deletions
diff --git a/dev-lang/lua/ChangeLog b/dev-lang/lua/ChangeLog
index 12cdeb261457..30089be70432 100644
--- a/dev-lang/lua/ChangeLog
+++ b/dev-lang/lua/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/lua
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/ChangeLog,v 1.62 2007/01/22 21:39:57 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/ChangeLog,v 1.63 2007/01/23 09:47:09 mabi Exp $
+
+ 23 Jan 2007; Matti Bickel <mabi@gentoo.org> files/lua-5.1.1-make.patch:
+ Fixing slotted fallout in make.patch
22 Jan 2007; Matti Bickel <mabi@gentoo.org>
-files/lua-5.1.1-Makefile.patch, -lua-5.0.3-r1.ebuild,
diff --git a/dev-lang/lua/files/lua-5.1.1-make.patch b/dev-lang/lua/files/lua-5.1.1-make.patch
index 03959c05ef47..fb95d253422d 100644
--- a/dev-lang/lua/files/lua-5.1.1-make.patch
+++ b/dev-lang/lua/files/lua-5.1.1-make.patch
@@ -1,5 +1,5 @@
---- /home/mabi/gentoo/lua-5.1.1.orig/Makefile 2006-06-02 12:53:38.000000000 +0200
-+++ ./Makefile 2006-11-16 02:16:53.000000000 +0100
+--- lua-5.1.1.orig/Makefile 2006-06-02 12:53:38.000000000 +0200
++++ lua-5.1.1/Makefile 2006-11-16 02:16:53.000000000 +0100
@@ -22,10 +22,10 @@
# How to install. You may prefer "install" instead of "cp" if you have it.
# To remove debug information from binaries, use "install -s" in INSTALL_EXEC.
@@ -38,8 +38,8 @@
+ cd src; $(INSTALL_DATA) $(TO_INC) $(INSTALL_INC)
+ cd src; $(LIBTOOL) --mode=install $(INSTALL_DATA) liblua.la $(INSTALL_LIB)
+ cd src; $(LIBTOOL) --mode=install $(INSTALL_DATA) liblua.a $(INSTALL_LIB)
---- /home/mabi/gentoo/lua-5.1.1.orig/src/Makefile 2006-03-22 01:41:49.000000000 +0100
-+++ ./src/Makefile 2006-11-16 02:10:27.000000000 +0100
+--- lua-5.1.1.orig/src/Makefile 2006-03-22 01:41:49.000000000 +0100
++++ lua-5.1.1/src/Makefile 2006-11-16 02:10:27.000000000 +0100
@@ -176,3 +176,36 @@
ltm.h lzio.h lmem.h lopcodes.h lundump.h
@@ -64,16 +64,16 @@
+$(LIB_NAME:.la=.a): $(LIB_OBJS)
+ $(LIBTOOL) --mode=link $(CC) -static -o $(LIB_NAME:.la=.a) $(LIB_OBJS)
+
-+lua: $(LUA_O) $(LIB_NAME)
++$(LUA_T): $(LUA_O) $(LIB_NAME)
+ $(LIBTOOL) --mode=link $(CC) -Wl,-E -o $@ $(LUA_O) $(LUA_LIBS) -llua
+
+lua_test: $(LUA_O) $(LIB_NAME)
+ $(LIBTOOL) --mode=link $(CC) -static -Wl,-E -o $@ $(LUA_O) $(LIB_NAME) $(LUA_LIBS)
+
-+luac: $(LUAC_O) $(LIB_NAME)
++$(LUAC_T): $(LUAC_O) $(LIB_NAME)
+ $(LIBTOOL) --mode=link $(CC) -static -o $@ $(LUAC_O) $(LIB_NAME)
+
+gentoo_clean:
+ $(LIBTOOL) --mode=clean $(RM) $(ALL_O:.o=.lo) $(LIB_NAME) lua luac
+
-+gentoo_all: $(LIB_NAME) $(LIB_NAME:.la=.a) lua lua_test luac
++gentoo_all: $(LIB_NAME) $(LIB_NAME:.la=.a) $(LUA_T) lua_test $(LUAC_T)