summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2014-05-09 20:45:25 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2014-05-09 20:45:25 +0000
commitfd7421e473bf29d851025103f44c7af66c0cf454 (patch)
tree872a07565728ae6d52283c8e7dc7f2400d582f50 /dev-lang
parentBump to 2.3 (diff)
downloadgentoo-2-fd7421e473bf29d851025103f44c7af66c0cf454.tar.gz
gentoo-2-fd7421e473bf29d851025103f44c7af66c0cf454.tar.bz2
gentoo-2-fd7421e473bf29d851025103f44c7af66c0cf454.zip
Version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 09BF4F54C2BA7F3C!)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/jimtcl/ChangeLog9
-rw-r--r--dev-lang/jimtcl/jimtcl-0.75.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/dev-lang/jimtcl/ChangeLog b/dev-lang/jimtcl/ChangeLog
index 0827e4fb3975..f9af52d5184b 100644
--- a/dev-lang/jimtcl/ChangeLog
+++ b/dev-lang/jimtcl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/jimtcl
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/ChangeLog,v 1.11 2013/09/17 19:16:49 hwoarang Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/ChangeLog,v 1.12 2014/05/09 20:45:25 hwoarang Exp $
+
+*jimtcl-0.75 (09 May 2014)
+
+ 09 May 2014; Markos Chandras <hwoarang@gentoo.org> +jimtcl-0.75.ebuild:
+ Version bump
*jimtcl-0.74-r1 (17 Sep 2013)
diff --git a/dev-lang/jimtcl/jimtcl-0.75.ebuild b/dev-lang/jimtcl/jimtcl-0.75.ebuild
new file mode 100644
index 000000000000..6f77c553797f
--- /dev/null
+++ b/dev-lang/jimtcl/jimtcl-0.75.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/jimtcl-0.75.ebuild,v 1.1 2014/05/09 20:45:25 hwoarang Exp $
+
+EAPI="5"
+
+inherit multilib
+
+DESCRIPTION="Small footprint implementation of Tcl programming language"
+HOMEPAGE="http://jim.tcl.tk"
+SRC_URI="https://github.com/msteveb/jimtcl/zipball/${PV} -> ${P}.zip"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc static-libs"
+DEPEND="doc? ( app-text/asciidoc )
+ app-arch/unzip"
+
+GIT_HASH="cffd1a5"
+S="${WORKDIR}"/msteveb-${PN}-${GIT_HASH}
+
+src_configure() {
+ ! use static-libs && myconf=--with-jim-shared
+ econf ${myconf}
+}
+
+src_compile() {
+ emake all
+ use doc && emake docs
+}
+
+src_install() {
+ dobin jimsh
+ use static-libs && {
+ dolib.a libjim.a
+ } || {
+ dolib.so libjim.so.${PV}
+ dosym /usr/$(get_libdir)/libjim.so.${PV} \
+ /usr/$(get_libdir)/libjim.so
+ }
+ insinto /usr/include
+ doins jim.h jimautoconf.h jim-subcmd.h jim-signal.h
+ doins jim-win32compat.h jim-eventloop.h jim-config.h
+ dodoc AUTHORS README TODO
+ use doc && dohtml Tcl.html
+}