summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nelson <jnelson@gentoo.org>2002-05-30 03:11:35 +0000
committerJon Nelson <jnelson@gentoo.org>2002-05-30 03:11:35 +0000
commitff8ffdcd9121c592d96db2cad4381bc055d2e6f9 (patch)
tree911e8eb28f6979d080c6928b9928f5ec9ea50633 /dev-lang
parentmask python 2.2.1-r1 (diff)
downloadgentoo-2-ff8ffdcd9121c592d96db2cad4381bc055d2e6f9.tar.gz
gentoo-2-ff8ffdcd9121c592d96db2cad4381bc055d2e6f9.tar.bz2
gentoo-2-ff8ffdcd9121c592d96db2cad4381bc055d2e6f9.zip
depend on expat, use econf and emake. also, dont bother with Modules/Setup.local -- *shared* is turned on for Linux by default
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/files/digest-python-2.2.1-r11
-rw-r--r--dev-lang/python/python-2.2.1-r1.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-lang/python/files/digest-python-2.2.1-r1 b/dev-lang/python/files/digest-python-2.2.1-r1
new file mode 100644
index 000000000000..ea99f8857c06
--- /dev/null
+++ b/dev-lang/python/files/digest-python-2.2.1-r1
@@ -0,0 +1 @@
+MD5 e7012d611602b62e36073c2fd02396a3 Python-2.2.1.tgz 6535104
diff --git a/dev-lang/python/python-2.2.1-r1.ebuild b/dev-lang/python/python-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..b1b9eb34e8c5
--- /dev/null
+++ b/dev-lang/python/python-2.2.1-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.1-r1.ebuild,v 1.1 2002/05/30 03:11:35 jnelson Exp $
+
+PYVER_MAJOR="`echo ${PV} | cut -d '.' -f 1`"
+PYVER_MINOR="`echo ${PV} | cut -d '.' -f 2`"
+PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
+S=${WORKDIR}/Python-${PV}
+DESCRIPTION="A really great language"
+SRC_URI="http://www.python.org/ftp/python/${PV}/Python-${PV}.tgz"
+
+HOMEPAGE="http://www.python.org"
+LICENSE="PSF-2.2"
+
+DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
+ readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
+ berkdb? ( >=sys-libs/db-3 )
+ tcltk? ( >=dev-lang/tk-8.0 )
+ !build? ( !bootstrap? ( dev-libs/expat ) )"
+RDEPEND="$DEPEND dev-python/python-fchksum"
+
+# The dev-python/python-fchksum RDEPEND is needed to that this python provides
+# the functionality expected from previous pythons.
+
+PROVIDE="virtual/python"
+
+SLOT="2.2"
+
+src_compile() {
+ export OPT="$CFLAGS"
+
+ # adjust makefile to install pydoc into ${D} correctly
+ t=${S}/Makefile.pre.in
+ cp $t $t.orig || die
+ sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' $t.orig > $t
+
+ local myopts
+ #if we are creating a new build image, we remove the dependency on g++
+ if [ "`use build`" -a ! "`use bootstrap`" ]
+ then
+ myopts="--with-cxx=no"
+ fi
+
+ econf --with-fpectl \
+ --infodir='${prefix}'/share/info \
+ --mandir='${prefix}'/share/man \
+ $myopts || die
+ emake || die "Parallel make failed"
+}
+
+src_install() {
+ dodir /usr
+ make install prefix=${D}/usr || die
+ rm "${D}/usr/bin/python"
+ dosym python${PYVER_MAJOR} /usr/bin/python
+ dosym python${PYVER_MAJOR}.${PYVER_MINOR} /usr/bin/python${PYVER_MAJOR}
+ dodoc README
+
+ # install our own custom python-config
+ exeinto /usr/bin
+ newexe ${FILESDIR}/python-config-${PYVER} python-config
+
+ # seems like the build do not install Makefile.pre.in anymore
+ # it probably shouldn't - use DistUtils, people!
+ insinto /usr/lib/python${PYVER}/config
+ doins ${S}/Makefile.pre.in
+
+ # If USE tcltk lets install idle
+ # Need to script the python version in the path
+ if use tcltk; then
+ mkdir "${D}/usr/lib/python${PYVER}/tools"
+ mv "${S}/Tools/idle" "${D}/usr/lib/python${PYVER}/tools/"
+ dosym /usr/lib/python${PYVER}/tools/idle/idle.py /usr/bin/idle.py
+ fi
+}