summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-02 01:07:00 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-02 01:07:00 +0000
commit1c7456e61b61a79d70a9bafcf07fa860053100bd (patch)
treed92d4e79efac89b598519dff4a85542b2096f598 /dev-libs/DirectFB
parentMarked ~amd64, keywording KDE split ebuilds, bug 80944. (diff)
downloadgentoo-2-1c7456e61b61a79d70a9bafcf07fa860053100bd.tar.gz
gentoo-2-1c7456e61b61a79d70a9bafcf07fa860053100bd.tar.bz2
gentoo-2-1c7456e61b61a79d70a9bafcf07fa860053100bd.zip
Version bump.
(Portage version: 2.0.51.18)
Diffstat (limited to 'dev-libs/DirectFB')
-rw-r--r--dev-libs/DirectFB/ChangeLog9
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.20-r1.ebuild4
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.21.ebuild4
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.22.ebuild104
-rw-r--r--dev-libs/DirectFB/files/digest-DirectFB-0.9.221
5 files changed, 116 insertions, 6 deletions
diff --git a/dev-libs/DirectFB/ChangeLog b/dev-libs/DirectFB/ChangeLog
index 4f935c9a7444..e3716c5a6808 100644
--- a/dev-libs/DirectFB/ChangeLog
+++ b/dev-libs/DirectFB/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/DirectFB
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/ChangeLog,v 1.45 2004/12/24 10:24:31 vapier Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/ChangeLog,v 1.46 2005/03/02 01:07:00 vapier Exp $
+
+*DirectFB-0.9.22 (01 Mar 2005)
+
+ 01 Mar 2005; Mike Frysinger <vapier@gentoo.org> +DirectFB-0.9.22.ebuild:
+ Version bump.
*DirectFB-0.9.21 (24 Dec 2004)
diff --git a/dev-libs/DirectFB/DirectFB-0.9.20-r1.ebuild b/dev-libs/DirectFB/DirectFB-0.9.20-r1.ebuild
index e3cf104905ea..7548a02a017b 100644
--- a/dev-libs/DirectFB/DirectFB-0.9.20-r1.ebuild
+++ b/dev-libs/DirectFB/DirectFB-0.9.20-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.20-r1.ebuild,v 1.3 2004/12/05 00:18:36 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.20-r1.ebuild,v 1.4 2005/03/02 01:07:00 vapier Exp $
inherit eutils 64-bit flag-o-matic gcc
diff --git a/dev-libs/DirectFB/DirectFB-0.9.21.ebuild b/dev-libs/DirectFB/DirectFB-0.9.21.ebuild
index c8fd9c59615f..a0da52033dc4 100644
--- a/dev-libs/DirectFB/DirectFB-0.9.21.ebuild
+++ b/dev-libs/DirectFB/DirectFB-0.9.21.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.21.ebuild,v 1.2 2005/03/02 00:30:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.21.ebuild,v 1.3 2005/03/02 01:07:00 vapier Exp $
inherit eutils 64-bit flag-o-matic gcc
diff --git a/dev-libs/DirectFB/DirectFB-0.9.22.ebuild b/dev-libs/DirectFB/DirectFB-0.9.22.ebuild
new file mode 100644
index 000000000000..2654ed6a7c85
--- /dev/null
+++ b/dev-libs/DirectFB/DirectFB-0.9.22.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.22.ebuild,v 1.1 2005/03/02 01:07:00 vapier Exp $
+
+inherit eutils 64-bit flag-o-matic gcc
+
+IUSE_VIDEO_CARDS="ati128 cle266 cyber5k i810 mach64 matrox neomagic nsc nvidia radeon savage sis315 tdfx unichrome"
+
+DESCRIPTION="Thin library on top of the Linux framebuffer devices"
+HOMEPAGE="http://www.directfb.org/"
+SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 -mips ~ppc -sparc ~x86"
+IUSE="sdl jpeg gif png truetype mpeg mmx sse fusion debug fbcon static"
+
+DEPEND="sdl? ( media-libs/libsdl )
+ gif? ( media-libs/giflib )
+ png? ( media-libs/libpng )
+ jpeg? ( media-libs/jpeg )
+ mpeg? ( media-libs/libmpeg3 )
+ truetype? ( >=media-libs/freetype-2.0.1 )"
+
+pkg_setup() {
+ if [[ -z ${VIDEO_CARDS} ]] ; then
+ ewarn "All video drivers will be built since you did not specify"
+ ewarn "via the VIDEO_CARDS variable what video card you use."
+ einfo "DirectFB supports: ${IUSE_VIDEO_CARDS} all none"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ #36924
+ sed -i \
+ -e 's:wm97xx_ts=yes:wm97xx_ts=no:' configure \
+ || die "sed configure failed"
+
+
+ # This patch enables simd optimisations for amd64. Since mmx and sse are
+ # masked USE flags on amd64 due to their enabling x86 specific asm more
+ # often than not, we'll just enable them by default. All x86_64 cpus
+ # should support mmx and see. Travis Tilley <lv@gentoo.org>
+ use amd64 && epatch "${FILESDIR}"/0.9.21-simd-amd64.patch
+}
+
+src_compile() {
+ local vidcards card
+ for card in ${VIDEO_CARDS} ; do
+ has ${card} ${IUSE_VIDEO_CARDS} && vidcards="${vidcards},${card}"
+ done
+ [[ -z ${vidcards} ]] \
+ && vidcards="all" \
+ || vidcards="${vidcards:1}"
+
+ local sdlconf="--disable-sdl"
+ if use sdl ; then
+ # since SDL can link against DirectFB and trigger a
+ # dependency loop, only link against SDL if it isn't
+ # broken #61592
+ echo 'int main(){}' > sdl-test.c
+ $(gcc-getCC) sdl-test.c -lSDL 2>/dev/null \
+ && sdlconf="--enable-sdl" \
+ || ewarn "Disabling SDL since libSDL.so is broken"
+ fi
+
+ use mpeg && export CPPFLAGS="${CPPFLAGS} -I/usr/include/libmpeg3"
+ econf \
+ $(use_enable fbcon fbdev) \
+ $(use_enable mmx) \
+ $(use_enable sse) \
+ $(use_enable mpeg libmpeg3) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable gif) \
+ $(use_enable truetype freetype) \
+ $(use_enable fusion multi) \
+ $(use_enable debug) \
+ $(use_enable static) \
+ ${sdlconf} \
+ --with-gfxdrivers="${vidcards}" \
+ || die
+ emake || die
+}
+
+src_install() {
+ insinto /etc
+ doins fb.modes
+
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README* TODO
+ dohtml -r docs/html/*
+}
+
+pkg_postinst() {
+ ewarn "Each DirectFB update in the 0.9.xx series"
+ ewarn "breaks DirectFB related applications."
+ ewarn "Please run \"revdep-rebuild\" which can be"
+ ewarn "found by emerging the package 'gentoolkit'."
+}
diff --git a/dev-libs/DirectFB/files/digest-DirectFB-0.9.22 b/dev-libs/DirectFB/files/digest-DirectFB-0.9.22
new file mode 100644
index 000000000000..50320f188b72
--- /dev/null
+++ b/dev-libs/DirectFB/files/digest-DirectFB-0.9.22
@@ -0,0 +1 @@
+MD5 f52e23f4bb56db0d284d2a78ebc4a586 DirectFB-0.9.22.tar.gz 1957905