summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-11-08 22:03:45 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-11-08 22:03:45 +0000
commit91f2e5e6d43785f023d8ce15fe7b82a4ec0e1a3e (patch)
tree59f107bceca422d05a4054bf0e407603a128bfd8 /dev-libs/DirectFB
parentsmall fix0rs (diff)
downloadgentoo-2-91f2e5e6d43785f023d8ce15fe7b82a4ec0e1a3e.tar.gz
gentoo-2-91f2e5e6d43785f023d8ce15fe7b82a4ec0e1a3e.tar.bz2
gentoo-2-91f2e5e6d43785f023d8ce15fe7b82a4ec0e1a3e.zip
added note about econf and einstall
Diffstat (limited to 'dev-libs/DirectFB')
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.14.ebuild110
-rw-r--r--dev-libs/DirectFB/files/digest-DirectFB-0.9.141
2 files changed, 111 insertions, 0 deletions
diff --git a/dev-libs/DirectFB/DirectFB-0.9.14.ebuild b/dev-libs/DirectFB/DirectFB-0.9.14.ebuild
new file mode 100644
index 000000000000..4ce90f5a4a29
--- /dev/null
+++ b/dev-libs/DirectFB/DirectFB-0.9.14.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.14.ebuild,v 1.1 2002/11/08 22:03:45 seemant Exp $
+
+IUSE="gif quicktime mpeg png truetype flash jpeg mmx sse sdl"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="DirectFB is a thin library on top of the Linux framebuffer devices"
+SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
+HOMEPAGE="http://www.directfb.org/"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+
+DEPEND="sys-devel/perl
+ gif? ( media-libs/giflib )
+ png? ( media-libs/libpng )
+ jpeg? ( media-libs/jpeg )
+ mpeg? ( media-libs/libmpeg3 )
+ flash? ( >=media-libs/libflash-0.4.10 )
+ truetype? ( >=media-libs/freetype-2.0.1 )
+ quicktime? ( media-libs/quicktime4linux )"
+# avi? ( >=media-video/avifile-0.7.4.20020426-r2 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp configure configure.orig
+ sed -e 's:ac_safe=`echo "libmpeg3.h:ac_safe=`echo "libmpeg3/libmpeg3.h:' \
+ -e 's:#include <libmpeg3.h>:#include <libmpeg3/libmpeg3.h>:' \
+ configure.orig > configure
+}
+
+src_compile() {
+ local myconf=""
+
+ # Bug in the ./configure script that breaks if you
+ # have --enable-mmx
+ use mmx \
+ && myconf="${myconf} --enable-mmx" \
+ || myconf="${myconf} --disable-mmx"
+
+ use sse \
+ && myconf="${myconf} --enable-sse" \
+ || myconf="${myconf} --disable-sse"
+
+# Still do not work currently
+# use avi \
+# && myconf="${myconf} --enable-avifile" \
+# || myconf="${myconf} --disable-avifile"
+ myconf="${myconf} --disable-avifile"
+
+ use mpeg \
+ && myconf="${myconf} --enable-libmpeg3" \
+ || myconf="${myconf} --disable-libmpeg3"
+
+ use sdl \
+ && myconf="${myconf} --enable-sdl" \
+ || myconf="${myconf} --disable-sdl"
+
+ use flash \
+ && myconf="${myconf} --enable-flash" \
+ || myconf="${myconf} --disable-flash"
+
+ use jpeg \
+ && myconf="${myconf} --enable-jpeg" \
+ || myconf="${myconf} --disable-jpeg"
+
+ use png \
+ && myconf="${myconf} --enable-png" \
+ || myconf="${myconf} --disable-png"
+
+ use gif \
+ && myconf="${myconf} --enable-gif" \
+ || myconf="${myconf} --disable-gif"
+
+ use truetype \
+ && myconf="${myconf} --enable-freetype" \
+ || myconf="${myconf} --disable-freetype"
+
+ # fix gcc3.x linking with libflash
+ cp configure configure.old
+ sed -e 's:-lflash:-lflash -lstdc++:' configure.old > configure
+ econf ${myconf}
+
+ use mpeg && ( \
+ cd ${S}/interfaces/IDirectFBVideoProvider
+ cp idirectfbvideoprovider_libmpeg3.c \
+ idirectfbvideoprovider_libmpeg3.c.orig
+
+ sed s':#include <libmpeg3.h>:#include <libmpeg3/libmpeg3.h>:' \
+ idirectfbvideoprovider_libmpeg3.c.orig > \
+ idirectfbvideoprovider_libmpeg3.c
+ cd ${S}
+ )
+
+ # add extra -lstdc++ so libpng/libflash link correctly
+ make LDFLAGS="${LDFLAGS} -lstdc++" || die
+}
+
+src_install() {
+ insinto /etc
+ doins fb.modes
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
+ dohtml -r docs/html
+}
diff --git a/dev-libs/DirectFB/files/digest-DirectFB-0.9.14 b/dev-libs/DirectFB/files/digest-DirectFB-0.9.14
new file mode 100644
index 000000000000..02a2284cfdb1
--- /dev/null
+++ b/dev-libs/DirectFB/files/digest-DirectFB-0.9.14
@@ -0,0 +1 @@
+MD5 fc57b71776c27d448f98eaeffbcd09d1 DirectFB-0.9.14.tar.gz 881567