summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Stewart <vericgar@gentoo.org>2006-05-18 01:22:33 +0000
committerMichael Stewart <vericgar@gentoo.org>2006-05-18 01:22:33 +0000
commit80dfe6b633d16f464d4fb7105b795b47d7f645f4 (patch)
tree32021e5f54320ebaaf79343820e563f3b4a59525 /dev-libs/apr/apr-1.2.7.ebuild
parentNew release: 1.8.3 (diff)
downloadgentoo-2-80dfe6b633d16f464d4fb7105b795b47d7f645f4.tar.gz
gentoo-2-80dfe6b633d16f464d4fb7105b795b47d7f645f4.tar.bz2
gentoo-2-80dfe6b633d16f464d4fb7105b795b47d7f645f4.zip
Fix sem_open related sandbox violations. Resolves bug 133573.
(Portage version: 2.1_rc1-r2)
Diffstat (limited to 'dev-libs/apr/apr-1.2.7.ebuild')
-rw-r--r--dev-libs/apr/apr-1.2.7.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-libs/apr/apr-1.2.7.ebuild b/dev-libs/apr/apr-1.2.7.ebuild
index fcda9e91a9ea..be50bcb13612 100644
--- a/dev-libs/apr/apr-1.2.7.ebuild
+++ b/dev-libs/apr/apr-1.2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/apr-1.2.7.ebuild,v 1.2 2006/04/19 00:55:06 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/apr-1.2.7.ebuild,v 1.3 2006/05/18 01:22:33 vericgar Exp $
inherit libtool
@@ -31,6 +31,14 @@ src_compile() {
einfo "Using /dev/random as random device"
myconf="${myconf} --with-devrandom=/dev/random"
fi
+
+ # We pre-load the cache with the correct answer! This avoids
+ # it violating the sandbox. This may have to be changed for
+ # non-Linux systems or if sem_open changes on Linux. This
+ # hack is built around documentation in /usr/include/semaphore.h
+ # and the glibc (pthread) source
+ # See bugs 24215 and 133573
+ echo 'ac_cv_func_sem_open=${ac_cv_func_sem_open=no}' >> ${S}/config.cache
econf ${myconf} || die "Configure failed"
emake || die "Make failed"