summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2007-07-30 21:42:59 +0000
committerBenedikt Boehm <hollow@gentoo.org>2007-07-30 21:42:59 +0000
commitccf8b1f96cb32c70f69d8169a496365784df88f3 (patch)
tree0f57acd67211bb533677eb3fbf684a3a2239ec9a /dev-libs/apr
parentFix compilation with gcc 4.2. Closes bug #186706. Thanks to Tiziano for the p... (diff)
downloadgentoo-2-ccf8b1f96cb32c70f69d8169a496365784df88f3.tar.gz
gentoo-2-ccf8b1f96cb32c70f69d8169a496365784df88f3.tar.bz2
gentoo-2-ccf8b1f96cb32c70f69d8169a496365784df88f3.zip
version bump
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'dev-libs/apr')
-rw-r--r--dev-libs/apr/ChangeLog7
-rw-r--r--dev-libs/apr/apr-1.2.9.ebuild85
-rw-r--r--dev-libs/apr/files/digest-apr-1.2.93
3 files changed, 94 insertions, 1 deletions
diff --git a/dev-libs/apr/ChangeLog b/dev-libs/apr/ChangeLog
index eac2a1a17543..0bcdb1f92c33 100644
--- a/dev-libs/apr/ChangeLog
+++ b/dev-libs/apr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/apr
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.88 2007/06/27 19:54:59 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.89 2007/07/30 21:42:59 hollow Exp $
+
+*apr-1.2.9 (30 Jul 2007)
+
+ 30 Jul 2007; Benedikt Böhm <hollow@gentoo.org> +apr-1.2.9.ebuild:
+ version bump
27 Jun 2007; Lars Weiler <pylon@gentoo.org> apr-1.2.8.ebuild:
Stable on ppc; bug #178264.
diff --git a/dev-libs/apr/apr-1.2.9.ebuild b/dev-libs/apr/apr-1.2.9.ebuild
new file mode 100644
index 000000000000..2a114691aa69
--- /dev/null
+++ b/dev-libs/apr/apr-1.2.9.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/apr-1.2.9.ebuild,v 1.1 2007/07/30 21:42:59 hollow Exp $
+
+inherit autotools
+
+DESCRIPTION="Apache Portable Runtime Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
+IUSE="ipv6 urandom debug"
+RESTRICT="test"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # for some reason not all the .m4 files that are referenced in
+ # configure.in exist, so we remove all references and include every
+ # .m4 file in build using aclocal via eautoreconf
+ # See bug 135463
+ sed -i -e '/sinclude/d' configure.in
+ AT_M4DIR="build" eautoreconf
+
+ epatch "${FILESDIR}"/config.layout.patch
+}
+
+src_compile() {
+ # For now we always enable ipv6. Testing has shown that is still works
+ # correctly in ipv4 systems, and currently, the ipv4-only support
+ # is broken in apr. (ipv6 is enabled by default)
+ #myconf="${myconf} $(use_enable ipv6)"
+
+ if use urandom; then
+ myconf="${myconf} --with-devrandom=/dev/urandom"
+ else
+ myconf="${myconf} --with-devrandom=/dev/random"
+ fi
+
+ use debug && myconf="${myconf} --enable-maintainer-mode"
+
+ # We pre-load the cache with the correct answer! This avoids
+ # it violating the sandbox. This may have to be changed for
+ # non-Linux systems or if sem_open changes on Linux. This
+ # hack is built around documentation in /usr/include/semaphore.h
+ # and the glibc (pthread) source
+ # See bugs 24215 and 133573
+ echo 'ac_cv_func_sem_open=${ac_cv_func_sem_open=no}' >> "${S}"/config.cache
+
+ econf --enable-layout=gentoo \
+ --enable-threads \
+ --enable-nonportable-atomics \
+ ${myconf} || die "econf failed!"
+
+ # Make sure we use the system libtool
+ sed -i 's,$(apr_builddir)/libtool,/usr/bin/libtool,' "${S}"/build/apr_rules.mk
+ sed -i 's,${installbuilddir}/libtool,/usr/bin/libtool,' "${S}"/apr-1-config
+ rm -f "${S}"/libtool
+
+ emake || die "Make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # This file is only used on AIX systems, which gentoo is not,
+ # and causes collisions between the SLOTs, so kill it
+ rm "${D}"/usr/$(get_libdir)/apr.exp
+
+ dodoc CHANGES NOTICE
+}
+
+pkg_postinst() {
+ ewarn "We are now using the system's libtool rather then bundling"
+ ewarn "our own. You will need to rebuild Apache and possibly other"
+ ewarn "software if you get a message similiar to the following:"
+ ewarn
+ ewarn " /usr/share/apr-1/build-1/libtool: No such file or directory"
+ ewarn
+}
diff --git a/dev-libs/apr/files/digest-apr-1.2.9 b/dev-libs/apr/files/digest-apr-1.2.9
new file mode 100644
index 000000000000..c2b00d0cf771
--- /dev/null
+++ b/dev-libs/apr/files/digest-apr-1.2.9
@@ -0,0 +1,3 @@
+MD5 6f4b063ac01a54ba0818c31280f06959 apr-1.2.9.tar.gz 1109990
+RMD160 02d5e81c4bcc389a7c28dd19b96b792fad729ba8 apr-1.2.9.tar.gz 1109990
+SHA256 a41608b5ecd76b5d555b853c9907d55d1cf20e9d1686923eccbc1437ef967d13 apr-1.2.9.tar.gz 1109990