summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2013-06-13 00:50:14 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2013-06-13 00:50:14 +0000
commit0d284fffd3eb960a9acf81cdc2e69681ab22cc13 (patch)
tree6404d04ad95d156f0a6cf289281ade6f261f1280 /dev-libs/bitset
parentUpdate 2.1.8 with eclass bump and new python variable and inherit (diff)
downloadgentoo-2-0d284fffd3eb960a9acf81cdc2e69681ab22cc13.tar.gz
gentoo-2-0d284fffd3eb960a9acf81cdc2e69681ab22cc13.tar.bz2
gentoo-2-0d284fffd3eb960a9acf81cdc2e69681ab22cc13.zip
Version bump. Fixes bug 472806.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key D1BBFDA0)
Diffstat (limited to 'dev-libs/bitset')
-rw-r--r--dev-libs/bitset/ChangeLog7
-rw-r--r--dev-libs/bitset/bitset-2.8.4.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-libs/bitset/ChangeLog b/dev-libs/bitset/ChangeLog
index 5b902822390e..4ac0026d2999 100644
--- a/dev-libs/bitset/ChangeLog
+++ b/dev-libs/bitset/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/bitset
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/bitset/ChangeLog,v 1.6 2013/04/15 08:51:37 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/bitset/ChangeLog,v 1.7 2013/06/13 00:50:14 titanofold Exp $
+
+*bitset-2.8.4 (13 Jun 2013)
+
+ 13 Jun 2013; Aaron W. Swenson <titanofold@gentoo.org> +bitset-2.8.4.ebuild:
+ Version bump. Fixes bug 472806.
15 Apr 2013; Agostino Sarubbo <ago@gentoo.org> bitset-2.8.3.ebuild:
Stable for x86, wrt bug #465674
diff --git a/dev-libs/bitset/bitset-2.8.4.ebuild b/dev-libs/bitset/bitset-2.8.4.ebuild
new file mode 100644
index 000000000000..e76b6191d6c3
--- /dev/null
+++ b/dev-libs/bitset/bitset-2.8.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/bitset/bitset-2.8.4.ebuild,v 1.1 2013/06/13 00:50:14 titanofold Exp $
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="A compressed bitset with supporting data structures and algorithms"
+HOMEPAGE="http://github.com/chriso/bitset"
+SRC_URI="https://github.com/chriso/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="jemalloc static-libs tcmalloc"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="tcmalloc? ( dev-util/google-perftools )
+ jemalloc? ( >=dev-libs/jemalloc-3.2 )"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="?? ( jemalloc tcmalloc )"
+
+DOCS=( README.md )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with jemalloc) \
+ $(use_with tcmalloc)
+ )
+ autotools-utils_src_configure
+}