summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-07-02 04:13:11 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-07-02 04:13:11 +0000
commitcc64b4e30922101afbbced093f919c2fbb86b9a2 (patch)
tree9c0bd0045c288b00f5e5f268e7500fbb6df48299 /dev-libs/boost
parentVersion bump. (diff)
downloadgentoo-2-cc64b4e30922101afbbced093f919c2fbb86b9a2.tar.gz
gentoo-2-cc64b4e30922101afbbced093f919c2fbb86b9a2.tar.bz2
gentoo-2-cc64b4e30922101afbbced093f919c2fbb86b9a2.zip
Replace -fno-strict-aliasing workaround with -Wno-strict-aliasing, which
does the job and avoids the performance hit. Also apply to 1.35 and 1.36. (Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog7
-rw-r--r--dev-libs/boost/boost-1.35.0-r5.ebuild5
-rw-r--r--dev-libs/boost/boost-1.36.0-r1.ebuild5
-rw-r--r--dev-libs/boost/boost-1.37.0-r1.ebuild6
4 files changed, 17 insertions, 6 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 8faedc36765a..9d10a22ed3b3 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/boost
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.162 2009/06/15 18:31:33 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.163 2009/07/02 04:13:11 dirtyepic Exp $
+
+ 02 Jul 2009; Ryan Hill <dirtyepic@gentoo.org> boost-1.35.0-r5.ebuild,
+ boost-1.36.0-r1.ebuild, boost-1.37.0-r1.ebuild:
+ Replace -fno-strict-aliasing workaround with -Wno-strict-aliasing, which
+ does the job and avoids the performance hit. Also apply to 1.35 and 1.36.
15 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
boost-1.37.0-r1.ebuild:
diff --git a/dev-libs/boost/boost-1.35.0-r5.ebuild b/dev-libs/boost/boost-1.35.0-r5.ebuild
index 4557388c9513..c28784055512 100644
--- a/dev-libs/boost/boost-1.35.0-r5.ebuild
+++ b/dev-libs/boost/boost-1.35.0-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.35.0-r5.ebuild,v 1.4 2009/05/15 10:42:27 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.35.0-r5.ebuild,v 1.5 2009/07/02 04:13:11 dirtyepic Exp $
EAPI="2"
@@ -103,6 +103,9 @@ src_configure() {
compilerExecutable=$(tc-getCXX)
fi
+ # Huge number of strict-aliasing warnings cause a build failure w/ >= GCC 4.4 bug #252287
+ [[ $(gcc-version) > 4.3 ]] && append-flags -Wno-strict-aliasing
+
use mpi && mpi="using mpi ;"
if use python ; then
diff --git a/dev-libs/boost/boost-1.36.0-r1.ebuild b/dev-libs/boost/boost-1.36.0-r1.ebuild
index 7d8ca5b21ae2..7c9e5695dd86 100644
--- a/dev-libs/boost/boost-1.36.0-r1.ebuild
+++ b/dev-libs/boost/boost-1.36.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.36.0-r1.ebuild,v 1.5 2009/05/24 05:42:24 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.36.0-r1.ebuild,v 1.6 2009/07/02 04:13:11 dirtyepic Exp $
EAPI="2"
@@ -101,6 +101,9 @@ src_configure() {
compilerExecutable=$(tc-getCXX)
fi
+ # Huge number of strict-aliasing warnings cause a build failure w/ >= GCC4.4 bug #252287
+ [[ $(gcc-version) > 4.3 ]] && append-flags -Wno-strict-aliasing
+
use mpi && mpi="using mpi ;"
if use python ; then
diff --git a/dev-libs/boost/boost-1.37.0-r1.ebuild b/dev-libs/boost/boost-1.37.0-r1.ebuild
index f487409a914d..578a87ed8137 100644
--- a/dev-libs/boost/boost-1.37.0-r1.ebuild
+++ b/dev-libs/boost/boost-1.37.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.37.0-r1.ebuild,v 1.8 2009/06/15 18:31:33 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.37.0-r1.ebuild,v 1.9 2009/07/02 04:13:11 dirtyepic Exp $
EAPI="2"
@@ -117,8 +117,8 @@ src_configure() {
compilerExecutable=$(tc-getCXX)
fi
- # Temporary workaround for bug #252287
- [[ $(gcc-version) == "4.4" ]] && append-flags -fno-strict-aliasing
+ # Huge number of strict-aliasing warnings cause a build failure w/ >= GCC 4.4 bug #252287
+ [[ $(gcc-version) > 4.3 ]] && append-flags -Wno-strict-aliasing
use mpi && mpi="using mpi ;"