summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2009-12-02 14:32:19 +0000
committerDirkjan Ochtman <djc@gentoo.org>2009-12-02 14:32:19 +0000
commitf9649d4cc31d549f54608d43d0c73f6cb50c07ca (patch)
treeab19da4aaf3d94924fa43e6796116aad8d3c9c7e /dev-libs/boost
parentVersion bumped. (diff)
downloadgentoo-2-f9649d4cc31d549f54608d43d0c73f6cb50c07ca.tar.gz
gentoo-2-f9649d4cc31d549f54608d43d0c73f6cb50c07ca.tar.bz2
gentoo-2-f9649d4cc31d549f54608d43d0c73f6cb50c07ca.zip
Version bump dev-libs/boost to 1.41.0.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog10
-rw-r--r--dev-libs/boost/boost-1.41.0.ebuild426
-rw-r--r--dev-libs/boost/files/boost-1.41.0-mpi_process_group-missing-include.patch12
-rw-r--r--dev-libs/boost/files/boost-1.41.0-parameter-needs-python.patch106
-rw-r--r--dev-libs/boost/files/remove-toolset-1.41.0.patch11
-rw-r--r--dev-libs/boost/metadata.xml4
6 files changed, 568 insertions, 1 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index d26dee53ad17..afb60c281a70 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/boost
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.176 2009/11/25 17:59:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.177 2009/12/02 14:32:19 djc Exp $
+
+*boost-1.41.0 (02 Dec 2009)
+
+ 02 Dec 2009; Dirkjan Ochtman <djc@gentoo.org> +boost-1.41.0.ebuild,
+ +files/boost-1.41.0-mpi_process_group-missing-include.patch,
+ +files/boost-1.41.0-parameter-needs-python.patch,
+ +files/remove-toolset-1.41.0.patch, metadata.xml:
+ Version bump to 1.41.0. Add maintainer-by-proxy.
25 Nov 2009; Jeroen Roovers <jer@gentoo.org> boost-1.36.0-r1.ebuild,
boost-1.37.0-r1.ebuild, boost-1.39.0.ebuild, boost-1.40.0.ebuild:
diff --git a/dev-libs/boost/boost-1.41.0.ebuild b/dev-libs/boost/boost-1.41.0.ebuild
new file mode 100644
index 000000000000..693cbaba13f6
--- /dev/null
+++ b/dev-libs/boost/boost-1.41.0.ebuild
@@ -0,0 +1,426 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.41.0.ebuild,v 1.1 2009/12/02 14:32:19 djc Exp $
+
+EAPI="2"
+
+inherit python flag-o-matic multilib toolchain-funcs versionator check-reqs
+
+MY_P=${PN}_$(replace_all_version_separators _)
+
+DESCRIPTION="Boost Libraries for C++"
+HOMEPAGE="http://www.boost.org/"
+SRC_URI="mirror://sourceforge/boost/${MY_P}.tar.bz2"
+LICENSE="Boost-1.0"
+SLOT="$(get_version_component_range 1-2)"
+IUSE="debug doc +eselect expat icu mpi python test tools"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+RDEPEND="icu? ( >=dev-libs/icu-3.3 )
+ expat? ( dev-libs/expat )
+ mpi? ( || ( >=sys-cluster/openmpi-1.2.9[cxx] <sys-cluster/openmpi-1.2.9[-nocxx] sys-cluster/mpich2[cxx] sys-cluster/lam-mpi ) )
+ sys-libs/zlib
+ python? ( virtual/python )
+ !!<=dev-libs/boost-1.35.0-r2
+ >=app-admin/eselect-boost-0.3"
+DEPEND="${RDEPEND}
+ dev-util/boost-build:${SLOT}"
+
+S=${WORKDIR}/${MY_P}
+
+MAJOR_PV=$(replace_all_version_separators _ ${SLOT})
+BJAM="bjam-${MAJOR_PV}"
+
+# Usage:
+# _add_line <line-to-add> <profile>
+# ... to add to specific profile
+# or
+# _add_line <line-to-add>
+# ... to add to all profiles for which the use flag set
+
+_add_line() {
+ if [ -z "$2" ] ; then
+ echo "${1}" >> "${D}/usr/share/boost-eselect/profiles/${SLOT}/default"
+ use debug && echo "${1}" >> "${D}/usr/share/boost-eselect/profiles/${SLOT}/debug"
+ else
+ echo "${1}" >> "${D}/usr/share/boost-eselect/profiles/${SLOT}/${2}"
+ fi
+}
+
+pkg_setup() {
+ if use test ; then
+ CHECKREQS_DISK_BUILD="1024"
+ check_reqs
+
+ ewarn "The tests may take several hours on a recent machine"
+ ewarn "but they will not fail (unless something weird happens ;-)"
+ ewarn "This is because the tests depend on the used compiler/-version"
+ ewarn "and the platform and upstream says that this is normal."
+ ewarn "If you are interested in the results, please take a look at the"
+ ewarn "generated results page:"
+ ewarn " ${ROOT}usr/share/doc/${PF}/status/cs-$(uname).html"
+ ebeep 5
+
+ fi
+
+ if use debug ; then
+ ewarn "The debug USE-flag means that a second set of the boost libraries"
+ ewarn "will be built containing debug-symbols. You'll be able to select them"
+ ewarn "using the boost-eselect module. But even though the optimization flags"
+ ewarn "you might have set are not stripped, there will be a performance"
+ ewarn "penalty and linking other packages against the debug version"
+ ewarn "of boost is _not_ recommended."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/remove-toolset-${PV}.patch"
+
+ # bug 291660
+ epatch "${FILESDIR}/boost-${PV}-parameter-needs-python.patch"
+
+ # http://thread.gmane.org/gmane.comp.lib.boost.devel/196471
+ epatch "${FILESDIR}/boost-${PV}-mpi_process_group-missing-include.patch"
+
+ # This enables building the boost.random library with /dev/urandom support
+ if [[ -e /dev/urandom ]] ; then
+ mkdir -p libs/random/build
+ cp "${FILESDIR}/random-Jamfile" libs/random/build/Jamfile.v2
+ # yeah, we WANT it to work on non-Linux too
+ sed -i -e 's/#ifdef __linux__/#if 1/' libs/random/random_device.cpp || die
+ fi
+}
+
+src_configure() {
+ einfo "Writing new user-config.jam"
+
+ local compiler compilerVersion compilerExecutable mpi
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ compiler=darwin
+ compilerVersion=$(gcc-fullversion)
+ compilerExecutable=$(tc-getCXX)
+ # we need to add the prefix, and in two cases this exceeds, so prepare
+ # for the largest possible space allocation
+ append-ldflags -Wl,-headerpad_max_install_names
+ else
+ compiler=gcc
+ compilerVersion=$(gcc-version)
+ compilerExecutable=$(tc-getCXX)
+ fi
+
+ # Using -fno-strict-aliasing to prevent possible creation of invalid code.
+ append-flags -fno-strict-aliasing
+
+ use mpi && mpi="using mpi ;"
+
+ if use python ; then
+ python_version
+ pystring="using python : ${PYVER} : /usr : /usr/include/python${PYVER} : /usr/lib/python${PYVER} ;"
+ fi
+
+ cat > "${S}/user-config.jam" << __EOF__
+
+variant gentoorelease : release : <optimization>none <debug-symbols>none ;
+variant gentoodebug : debug : <optimization>none ;
+
+using ${compiler} : ${compilerVersion} : ${compilerExecutable} : <cxxflags>"${CXXFLAGS}" <linkflags>"${LDFLAGS}" ;
+
+${pystring}
+
+${mpi}
+
+__EOF__
+
+ # Maintainer information:
+ # The debug-symbols=none and optimization=none
+ # are not official upstream flags but a Gentoo
+ # specific patch to make sure that all our
+ # CXXFLAGS/LDFLAGS are being respected.
+ # Using optimization=off would for example add
+ # "-O0" and override "-O2" set by the user.
+ # Please take a look at the boost-build ebuild
+ # for more infomration.
+
+ use icu && OPTIONS="-sICU_PATH=/usr"
+ use expat && OPTIONS="${OPTIONS} -sEXPAT_INCLUDE=/usr/include -sEXPAT_LIBPATH=/usr/$(get_libdir)"
+ use mpi || OPTIONS="${OPTIONS} --without-mpi"
+ use python || OPTIONS="${OPTIONS} --without-python"
+
+ # https://svn.boost.org/trac/boost/attachment/ticket/2597/add-disable-long-double.patch
+ if use sparc || use mips || use hppa || use arm || use x86-fbsd; then
+ OPTIONS="${OPTIONS} --disable-long-double"
+ fi
+
+ OPTIONS="${OPTIONS} --user-config=\"${S}/user-config.jam\" --boost-build=/usr/share/boost-build-${MAJOR_PV} --prefix=\"${D}/usr\" --layout=versioned"
+
+}
+
+src_compile() {
+
+ NUMJOBS=$(sed -r -e 's/--jobs=?/-j/; s/.*(-j ?[0-9]+).*/\1/' <<< ${MAKEOPTS})
+
+ einfo "Using the following options to build: "
+ einfo " ${OPTIONS}"
+
+ export BOOST_ROOT="${S}"
+
+ ${BJAM} ${NUMJOBS} -q \
+ gentoorelease \
+ ${OPTIONS} \
+ threading=single,multi link=shared,static runtime-link=shared \
+ || die "building boost failed"
+
+ # ... and do the whole thing one more time to get the debug libs
+ if use debug ; then
+ ${BJAM} ${NUMJOBS} -q \
+ gentoodebug \
+ ${OPTIONS} \
+ threading=single,multi link=shared,static runtime-link=shared \
+ --buildid=debug \
+ || die "building boost failed"
+ fi
+
+ if use tools; then
+ cd "${S}/tools/"
+ ${BJAM} ${NUMJOBS} -q \
+ gentoorelease \
+ ${OPTIONS} \
+ || die "building tools failed"
+ fi
+
+}
+
+src_install () {
+ einfo "Using the following options to install: "
+ einfo " ${OPTIONS}"
+
+ export BOOST_ROOT="${S}"
+
+ ${BJAM} -q \
+ gentoorelease \
+ ${OPTIONS} \
+ threading=single,multi link=shared,static runtime-link=shared \
+ --includedir="${D}/usr/include" \
+ --libdir="${D}/usr/$(get_libdir)" \
+ install || die "install failed for options '${OPTIONS}'"
+
+ if use debug ; then
+ ${BJAM} -q \
+ gentoodebug \
+ ${OPTIONS} \
+ threading=single,multi link=shared,static runtime-link=shared \
+ --includedir="${D}/usr/include" \
+ --libdir="${D}/usr/$(get_libdir)" \
+ --buildid=debug \
+ install || die "install failed for options '${OPTIONS}'"
+ fi
+
+ use python || rm -rf "${D}/usr/include/boost-${MAJOR_PV}/boost"/python*
+
+ dodir /usr/share/boost-eselect/profiles/${SLOT}
+ touch "${D}/usr/share/boost-eselect/profiles/${SLOT}/default"
+ use debug && touch "${D}/usr/share/boost-eselect/profiles/${SLOT}/debug"
+
+ # Move the mpi.so to the right place and make sure it's slotted
+ if use mpi && use python; then
+ mkdir -p "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}"
+ mv "${D}/usr/$(get_libdir)/mpi.so" "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}/"
+ touch "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}/__init__.py"
+ _add_line "python=\"/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}/mpi.so\""
+ fi
+
+ if use doc ; then
+ find libs/*/* -iname "test" -or -iname "src" | xargs rm -rf
+ dohtml \
+ -A pdf,txt,cpp,hpp \
+ *.{htm,html,png,css} \
+ -r doc more people wiki
+ dohtml \
+ -A pdf,txt \
+ -r tools
+ insinto /usr/share/doc/${PF}/html
+ doins -r libs
+
+ # To avoid broken links
+ insinto /usr/share/doc/${PF}/html
+ doins LICENSE_1_0.txt
+
+ dosym /usr/include/boost-${MAJOR_PV}/boost /usr/share/doc/${PF}/html/boost
+ fi
+
+ cd "${D}/usr/$(get_libdir)"
+
+ # Remove (unversioned) symlinks
+ # And check for what we remove to catch bugs
+ # got a better idea how to do it? tell me!
+ for f in $(ls -1 *{.a,$(get_libname)} | grep -v "${MAJOR_PV}") ; do
+ if [ ! -h "${f}" ] ; then
+ eerror "Ups, tried to remove '${f}' which is a a real file instead of a symlink"
+ die "slotting/naming of the libs broken!"
+ fi
+ rm "${f}"
+ done
+
+ # The threading libs obviously always gets the "-mt" (multithreading) tag
+ # some packages seem to have a problem with it. Creating symlinks...
+ for lib in libboost_thread-mt-${MAJOR_PV}{.a,$(get_libname)} ; do
+ dosym ${lib} "/usr/$(get_libdir)/$(sed -e 's/-mt//' <<< ${lib})"
+ done
+
+ # The same goes for the mpi libs
+ if use mpi ; then
+ for lib in libboost_mpi-mt-${MAJOR_PV}{.a,$(get_libname)} ; do
+ dosym ${lib} "/usr/$(get_libdir)/$(sed -e 's/-mt//' <<< ${lib})"
+ done
+ fi
+
+ if use debug ; then
+ for lib in libboost_thread-mt-${MAJOR_PV}-debug{.a,$(get_libname)} ; do
+ dosym ${lib} "/usr/$(get_libdir)/$(sed -e 's/-mt//' <<< ${lib})"
+ done
+
+ if use mpi ; then
+ for lib in libboost_mpi-mt-${MAJOR_PV}-debug{.a,$(get_libname)} ; do
+ dosym ${lib} "/usr/$(get_libdir)/$(sed -e 's/-mt//' <<< ${lib})"
+ done
+ fi
+ fi
+
+ # Create a subdirectory with completely unversioned symlinks
+ # and store the names in the profiles-file for eselect
+ dodir /usr/$(get_libdir)/boost-${MAJOR_PV}
+
+ _add_line "libs=\"" default
+ for f in $(ls -1 *{.a,$(get_libname)} | grep -v debug) ; do
+ dosym ../${f} /usr/$(get_libdir)/boost-${MAJOR_PV}/${f/-${MAJOR_PV}}
+ _add_line "/usr/$(get_libdir)/${f}" default
+ done
+ _add_line "\"" default
+
+ if use debug ; then
+ _add_line "libs=\"" debug
+ dodir /usr/$(get_libdir)/boost-${MAJOR_PV}-debug
+ for f in $(ls -1 *{.a,$(get_libname)} | grep debug) ; do
+ dosym ../${f} /usr/$(get_libdir)/boost-${MAJOR_PV}-debug/${f/-${MAJOR_PV}-debug}
+ _add_line "/usr/$(get_libdir)/${f}" debug
+ done
+ _add_line "\"" debug
+
+ _add_line "includes=\"/usr/include/boost-${MAJOR_PV}/boost\"" debug
+ _add_line "suffix=\"-debug\"" debug
+ fi
+
+ _add_line "includes=\"/usr/include/boost-${MAJOR_PV}/boost\"" default
+
+ if use tools; then
+ cd "${S}/dist/bin"
+ # Append version postfix to binaries for slotting
+ _add_line "bins=\""
+ for b in * ; do
+ newbin "${b}" "${b}-${MAJOR_PV}"
+ _add_line "/usr/bin/${b}-${MAJOR_PV}"
+ done
+ _add_line "\""
+
+ cd "${S}/dist"
+ insinto /usr/share
+ doins -r share/boostbook
+ # Append version postfix for slotting
+ mv "${D}/usr/share/boostbook" "${D}/usr/share/boostbook-${MAJOR_PV}"
+ _add_line "dirs=\"/usr/share/boostbook-${MAJOR_PV}\""
+ fi
+
+ cd "${S}/status"
+ if [ -f regress.log ] ; then
+ docinto status
+ dohtml *.{html,gif} ../boost.png
+ dodoc regress.log
+ fi
+
+ use python && python_need_rebuild
+
+ # boost's build system truely sucks for not having a destdir. Because for
+ # this reason we are forced to build with a prefix that includes the
+ # DESTROOT, dynamic libraries on Darwin end messed up, referencing the
+ # DESTROOT instread of the actual EPREFIX. There is no way out of here
+ # but to do it the dirty way of manually setting the right install_names.
+ [[ -z ${ED+set} ]] && local ED=${D%/}${EPREFIX}/
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ einfo "Working around completely broken build-system(tm)"
+ for d in "${ED}"usr/lib/*.dylib ; do
+ if [[ -f ${d} ]] ; then
+ # fix the "soname"
+ ebegin " correcting install_name of ${d#${ED}}"
+ install_name_tool -id "/${d#${D}}" "${d}"
+ eend $?
+ # fix references to other libs
+ refs=$(otool -XL "${d}" | \
+ sed -e '1d' -e 's/^\t//' | \
+ grep "^libboost_" | \
+ cut -f1 -d' ')
+ for r in ${refs} ; do
+ ebegin " correcting reference to ${r}"
+ install_name_tool -change \
+ "${r}" \
+ "${EPREFIX}/usr/lib/${r}" \
+ "${d}"
+ eend $?
+ done
+ fi
+ done
+ fi
+}
+
+src_test() {
+ export BOOST_ROOT=${S}
+
+ cd "${S}/tools/regression/build"
+ ${BJAM} -q \
+ gentoorelease \
+ ${OPTIONS} \
+ process_jam_log compiler_status \
+ || die "building regression test helpers failed"
+
+ cd "${S}/status"
+
+ # Some of the test-checks seem to rely on regexps
+ export LC_ALL="C"
+
+ # The following is largely taken from tools/regression/run_tests.sh,
+ # but adapted to our needs.
+
+ # Run the tests & write them into a file for postprocessing
+ ${BJAM} \
+ ${OPTIONS} \
+ --dump-tests 2>&1 | tee regress.log
+
+ # Postprocessing
+ cat regress.log | "${S}/tools/regression/build/bin/gcc-$(gcc-version)/gentoorelease/process_jam_log" --v2
+ if test $? != 0 ; then
+ die "Postprocessing the build log failed"
+ fi
+
+ cat > "${S}/status/comment.html" <<- __EOF__
+ <p>Tests are run on a <a href="http://www.gentoo.org">Gentoo</a> system.</p>
+__EOF__
+
+ # Generate the build log html summary page
+ "${S}/tools/regression/build/bin/gcc-$(gcc-version)/gentoorelease/compiler_status" --v2 \
+ --comment "${S}/status/comment.html" "${S}" \
+ cs-$(uname).html cs-$(uname)-links.html
+ if test $? != 0 ; then
+ die "Generating the build log html summary page failed"
+ fi
+
+ # And do some cosmetic fixes :)
+ sed -i -e 's|http://www.boost.org/boost.png|boost.png|' *.html
+}
+
+pkg_postinst() {
+ use eselect && eselect boost update
+ if [ ! -h "${ROOT}/etc/eselect/boost/active" ] ; then
+ elog "No active boost version found. Calling eselect to select one..."
+ eselect boost update
+ fi
+}
diff --git a/dev-libs/boost/files/boost-1.41.0-mpi_process_group-missing-include.patch b/dev-libs/boost/files/boost-1.41.0-mpi_process_group-missing-include.patch
new file mode 100644
index 000000000000..13f7b8a4e83c
--- /dev/null
+++ b/dev-libs/boost/files/boost-1.41.0-mpi_process_group-missing-include.patch
@@ -0,0 +1,12 @@
+Index: boost/graph/distributed/detail/mpi_process_group.ipp
+===================================================================
+--- boost/graph/distributed/detail/mpi_process_group.ipp (revision 57744)
++++ boost/graph/distributed/detail/mpi_process_group.ipp (working copy)
+@@ -28,6 +28,7 @@
+ #include <queue>
+ #include <stack>
+ #include <boost/graph/distributed/detail/tag_allocator.hpp>
++#include <stdio.h>
+
+ // #define PBGL_PROCESS_GROUP_DEBUG
+
diff --git a/dev-libs/boost/files/boost-1.41.0-parameter-needs-python.patch b/dev-libs/boost/files/boost-1.41.0-parameter-needs-python.patch
new file mode 100644
index 000000000000..2002ba3a9019
--- /dev/null
+++ b/dev-libs/boost/files/boost-1.41.0-parameter-needs-python.patch
@@ -0,0 +1,106 @@
+--- boost/parameter/aux_/maybe.hpp 2008-03-22 21:45:55.000000000 +0000
++++ boost/parameter/aux_/maybe.hpp.new 2009-10-22 03:55:24.000000000 +0000
+@@ -2,20 +2,41 @@
+ // subject to the Boost Software License, Version 1.0. (See accompanying
+ // file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt)
+
+-#ifndef BOOST_PARAMETER_MAYBE_060211_HPP
+-# define BOOST_PARAMETER_MAYBE_060211_HPP
++//
++// 2009.10.21 TDS remove depenency on boost::python::detail::referent_storage
++//
++#ifndef BOOST_PARAMETER_MAYBE_091021_HPP
++# define BOOST_PARAMETER_MAYBE_091021_HPP
+
+ # include <boost/mpl/if.hpp>
+ # include <boost/mpl/identity.hpp>
+ # include <boost/type_traits/is_reference.hpp>
+ # include <boost/type_traits/add_reference.hpp>
+ # include <boost/optional.hpp>
+-# include <boost/python/detail/referent_storage.hpp>
++# include <boost/aligned_storage.hpp>
+ # include <boost/type_traits/remove_cv.hpp>
+ # include <boost/type_traits/add_const.hpp>
+
+ namespace boost { namespace parameter { namespace aux {
+
++template <class T> struct referent_size;
++
++template <class T>
++struct referent_size<T&>
++{
++ BOOST_STATIC_CONSTANT(std::size_t, value = sizeof(T));
++};
++
++// A metafunction returning a POD type which can store U, where T ==
++// U&. If T is not a reference type, returns a POD which can store T.
++template <class T>
++struct referent_storage
++{
++ typedef typename boost::aligned_storage<
++ referent_size<T>::value
++ >::type type;
++};
++
+ struct maybe_base {};
+
+ template <class T>
+@@ -33,8 +54,8 @@
+ BOOST_DEDUCED_TYPENAME remove_reference<reference>::type
+ >::type non_cv_value;
+
+- explicit maybe(T value)
+- : value(value)
++ explicit maybe(T value_)
++ : value(value_)
+ , constructed(false)
+ {}
+
+@@ -48,28 +69,28 @@
+ this->destroy();
+ }
+
+- reference construct(reference value) const
++ reference construct(reference value_) const
+ {
+- return value;
++ return value_;
+ }
+
+ template <class U>
+- reference construct2(U const& value) const
++ reference construct2(U const& value_) const
+ {
+- new (m_storage.bytes) non_cv_value(value);
++ new (m_storage.address()) non_cv_value(value_);
+ constructed = true;
+- return *(non_cv_value*)m_storage.bytes;
++ return *(non_cv_value*)m_storage.address();
+ }
+
+ template <class U>
+- reference construct(U const& value) const
++ reference construct(U const& value_) const
+ {
+- return this->construct2(value);
++ return this->construct2(value_);
+ }
+
+ void destroy()
+ {
+- ((non_cv_value*)m_storage.bytes)->~non_cv_value();
++ ((non_cv_value*)m_storage.address())->~non_cv_value();
+ }
+
+ typedef reference(maybe<T>::*safe_bool)() const;
+@@ -87,7 +108,9 @@
+ private:
+ boost::optional<T> value;
+ mutable bool constructed;
+- mutable typename boost::python::detail::referent_storage<
++
++
++ mutable typename referent_storage<
+ reference
+ >::type m_storage;
+ };
diff --git a/dev-libs/boost/files/remove-toolset-1.41.0.patch b/dev-libs/boost/files/remove-toolset-1.41.0.patch
new file mode 100644
index 000000000000..b7d797c37376
--- /dev/null
+++ b/dev-libs/boost/files/remove-toolset-1.41.0.patch
@@ -0,0 +1,11 @@
+--- Jamroot 2009-08-23 18:17:37.000000000 +0200
++++ Jamroot.gentoo 2009-10-21 13:31:46.000000000 +0200
+@@ -352,7 +352,7 @@
+ if $(layout) = versioned
+ {
+ result = [ common.format-name
+- <base> <toolset> <threading> <runtime> -$(BOOST_VERSION_TAG)
++ <base> <threading> <runtime> -$(BOOST_VERSION_TAG)
+ -$(BUILD_ID)
+ : $(name) : $(type) : $(property-set) ] ;
+ }
diff --git a/dev-libs/boost/metadata.xml b/dev-libs/boost/metadata.xml
index 09016cd72c97..53a1a3d25382 100644
--- a/dev-libs/boost/metadata.xml
+++ b/dev-libs/boost/metadata.xml
@@ -10,6 +10,10 @@
<email>djc@gentoo.org</email>
<name>Dirkjan Ochtman</name>
</maintainer>
+ <maintainer>
+ <email>s.mingramm@gmx.de</email>
+ <name>Sebastian Mingramm</name>
+ </maintainer>
<longdescription>
Boost is a free peer-reviewed portable C++ source libraries.
</longdescription>