summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2003-11-25 00:30:40 +0000
committerRyan Phillips <rphillips@gentoo.org>2003-11-25 00:30:40 +0000
commit61659bd4188882c8e7c8b12b1e56750db94d5cf7 (patch)
tree0f402d8a2793b843cdc03e99108bc16a6e4a3f7e /dev-libs/crypto++/crypto++-5.1.ebuild
parentNew package. submitted by Marc Bevand. Fixes #33685 (diff)
downloadgentoo-2-61659bd4188882c8e7c8b12b1e56750db94d5cf7.tar.gz
gentoo-2-61659bd4188882c8e7c8b12b1e56750db94d5cf7.tar.bz2
gentoo-2-61659bd4188882c8e7c8b12b1e56750db94d5cf7.zip
New package. submitted by Marc Bevand. Fixes #33685
Diffstat (limited to 'dev-libs/crypto++/crypto++-5.1.ebuild')
-rw-r--r--dev-libs/crypto++/crypto++-5.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/crypto++/crypto++-5.1.ebuild b/dev-libs/crypto++/crypto++-5.1.ebuild
new file mode 100644
index 000000000000..db83b9c550d8
--- /dev/null
+++ b/dev-libs/crypto++/crypto++-5.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/crypto++/crypto++-5.1.ebuild,v 1.1 2003/11/25 00:30:38 rphillips Exp $
+
+DESCRIPTION="Crypto++ is a C++ class library of cryptographic schemes"
+HOMEPAGE="http://cryptopp.com"
+SRC_URI="mirror://sourceforge/cryptopp/crypto${PV//.}.zip"
+
+LICENSE="cryptopp"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND=""
+#RDEPEND=""
+
+S=${WORKDIR}
+
+src_compile() {
+ emake -f GNUmakefile CXXFLAGS="${CXXFLAGS}" || die
+}
+
+src_install() {
+ # For consistency across GNU/Linux distributions,
+ # "crypto++" has been preferred over "crytopp"
+ newlib.a libcryptopp.a libcrypto++.a
+ insinto /usr/include/crypto++
+ doins *.h
+}