summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-09-16 18:37:45 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-09-16 18:37:45 +0000
commit9cf476b4a76f6c6dcf7d17515ea7bd98096aa0b4 (patch)
tree4187ff8230fa5fd62676ba5e5f83eeb0a55658da /dev-libs/d0_blind_id
parentUpdate the ebuild to eapi4, add static-libs useflag, punt libtool archive. (diff)
downloadgentoo-2-9cf476b4a76f6c6dcf7d17515ea7bd98096aa0b4.tar.gz
gentoo-2-9cf476b4a76f6c6dcf7d17515ea7bd98096aa0b4.tar.bz2
gentoo-2-9cf476b4a76f6c6dcf7d17515ea7bd98096aa0b4.zip
initial commit; dep for games-fps/xonotic
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'dev-libs/d0_blind_id')
-rw-r--r--dev-libs/d0_blind_id/ChangeLog10
-rw-r--r--dev-libs/d0_blind_id/d0_blind_id-0.3.ebuild37
-rw-r--r--dev-libs/d0_blind_id/metadata.xml8
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-libs/d0_blind_id/ChangeLog b/dev-libs/d0_blind_id/ChangeLog
new file mode 100644
index 000000000000..7f71ae20f26f
--- /dev/null
+++ b/dev-libs/d0_blind_id/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-libs/d0_blind_id
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/d0_blind_id/ChangeLog,v 1.1 2011/09/16 18:37:45 mr_bones_ Exp $
+
+*d0_blind_id-0.3 (16 Sep 2011)
+
+ 16 Sep 2011; Michael Sterrett <mr_bones_@gentoo.org> +d0_blind_id-0.3.ebuild,
+ +metadata.xml:
+ initial commit; dep for games-fps/xonotic
+
diff --git a/dev-libs/d0_blind_id/d0_blind_id-0.3.ebuild b/dev-libs/d0_blind_id/d0_blind_id-0.3.ebuild
new file mode 100644
index 000000000000..f878a83af512
--- /dev/null
+++ b/dev-libs/d0_blind_id/d0_blind_id-0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/d0_blind_id/d0_blind_id-0.3.ebuild,v 1.1 2011/09/16 18:37:45 mr_bones_ Exp $
+
+EAPI=4
+inherit autotools-utils
+
+DESCRIPTION="Blind-ID library for user identification using RSA blind signatures"
+HOMEPAGE="http://git.xonotic.org/?p=xonotic/d0_blind_id.git;a=summary"
+SRC_URI="https://github.com/downloads/divVerent/d0_blind_id/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl static-libs tommath"
+REQUIRED_USE="ssl? ( !tommath )"
+
+RDEPEND="ssl? ( !tommath? ( dev-libs/gmp ) )
+ ssl? ( dev-libs/openssl )
+ tommath? ( dev-libs/libtommath )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS=( d0_blind_id.txt )
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --enable-rijndael \
+ $(use_with ssl openssl) \
+ $(use_with tommath) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ autotools-utils_src_install
+}
diff --git a/dev-libs/d0_blind_id/metadata.xml b/dev-libs/d0_blind_id/metadata.xml
new file mode 100644
index 000000000000..8998d6d2075e
--- /dev/null
+++ b/dev-libs/d0_blind_id/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<use>
+ <flag name='tommath'>use <pkg>dev-libs/libtommath</pkg> instead of <pkg>dev-libs/gmp</pkg></flag>
+</use>
+</pkgmetadata>