summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-04-28 17:37:56 +0000
committerMichał Górny <mgorny@gentoo.org>2014-04-28 17:37:56 +0000
commite0d60efb437092b37b4087fb837609897412eb12 (patch)
tree974c841b9504126fe0b027a9daa18dc727fefb42 /dev-libs/dbus-glib
parentReplace multilib_build_binaries with multilib_is_native_abi. The two are equi... (diff)
downloadgentoo-2-e0d60efb437092b37b4087fb837609897412eb12.tar.gz
gentoo-2-e0d60efb437092b37b4087fb837609897412eb12.tar.bz2
gentoo-2-e0d60efb437092b37b4087fb837609897412eb12.zip
Backport use of multilib_native_use_enable from the newer version, fix whitespace.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-libs/dbus-glib')
-rw-r--r--dev-libs/dbus-glib/ChangeLog7
-rw-r--r--dev-libs/dbus-glib/dbus-glib-0.100.2-r1.ebuild8
-rw-r--r--dev-libs/dbus-glib/dbus-glib-0.102.ebuild6
3 files changed, 13 insertions, 8 deletions
diff --git a/dev-libs/dbus-glib/ChangeLog b/dev-libs/dbus-glib/ChangeLog
index 24f4d12cb489..5cf824253e38 100644
--- a/dev-libs/dbus-glib/ChangeLog
+++ b/dev-libs/dbus-glib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/dbus-glib
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbus-glib/ChangeLog,v 1.151 2014/04/21 07:36:06 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbus-glib/ChangeLog,v 1.152 2014/04/28 17:37:56 mgorny Exp $
+
+ 28 Apr 2014; Michał Górny <mgorny@gentoo.org> dbus-glib-0.100.2-r1.ebuild,
+ dbus-glib-0.102.ebuild:
+ Backport use of multilib_native_use_enable from the newer version, fix
+ whitespace.
21 Apr 2014; Michał Górny <mgorny@gentoo.org> dbus-glib-0.102.ebuild:
Use the new multilib_native_use* functions.
diff --git a/dev-libs/dbus-glib/dbus-glib-0.100.2-r1.ebuild b/dev-libs/dbus-glib/dbus-glib-0.100.2-r1.ebuild
index 6306853ae288..c86b50e8fa57 100644
--- a/dev-libs/dbus-glib/dbus-glib-0.100.2-r1.ebuild
+++ b/dev-libs/dbus-glib/dbus-glib-0.100.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbus-glib/dbus-glib-0.100.2-r1.ebuild,v 1.9 2014/03/20 08:46:39 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbus-glib/dbus-glib-0.100.2-r1.ebuild,v 1.10 2014/04/28 17:37:56 mgorny Exp $
EAPI=5
inherit bash-completion-r1 eutils multilib-minimal
@@ -21,8 +21,8 @@ DEPEND="${CDEPEND}
virtual/pkgconfig
doc? ( >=dev-util/gtk-doc-1.4 )"
RDEPEND="${CDEPEND}
- abi_x86_32? (
- !<app-emulation/emul-linux-x86-baselibs-20131008-r8
+ abi_x86_32? (
+ !<app-emulation/emul-linux-x86-baselibs-20131008-r8
!app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
)"
@@ -49,7 +49,7 @@ multilib_src_configure() {
$(use_enable debug verbose-mode)
$(use_enable debug asserts)
$(use_enable static-libs static)
- $(multilib_build_binaries && use_enable doc gtk-doc || echo " --disable-gtk-doc")
+ $(multilib_native_use_enable doc gtk-doc)
)
ECONF_SOURCE="${S}" econf "${myconf[@]}"
diff --git a/dev-libs/dbus-glib/dbus-glib-0.102.ebuild b/dev-libs/dbus-glib/dbus-glib-0.102.ebuild
index 4877bebf09d0..916120be3ea4 100644
--- a/dev-libs/dbus-glib/dbus-glib-0.102.ebuild
+++ b/dev-libs/dbus-glib/dbus-glib-0.102.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbus-glib/dbus-glib-0.102.ebuild,v 1.4 2014/04/21 07:36:05 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbus-glib/dbus-glib-0.102.ebuild,v 1.5 2014/04/28 17:37:56 mgorny Exp $
EAPI=5
inherit bash-completion-r1 eutils multilib-minimal
@@ -21,8 +21,8 @@ DEPEND="${CDEPEND}
virtual/pkgconfig
doc? ( >=dev-util/gtk-doc-1.4 )"
RDEPEND="${CDEPEND}
- abi_x86_32? (
- !<app-emulation/emul-linux-x86-baselibs-20131008-r8
+ abi_x86_32? (
+ !<app-emulation/emul-linux-x86-baselibs-20131008-r8
!app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
)"