summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2006-06-22 07:57:16 +0000
committerBenedikt Boehm <hollow@gentoo.org>2006-06-22 07:57:16 +0000
commitedb0e25c5d16680161b076243894fdf4b45effe8 (patch)
tree98b3ed34769510cbf220da152f8706edb188a9a5 /dev-libs/dietlibc/dietlibc-0.30.ebuild
parentAdd support for fluidsynth (bug #137547) (diff)
downloadgentoo-2-edb0e25c5d16680161b076243894fdf4b45effe8.tar.gz
gentoo-2-edb0e25c5d16680161b076243894fdf4b45effe8.tar.bz2
gentoo-2-edb0e25c5d16680161b076243894fdf4b45effe8.zip
version bump
(Portage version: 2.1.1_pre1)
Diffstat (limited to 'dev-libs/dietlibc/dietlibc-0.30.ebuild')
-rw-r--r--dev-libs/dietlibc/dietlibc-0.30.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/dietlibc/dietlibc-0.30.ebuild b/dev-libs/dietlibc/dietlibc-0.30.ebuild
new file mode 100644
index 000000000000..5f532a557c3f
--- /dev/null
+++ b/dev-libs/dietlibc/dietlibc-0.30.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dietlibc/dietlibc-0.30.ebuild,v 1.1 2006/06/22 07:57:16 hollow Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A minimal libc"
+HOMEPAGE="http://www.fefe.de/dietlibc/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~phreak/distfiles/${P}-patches-${PR}.tar.bz2
+ http://dev.gentoo.org/~hollow/distfiles/${P}-patches-${PR}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+DEPEND=""
+
+pkg_setup() {
+ # Replace sparc64 related C[XX]FLAGS (see bug #45716)
+ use sparc && replace-sparc64-flags
+
+ # gcc-hppa suffers support for SSP, compilation will fail
+ use hppa && strip-unsupported-flags
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/patches/*.patch
+}
+
+src_compile() {
+ local my_cflags="${CFLAGS} -fno-pie"
+ use debug && my_cflags="${my_cflags} -g"
+ make CFLAGS="${my_cflags}" || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dobin "${D}"/usr/diet/bin/* || die "dobin failed"
+ doman "${D}"/usr/diet/man/*/* || die "doman failed"
+ rm -r "${D}"/usr/diet/{man,bin}
+ dodoc AUTHOR BUGS CAVEAT CHANGES README THANKS TODO PORTING
+}