summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2013-01-04 18:35:47 +0000
committerThomas Sachau <tommy@gentoo.org>2013-01-04 18:35:47 +0000
commite1b05d228a0206a1d6129396cd0e63c8da5f8130 (patch)
tree804e95840c70063624a0c4d90fb989fedc549acb /dev-libs/e_dbus
parentVersion bump. (diff)
downloadgentoo-2-e1b05d228a0206a1d6129396cd0e63c8da5f8130.tar.gz
gentoo-2-e1b05d228a0206a1d6129396cd0e63c8da5f8130.tar.bz2
gentoo-2-e1b05d228a0206a1d6129396cd0e63c8da5f8130.zip
Version bump
(Portage version: 2.2.0_alpha149-r1/cvs/Linux x86_64, signed Manifest commit with key 0x35899067)
Diffstat (limited to 'dev-libs/e_dbus')
-rw-r--r--dev-libs/e_dbus/ChangeLog9
-rw-r--r--dev-libs/e_dbus/e_dbus-1.7.5.ebuild61
2 files changed, 68 insertions, 2 deletions
diff --git a/dev-libs/e_dbus/ChangeLog b/dev-libs/e_dbus/ChangeLog
index d562187f7023..4539474d567b 100644
--- a/dev-libs/e_dbus/ChangeLog
+++ b/dev-libs/e_dbus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/e_dbus
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/e_dbus/ChangeLog,v 1.11 2012/12/21 20:22:28 tommy Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/e_dbus/ChangeLog,v 1.12 2013/01/04 18:35:47 tommy Exp $
+
+*e_dbus-1.7.5 (04 Jan 2013)
+
+ 04 Jan 2013; Thomas Sachau (Tommy[D]) <tommy@gentoo.org> +e_dbus-1.7.5.ebuild:
+ Version bump
*e_dbus-1.7.4 (21 Dec 2012)
diff --git a/dev-libs/e_dbus/e_dbus-1.7.5.ebuild b/dev-libs/e_dbus/e_dbus-1.7.5.ebuild
new file mode 100644
index 000000000000..09ee40bd1e58
--- /dev/null
+++ b/dev-libs/e_dbus/e_dbus-1.7.5.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/e_dbus/e_dbus-1.7.5.ebuild,v 1.1 2013/01/04 18:35:46 tommy Exp $
+
+EAPI="2"
+
+inherit autotools enlightenment
+
+DESCRIPTION="Enlightenment's (Ecore) integration to DBus"
+SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="bluetooth +connman +libnotify ofono static-libs test-binaries +udev"
+
+RDEPEND=">=dev-libs/eina-1.7.4
+ >=dev-libs/ecore-1.7.5
+ sys-apps/dbus
+ connman? ( >=net-misc/connman-0.75 )
+ libnotify? ( >=media-libs/evas-1.7.5 )
+ udev? ( sys-power/upower sys-fs/udisks:0 )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i "s:1.7.5:1.7.4:g" configure.ac
+ eautoreconf
+}
+
+src_configure() {
+ MY_ECONF="
+ $(use_enable bluetooth ebluez)
+ $(use_enable connman econnman0_7x)
+ $(use_enable doc)
+ --disable-ehal
+ $(use_enable libnotify enotify)
+ $(use_enable ofono eofono)
+ $(use_enable test-binaries edbus-test)
+ $(use_enable test-binaries edbus-test-client)
+ $(use_enable udev eukit)"
+ if use test-binaries ; then
+ MY_ECONF+="
+ $(use_enable bluetooth edbus-bluez-test)
+ $(use_enable connman edbus-connman0_7x-test)
+ $(use_enable libnotify edbus-notification-daemon-test)
+ $(use_enable libnotify edbus-notify-test)
+ $(use_enable ofono edbus-ofono-test)
+ $(use_enable udev edbus-ukit-test)"
+ else
+ MY_ECONF+="
+ --disable-edbus-bluez-test
+ --disable-edbus-connman0_7x-test
+ --disable-edbus-notification-daemon-test
+ --disable-edbus-notify-test
+ --disable-edbus-ofono-test
+ --disable-edbus-ukit-test
+ --disable-edbus-async-test
+ --disable-edbus-performance-test"
+ fi
+ enlightenment_src_configure
+}