summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2010-08-24 11:33:40 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2010-08-24 11:33:40 +0000
commit84005377373b4b0fc67a8060f558cd1acf34756c (patch)
tree2e0660089792bb2100ee5825b3434145161f7e88 /dev-libs/ffcall
parentIncrement genpatches for 2.6.35-r4 (diff)
downloadgentoo-2-84005377373b4b0fc67a8060f558cd1acf34756c.tar.gz
gentoo-2-84005377373b4b0fc67a8060f558cd1acf34756c.tar.bz2
gentoo-2-84005377373b4b0fc67a8060f558cd1acf34756c.zip
Finally fix bug #298348, patch from PLD
(Portage version: 2.2_rc68/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/ffcall')
-rw-r--r--dev-libs/ffcall/ChangeLog10
-rw-r--r--dev-libs/ffcall/ffcall-1.10-r3.ebuild56
-rw-r--r--dev-libs/ffcall/files/ffcall-make-jN.patch13
3 files changed, 77 insertions, 2 deletions
diff --git a/dev-libs/ffcall/ChangeLog b/dev-libs/ffcall/ChangeLog
index 93ce863c05df..51a2ecad51ca 100644
--- a/dev-libs/ffcall/ChangeLog
+++ b/dev-libs/ffcall/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/ffcall
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ffcall/ChangeLog,v 1.38 2009/12/25 15:56:25 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ffcall/ChangeLog,v 1.39 2010/08/24 11:33:39 voyageur Exp $
+
+*ffcall-1.10-r3 (24 Aug 2010)
+
+ 24 Aug 2010; Bernard Cafarelli <voyageur@gentoo.org>
+ +ffcall-1.10-r3.ebuild, +files/ffcall-make-jN.patch:
+ Finally fix bug #298348, patch from PLD
25 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org>
ffcall-1.10-r2.ebuild:
diff --git a/dev-libs/ffcall/ffcall-1.10-r3.ebuild b/dev-libs/ffcall/ffcall-1.10-r3.ebuild
new file mode 100644
index 000000000000..82b47c93b343
--- /dev/null
+++ b/dev-libs/ffcall/ffcall-1.10-r3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ffcall/ffcall-1.10-r3.ebuild,v 1.1 2010/08/24 11:33:40 voyageur Exp $
+
+EAPI=3
+inherit eutils flag-o-matic
+
+# CLISP maintains ffcall now
+CLISP_PACKAGE="clisp-2.41"
+
+DESCRIPTION="foreign function call libraries"
+HOMEPAGE="http://www.haible.de/bruno/packages-ffcall.html"
+SRC_URI="mirror://sourceforge/clisp/${CLISP_PACKAGE}.tar.bz2"
+
+# "Ffcall is under GNU GPL. As a special exception, if used in GNUstep
+# or in derivate works of GNUstep, the included parts of ffcall are
+# under GNU LGPL." -ffcall author
+LICENSE="|| ( GPL-2 LGPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+S=${WORKDIR}/${CLISP_PACKAGE}/${PN}
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-make-jN.patch
+}
+
+src_configure() {
+ append-flags -fPIC
+
+ # Doc goes in datadir
+ econf \
+ --datadir=/usr/share/doc/${PF} \
+ --enable-shared \
+ || die "./configure failed"
+}
+
+src_compile() {
+ # Because CHOST is set to (for example)
+ # alphaev67-unknown-linux-gnu, CPU gets set to alphaev67 which
+ # doesn't work in the Makefile (29 Jan 2004 agriffis)
+ local cpu_setting
+ [[ "${ARCH}" == "alpha" ]] && cpu_setting='CPU=alpha'
+
+ emake ${cpu_setting} || die
+}
+
+src_install() {
+ dodoc NEWS README
+ dodir /usr/share/man
+ emake DESTDIR="${D}" install || die "Install failed"
+}
diff --git a/dev-libs/ffcall/files/ffcall-make-jN.patch b/dev-libs/ffcall/files/ffcall-make-jN.patch
new file mode 100644
index 000000000000..98f4c497504e
--- /dev/null
+++ b/dev-libs/ffcall/files/ffcall-make-jN.patch
@@ -0,0 +1,13 @@
+--- ffcall-1.10/callback/Makefile.in~ 2003-10-01 21:46:19.000000000 +0200
++++ ffcall-1.10/callback/Makefile.in 2007-12-18 21:10:51.302118000 +0100
+@@ -51,6 +51,10 @@
+ all-subdirs : force
+ cd @subdir@; $(MAKE) all
+
++vacall_r/libvacall.la: all-subdirs
++
++trampoline_r/libtrampoline.la: all-subdirs
++
+ callback.h :
+ $(LN_S) $(srcdir)/callback.h.in callback.h
+