summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2009-04-19 07:47:26 +0000
committerMart Raudsepp <leio@gentoo.org>2009-04-19 07:47:26 +0000
commit5a521ef813cc9bb89ae3f79268c576baf3e4bb48 (patch)
tree14342e4dfc39f468b52f1b03743793d6127e28ad /dev-libs/glib
parentNew version: --toggle and --search-key-regexp support in gconftool-2; size an... (diff)
downloadgentoo-2-5a521ef813cc9bb89ae3f79268c576baf3e4bb48.tar.gz
gentoo-2-5a521ef813cc9bb89ae3f79268c576baf3e4bb48.tar.bz2
gentoo-2-5a521ef813cc9bb89ae3f79268c576baf3e4bb48.zip
Remove old redundant security vulnerable revisions
(Portage version: 2.2_rc22/cvs/Linux 2.6.29-gentoo-r1 x86_64)
Diffstat (limited to 'dev-libs/glib')
-rw-r--r--dev-libs/glib/ChangeLog6
-rw-r--r--dev-libs/glib/glib-2.16.5.ebuild80
-rw-r--r--dev-libs/glib/glib-2.16.6.ebuild87
-rw-r--r--dev-libs/glib/glib-2.18.4.ebuild87
4 files changed, 5 insertions, 255 deletions
diff --git a/dev-libs/glib/ChangeLog b/dev-libs/glib/ChangeLog
index 40761f925bb0..448aa68adbbf 100644
--- a/dev-libs/glib/ChangeLog
+++ b/dev-libs/glib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/glib
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.364 2009/04/12 20:36:13 bluebird Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.365 2009/04/19 07:47:26 leio Exp $
+
+ 19 Apr 2009; Mart Raudsepp <leio@gentoo.org> -glib-2.16.5.ebuild,
+ -glib-2.16.6.ebuild, -glib-2.18.4.ebuild:
+ Remove old redundant security vulnerable revisions
12 Apr 2009; Friedrich Oslage <bluebird@gentoo.org> ChangeLog:
Stable on sparc, bug #260063
diff --git a/dev-libs/glib/glib-2.16.5.ebuild b/dev-libs/glib/glib-2.16.5.ebuild
deleted file mode 100644
index 707e12a79938..000000000000
--- a/dev-libs/glib/glib-2.16.5.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.16.5.ebuild,v 1.10 2009/02/15 23:07:23 eva Exp $
-
-inherit gnome.org libtool eutils flag-o-matic
-
-DESCRIPTION="The GLib library of C routines"
-HOMEPAGE="http://www.gtk.org/"
-
-LICENSE="LGPL-2"
-SLOT="2"
-KEYWORDS=" m68k ppc ppc64"
-IUSE="debug fam hardened selinux xattr"
-
-RDEPEND="virtual/libc
- virtual/libiconv
- xattr? ( sys-apps/attr )
- fam? ( virtual/fam )"
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.16
- >=sys-devel/gettext-0.11"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- if use ppc64 && use hardened ; then
- replace-flags -O[2-3] -O1
- epatch "${FILESDIR}/glib-2.6.3-testglib-ssp.patch"
- fi
-
- if use ia64 ; then
- # Only apply for < 4.1
- local major=$(gcc-major-version)
- local minor=$(gcc-minor-version)
- if (( major < 4 || ( major == 4 && minor == 0 ) )); then
- epatch "${FILESDIR}/glib-2.10.3-ia64-atomic-ops.patch"
- fi
- fi
-
- # GNOME bug #538836, fix gio test failure on various arches
- sed -i -e 's:|\\<g_atomic_int\\|:|\\<g_atomic_int\\|\\<g_atomic_pointer_get\\|:' \
- "${S}/gio/pltcheck.sh"
-
- # Fix gmodule issues on fbsd; bug #184301
- epatch "${FILESDIR}"/${PN}-2.12.12-fbsd.patch
-
- [[ ${CHOST} == *-freebsd* ]] && elibtoolize
-}
-
-src_compile() {
- local myconf
-
- epunt_cxx
-
- # Building with --disable-debug highly unrecommended. It will build glib in
- # an unusable form as it disables some commonly used API. Please do not
- # convert this to the use_enable form, as it results in a broken build.
- # -- compnerd (3/27/06)
- use debug && myconf="--enable-debug"
-
- # always build static libs, see #153807
- econf ${myconf} \
- $(use_enable xattr) \
- $(use_enable fam) \
- $(use_enable selinux) \
- --enable-static \
- --with-threads=posix || die "configure failed"
-
- emake || die "make failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
-
- # Do not install charset.alias even if generated, leave it to libiconv
- rm -f "${D}/usr/lib/charset.alias"
-
- dodoc AUTHORS ChangeLog* NEWS* README
-}
diff --git a/dev-libs/glib/glib-2.16.6.ebuild b/dev-libs/glib/glib-2.16.6.ebuild
deleted file mode 100644
index 8cea821f43f6..000000000000
--- a/dev-libs/glib/glib-2.16.6.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.16.6.ebuild,v 1.8 2009/03/17 10:15:58 armin76 Exp $
-
-inherit gnome.org libtool eutils flag-o-matic
-
-DESCRIPTION="The GLib library of C routines"
-HOMEPAGE="http://www.gtk.org/"
-
-LICENSE="LGPL-2"
-SLOT="2"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="debug doc fam hardened selinux xattr"
-
-RDEPEND="virtual/libc
- virtual/libiconv
- xattr? ( sys-apps/attr )
- fam? ( virtual/fam )"
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.16
- >=sys-devel/gettext-0.11
- doc? (
- >=dev-libs/libxslt-1.0
- >=dev-util/gtk-doc-1.8
- ~app-text/docbook-xml-dtd-4.1.2
- )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- if use ppc64 && use hardened ; then
- replace-flags -O[2-3] -O1
- epatch "${FILESDIR}/glib-2.6.3-testglib-ssp.patch"
- fi
-
- if use ia64 ; then
- # Only apply for < 4.1
- local major=$(gcc-major-version)
- local minor=$(gcc-minor-version)
- if (( major < 4 || ( major == 4 && minor == 0 ) )); then
- epatch "${FILESDIR}/glib-2.10.3-ia64-atomic-ops.patch"
- fi
- fi
-
- # GNOME bug #538836, fix gio test failure on various arches
- sed -i -e 's:|\\<g_atomic_int\\|:|\\<g_atomic_int\\|\\<g_atomic_pointer_get\\|:' \
- "${S}/gio/pltcheck.sh"
-
- # Fix gmodule issues on fbsd; bug #184301
- epatch "${FILESDIR}"/${PN}-2.12.12-fbsd.patch
-
- [[ ${CHOST} == *-freebsd* ]] && elibtoolize
-}
-
-src_compile() {
- local myconf
-
- epunt_cxx
-
- # Building with --disable-debug highly unrecommended. It will build glib in
- # an unusable form as it disables some commonly used API. Please do not
- # convert this to the use_enable form, as it results in a broken build.
- # -- compnerd (3/27/06)
- use debug && myconf="--enable-debug"
-
- # always build static libs, see #153807
- econf ${myconf} \
- $(use_enable xattr) \
- $(use_enable doc man) \
- $(use_enable doc gtk-doc) \
- $(use_enable fam) \
- $(use_enable selinux) \
- --enable-static \
- --with-threads=posix || die "configure failed"
-
- emake || die "make failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
-
- # Do not install charset.alias even if generated, leave it to libiconv
- rm -f "${D}/usr/lib/charset.alias"
-
- dodoc AUTHORS ChangeLog* NEWS* README
-}
diff --git a/dev-libs/glib/glib-2.18.4.ebuild b/dev-libs/glib/glib-2.18.4.ebuild
deleted file mode 100644
index 4db239847605..000000000000
--- a/dev-libs/glib/glib-2.18.4.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.18.4.ebuild,v 1.7 2009/03/26 14:03:45 armin76 Exp $
-
-inherit gnome.org libtool eutils flag-o-matic
-
-DESCRIPTION="The GLib library of C routines"
-HOMEPAGE="http://www.gtk.org/"
-
-LICENSE="LGPL-2"
-SLOT="2"
-KEYWORDS="alpha amd64 arm ~hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="debug doc fam hardened selinux xattr"
-
-RDEPEND="virtual/libc
- virtual/libiconv
- xattr? ( sys-apps/attr )
- fam? ( virtual/fam )"
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.16
- >=sys-devel/gettext-0.11
- doc? (
- >=dev-libs/libxslt-1.0
- >=dev-util/gtk-doc-1.8
- ~app-text/docbook-xml-dtd-4.1.2
- )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- if use ppc64 && use hardened ; then
- replace-flags -O[2-3] -O1
- epatch "${FILESDIR}/glib-2.6.3-testglib-ssp.patch"
- fi
-
- if use ia64 ; then
- # Only apply for < 4.1
- local major=$(gcc-major-version)
- local minor=$(gcc-minor-version)
- if (( major < 4 || ( major == 4 && minor == 0 ) )); then
- epatch "${FILESDIR}/glib-2.10.3-ia64-atomic-ops.patch"
- fi
- fi
-
- # Don't fail gio tests when ran without userpriv, upstream bug 552912
- # This is only a temporary workaround, remove as soon as possible
- epatch "${FILESDIR}/${PN}-2.18.1-workaround-gio-test-failure-without-userpriv.patch"
-
- # Fix gmodule issues on fbsd; bug #184301
- epatch "${FILESDIR}"/${PN}-2.12.12-fbsd.patch
-
- [[ ${CHOST} == *-freebsd* ]] && elibtoolize
-}
-
-src_compile() {
- local myconf
-
- epunt_cxx
-
- # Building with --disable-debug highly unrecommended. It will build glib in
- # an unusable form as it disables some commonly used API. Please do not
- # convert this to the use_enable form, as it results in a broken build.
- # -- compnerd (3/27/06)
- use debug && myconf="--enable-debug"
-
- # always build static libs, see #153807
- econf ${myconf} \
- $(use_enable xattr) \
- $(use_enable doc man) \
- $(use_enable doc gtk-doc) \
- $(use_enable fam) \
- $(use_enable selinux) \
- --enable-static \
- --with-threads=posix || die "configure failed"
-
- emake || die "make failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
-
- # Do not install charset.alias even if generated, leave it to libiconv
- rm -f "${D}/usr/lib/charset.alias"
-
- dodoc AUTHORS ChangeLog* NEWS* README
-}