summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-03-26 02:26:38 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-03-26 02:26:38 +0000
commit16b02731297e10c434530a543d9ccbe940f01932 (patch)
tree9dc9533b5221549f8a734dac2876db251aee491a /dev-libs/gobject-introspection
parentDepend on kdevplatform[subversion], works around bug 347547 (diff)
downloadgentoo-2-16b02731297e10c434530a543d9ccbe940f01932.tar.gz
gentoo-2-16b02731297e10c434530a543d9ccbe940f01932.tar.bz2
gentoo-2-16b02731297e10c434530a543d9ccbe940f01932.zip
Bump to 0.10.6
(Portage version: 2.1.9.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/gobject-introspection')
-rw-r--r--dev-libs/gobject-introspection/ChangeLog8
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-0.10.6.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-libs/gobject-introspection/ChangeLog b/dev-libs/gobject-introspection/ChangeLog
index 42961d2857b2..9b8ee5e863b0 100644
--- a/dev-libs/gobject-introspection/ChangeLog
+++ b/dev-libs/gobject-introspection/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/gobject-introspection
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/ChangeLog,v 1.23 2011/03/22 18:52:05 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/ChangeLog,v 1.24 2011/03/26 02:26:38 nirbheek Exp $
+
+*gobject-introspection-0.10.6 (26 Mar 2011)
+
+ 26 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +gobject-introspection-0.10.6.ebuild:
+ Bump to 0.10.6
22 Mar 2011; Brent Baude <ranger@gentoo.org>
gobject-introspection-0.10.2.ebuild:
diff --git a/dev-libs/gobject-introspection/gobject-introspection-0.10.6.ebuild b/dev-libs/gobject-introspection/gobject-introspection-0.10.6.ebuild
new file mode 100644
index 000000000000..9ebf2db46508
--- /dev/null
+++ b/dev-libs/gobject-introspection/gobject-introspection-0.10.6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/gobject-introspection-0.10.6.ebuild,v 1.1 2011/03/26 02:26:38 nirbheek Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+PYTHON_DEPEND="2:2.5"
+
+inherit gnome2 python
+
+DESCRIPTION="Introspection infrastructure for gobject library bindings"
+HOMEPAGE="http://live.gnome.org/GObjectIntrospection/"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-libs/glib-2.24:2
+ virtual/libffi"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/flex
+ doc? ( >=dev-util/gtk-doc-1.12 )
+ test? ( x11-libs/cairo )"
+
+pkg_setup() {
+ DOCS="AUTHORS CONTRIBUTORS ChangeLog NEWS README TODO"
+ G2CONF="${G2CONF}
+ --disable-static
+ $(use_enable test tests)"
+
+ python_set_active_version 2
+}
+
+src_prepare() {
+ # FIXME: Parallel compilation failure with USE=doc
+ use doc && MAKEOPTS="-j1"
+
+ # Don't pre-compile .py
+ ln -sf $(type -P true) py-compile
+}
+
+src_install() {
+ gnome2_src_install
+ python_convert_shebangs 2 "${ED}"usr/bin/g-ir-scanner
+ python_convert_shebangs 2 "${ED}"usr/bin/g-ir-annotation-tool
+ find "${ED}" -name "*.la" -delete || die "la files removal failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}/giscanner
+ python_need_rebuild
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/lib*/${PN}/giscanner
+}