summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-09-27 12:59:44 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-09-27 12:59:44 +0000
commitaf1891cc7ed0c5234327e6467f6bc9a279c780ea (patch)
treecc93e2bec55eec0b3f9180fbaa38074d629747b1 /dev-libs/gobject-introspection
parentBump to 2.30, from the GNOME overlay. Ebuild updates by tetromino. (diff)
downloadgentoo-2-af1891cc7ed0c5234327e6467f6bc9a279c780ea.tar.gz
gentoo-2-af1891cc7ed0c5234327e6467f6bc9a279c780ea.tar.bz2
gentoo-2-af1891cc7ed0c5234327e6467f6bc9a279c780ea.zip
Bump to 1.30, from the GNOME overlay. Ebuild updates by tetromino.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/gobject-introspection')
-rw-r--r--dev-libs/gobject-introspection/ChangeLog8
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-1.30.0.ebuild69
2 files changed, 76 insertions, 1 deletions
diff --git a/dev-libs/gobject-introspection/ChangeLog b/dev-libs/gobject-introspection/ChangeLog
index 71125448f5cf..11fc8d81b0d2 100644
--- a/dev-libs/gobject-introspection/ChangeLog
+++ b/dev-libs/gobject-introspection/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/gobject-introspection
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/ChangeLog,v 1.43 2011/09/20 19:53:20 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/ChangeLog,v 1.44 2011/09/27 12:59:44 nirbheek Exp $
+
+*gobject-introspection-1.30.0 (27 Sep 2011)
+
+ 27 Sep 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +gobject-introspection-1.30.0.ebuild:
+ Bump to 1.30, from the GNOME overlay. Ebuild updates by tetromino.
20 Sep 2011; Matt Turner <mattst88@gentoo.org>
gobject-introspection-0.10.8.ebuild:
diff --git a/dev-libs/gobject-introspection/gobject-introspection-1.30.0.ebuild b/dev-libs/gobject-introspection/gobject-introspection-1.30.0.ebuild
new file mode 100644
index 000000000000..3b7700672015
--- /dev/null
+++ b/dev-libs/gobject-introspection/gobject-introspection-1.30.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/gobject-introspection-1.30.0.ebuild,v 1.1 2011/09/27 12:59:44 nirbheek Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+GNOME_TARBALL_SUFFIX="xz"
+GNOME2_LA_PUNT="yes"
+PYTHON_DEPEND="2:2.5"
+
+inherit gnome2 python
+
+DESCRIPTION="Introspection infrastructure for generating gobject library bindings for various languages"
+HOMEPAGE="http://live.gnome.org/GObjectIntrospection/"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86
+~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos
+~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="doc test"
+
+RDEPEND=">=dev-libs/glib-2.29.7:2
+ >=dev-libs/libffi-3.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/flex
+ virtual/yacc
+ doc? ( >=dev-util/gtk-doc-1.15 )
+ test? ( x11-libs/cairo )"
+
+pkg_setup() {
+ DOCS="AUTHORS CONTRIBUTORS ChangeLog NEWS README TODO"
+ G2CONF="${G2CONF}
+ --disable-static
+ YACC=$(type -p yacc)
+ $(use_enable test tests)"
+
+ python_set_active_version 2
+}
+
+src_prepare() {
+ # https://bugzilla.gnome.org/show_bug.cgi?id=659824
+ sed -i -e '/^TAGS/s/[{}]//g' "${S}/giscanner/docbookdescription.py" || die
+
+ # FIXME: Parallel compilation failure with USE=doc
+ use doc && MAKEOPTS="-j1"
+
+ # Don't pre-compile .py
+ ln -sf $(type -P true) py-compile
+ ln -sf $(type -P true) build-aux/py-compile
+
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ python_convert_shebangs 2 "${ED}"usr/bin/g-ir-{annotation-tool,doc-tool,scanner}
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}/giscanner
+ python_need_rebuild
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/lib*/${PN}/giscanner
+}