summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-01 16:50:26 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-01 16:50:26 +0000
commit806729b343786afaba725cef1822f87de7df1ee5 (patch)
treeb45263461dd8690e8050526476f72ea96de8d22d /dev-libs/gsl
parentAdded LICENSE, SLOT, KEYWORDS (diff)
downloadgentoo-2-806729b343786afaba725cef1822f87de7df1ee5.tar.gz
gentoo-2-806729b343786afaba725cef1822f87de7df1ee5.tar.bz2
gentoo-2-806729b343786afaba725cef1822f87de7df1ee5.zip
repoman'd
Diffstat (limited to 'dev-libs/gsl')
-rw-r--r--dev-libs/gsl/gsl-1.0.ebuild37
-rw-r--r--dev-libs/gsl/gsl-1.1.1.ebuild33
2 files changed, 21 insertions, 49 deletions
diff --git a/dev-libs/gsl/gsl-1.0.ebuild b/dev-libs/gsl/gsl-1.0.ebuild
index cd024ff8eba0..dba420ff7f78 100644
--- a/dev-libs/gsl/gsl-1.0.ebuild
+++ b/dev-libs/gsl/gsl-1.0.ebuild
@@ -1,15 +1,16 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gsl/gsl-1.0.ebuild,v 1.2 2002/07/11 06:30:20 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gsl/gsl-1.0.ebuild,v 1.3 2002/08/01 16:50:26 seemant Exp $
S=${WORKDIR}/${P}
-
DESCRIPTION="The GNU Scientific Library"
-
SRC_URI="http://mirrors.rcn.net/pub/sourceware/gsl/${P}.tar.gz"
-
HOMEPAGE="http://sources.redhat.com/gsl/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
DEPEND="virtual/glibc"
src_compile() {
@@ -18,31 +19,15 @@ src_compile() {
local myconf
myconf="--disable-libtool-lock"
- ./configure --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --prefix=/usr \
- --host=${CHOST} \
- ${myconf} || die
-
+ econf ${myconf} || die
emake || die
-#Uncomment the 'make check ...' line if you want to run the test suite.
-#Note that the check.log file will be several megabytes in size.
-# make check > check.log 2>&1 || die
-
+ #Uncomment the 'make check ...' line if you want to run the test suite.
+ #Note that the check.log file will be several megabytes in size.
+ # make check > check.log 2>&1 || die
}
src_install () {
-
- make prefix=${D}/usr \
- infodir=${D}/usr/share/info \
- mandir=${D}/usr/share/man \
- install || die
-
- dodoc AUTHORS COPYING ChangeLog INSTALL KNOWN-PROBLEMS MACHINES
-NEWS
-
+ einstall || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL KNOWN-PROBLEMS MACHINES NEWS
}
-
-
-
diff --git a/dev-libs/gsl/gsl-1.1.1.ebuild b/dev-libs/gsl/gsl-1.1.1.ebuild
index 3a963881fbdd..8598c0bf3b79 100644
--- a/dev-libs/gsl/gsl-1.1.1.ebuild
+++ b/dev-libs/gsl/gsl-1.1.1.ebuild
@@ -3,13 +3,14 @@
# /space/gentoo/cvsroot/gentoo-x86/dev-libs/gsl/gsl-1.0.ebuild,v 1.1 2002/01/12 15:24:19 verwilst Exp
S=${WORKDIR}/${P}
-
DESCRIPTION="The GNU Scientific Library"
-
SRC_URI="http://mirrors.rcn.net/pub/sourceware/gsl/${P}.tar.gz"
-
HOMEPAGE="http://sources.redhat.com/gsl/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
DEPEND="virtual/glibc"
src_compile() {
@@ -18,31 +19,17 @@ src_compile() {
local myconf
myconf="--disable-libtool-lock"
- ./configure --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --prefix=/usr \
- --host=${CHOST} \
- ${myconf} || die
-
+ econf ${myconf} || die
emake || die
-#Uncomment the 'make check ...' line if you want to run the test suite.
-#Note that the check.log file will be several megabytes in size.
-# make check > check.log 2>&1 || die
+ #Uncomment the 'make check ...' line if you want to run the test suite.
+ #Note that the check.log file will be several megabytes in size.
+ # make check > check.log 2>&1 || die
}
src_install () {
-
- make prefix=${D}/usr \
- infodir=${D}/usr/share/info \
- mandir=${D}/usr/share/man \
- install || die
-
- dodoc AUTHORS COPYING ChangeLog INSTALL KNOWN-PROBLEMS MACHINES
-NEWS
+ einstall || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL KNOWN-PROBLEMS MACHINES NEWS
}
-
-
-