summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-27 17:01:13 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-27 17:01:13 +0000
commit812232631bc9a26a9c35edf5447b45a00aa1480b (patch)
tree7ec82a4e30e2c7f6ac1c3539e27f21d6e8d55419 /dev-libs/igraph
parentsci-chemistry/ccp4-apps: Use PKG_CONFIG instead of generic pkg-config (diff)
downloadgentoo-2-812232631bc9a26a9c35edf5447b45a00aa1480b.tar.gz
gentoo-2-812232631bc9a26a9c35edf5447b45a00aa1480b.tar.bz2
gentoo-2-812232631bc9a26a9c35edf5447b45a00aa1480b.zip
dev-libs/igraph: Use detected pkg-config instead of generic
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'dev-libs/igraph')
-rw-r--r--dev-libs/igraph/ChangeLog6
-rw-r--r--dev-libs/igraph/files/igraph-0.6.4-unbundle.patch4
-rw-r--r--dev-libs/igraph/igraph-0.6.4.ebuild5
3 files changed, 10 insertions, 5 deletions
diff --git a/dev-libs/igraph/ChangeLog b/dev-libs/igraph/ChangeLog
index 9977e62ebcca..8745194c0dc7 100644
--- a/dev-libs/igraph/ChangeLog
+++ b/dev-libs/igraph/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/igraph
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/igraph/ChangeLog,v 1.4 2013/02/23 12:45:10 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/igraph/ChangeLog,v 1.5 2013/02/27 17:01:12 jlec Exp $
+
+ 27 Feb 2013; Justin Lecher <jlec@gentoo.org> igraph-0.6.4.ebuild,
+ files/igraph-0.6.4-unbundle.patch:
+ Use detected pkg-config instead of generic
23 Feb 2013; Justin Lecher <jlec@gentoo.org> igraph-0.6.4.ebuild:
Add missing dep on virtual/pkgconfig
diff --git a/dev-libs/igraph/files/igraph-0.6.4-unbundle.patch b/dev-libs/igraph/files/igraph-0.6.4-unbundle.patch
index 61bbb8720b81..f40a03067a6b 100644
--- a/dev-libs/igraph/files/igraph-0.6.4-unbundle.patch
+++ b/dev-libs/igraph/files/igraph-0.6.4-unbundle.patch
@@ -257,7 +257,7 @@ index 050974a..e1496ac 100644
AT_KEYWORDS([thread-safe ARPACK])
AT_COMPILE_CHECK([simple/tls2.c], [simple/tls2.out], [], [internal],
- [-lpthread])
-+ [-lpthread $(pkg-config --libs arpack)])
++ [-lpthread $(${PKG_CONFIG} --libs arpack)])
AT_CLEANUP
diff --git a/tests/types.at b/tests/types.at
index f80a6a2..45087e8 100644
@@ -268,7 +268,7 @@ index f80a6a2..45087e8 100644
AT_KEYWORDS([sparse matrix igraph_sparsemat_t])
AT_COMPILE_CHECK([simple/igraph_sparsemat2.c], [simple/igraph_sparsemat2.out],
- [], [INTERNAL], [-lblas])
-+ [], [INTERNAL], [$(pkg-config --libs blas)])
++ [], [INTERNAL], [$(${PKG_CONFIG} --libs blas)])
AT_CLEANUP
AT_SETUP([Sparse matrix, indexing (igraph_sparsemat_t): ])
diff --git a/dev-libs/igraph/igraph-0.6.4.ebuild b/dev-libs/igraph/igraph-0.6.4.ebuild
index 02088411e3e0..0a3d4e1925c6 100644
--- a/dev-libs/igraph/igraph-0.6.4.ebuild
+++ b/dev-libs/igraph/igraph-0.6.4.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/igraph/igraph-0.6.4.ebuild,v 1.2 2013/02/23 12:45:10 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/igraph/igraph-0.6.4.ebuild,v 1.3 2013/02/27 17:01:12 jlec Exp $
EAPI=5
AUTOTOOLS_AUTORECONF=true
-inherit autotools-utils
+inherit autotools-utils toolchain-funcs
DESCRIPTION="Creating and manipulating undirected and directed graphs"
HOMEPAGE="http://igraph.sourceforge.net/index.html"
@@ -37,6 +37,7 @@ src_prepare() {
}
src_configure() {
+ tc-export PKG_CONFIG
local myeconfargs=(
$(use_enable gmp)
$(use_enable debug)