summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-04-18 20:58:32 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-04-18 20:58:32 +0000
commitc59f7d047055862dbe89d0e6cf49a2a1e186c2fb (patch)
tree34552db0344c0a9d871e3aaffe2371ea5af92f8b /dev-libs/igraph
parentadd multilib support (diff)
downloadgentoo-2-c59f7d047055862dbe89d0e6cf49a2a1e186c2fb.tar.gz
gentoo-2-c59f7d047055862dbe89d0e6cf49a2a1e186c2fb.tar.bz2
gentoo-2-c59f7d047055862dbe89d0e6cf49a2a1e186c2fb.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-libs/igraph')
-rw-r--r--dev-libs/igraph/ChangeLog10
-rw-r--r--dev-libs/igraph/files/igraph-0.6.5-unbundle.patch274
-rw-r--r--dev-libs/igraph/igraph-0.6.5.ebuild52
3 files changed, 334 insertions, 2 deletions
diff --git a/dev-libs/igraph/ChangeLog b/dev-libs/igraph/ChangeLog
index 20d4bcec108e..7b6d7c0390b2 100644
--- a/dev-libs/igraph/ChangeLog
+++ b/dev-libs/igraph/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/igraph
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/igraph/ChangeLog,v 1.7 2013/03/09 17:18:48 vadimk Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/igraph/ChangeLog,v 1.8 2014/04/18 20:58:32 mrueg Exp $
+
+*igraph-0.6.5 (18 Apr 2014)
+
+ 18 Apr 2014; Manuel Rüger <mrueg@gentoo.org>
+ +files/igraph-0.6.5-unbundle.patch, +igraph-0.6.5.ebuild:
+ Version bump.
09 Mar 2013; Vadim Kuznetsov vadimk@gentoo.org metadata.xml:
maintainer needed
diff --git a/dev-libs/igraph/files/igraph-0.6.5-unbundle.patch b/dev-libs/igraph/files/igraph-0.6.5-unbundle.patch
new file mode 100644
index 000000000000..f8f6319105ca
--- /dev/null
+++ b/dev-libs/igraph/files/igraph-0.6.5-unbundle.patch
@@ -0,0 +1,274 @@
+ configure.ac | 32 ++++++++++++-------------------
+ examples/simple/igraph_arpack_rnsolve.out | 3 +++
+ examples/simple/igraph_layout_merge2.out | 20 +++++++++----------
+ examples/simple/igraph_sparsemat2.c | 2 +-
+ examples/simple/igraph_sparsemat3.c | 2 +-
+ examples/simple/igraph_sparsemat4.c | 2 +-
+ src/Makefile.am | 11 +++--------
+ src/sparsemat.c | 2 +-
+ tests/Makefile.am | 2 +-
+ tests/mt.at | 2 +-
+ tests/types.at | 2 +-
+ 11 files changed, 35 insertions(+), 45 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index c617aec..6d5d162 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -165,7 +165,8 @@ if test "x$enable_gmp" != "xno"; then
+ AC_CHECK_HEADER([gmp.h], [
+ AC_DEFINE([HAVE_GMP], [1], [Define to 1 if you have the GMP library])
+ gmp_support=yes
+- LDFLAGS="${LDFLAGS} -lgmp"
++ GMP_LIBS="-lgmp"
++ AC_SUBST(GMP_LIBS)
+ ])
+ ])
+ fi
+@@ -223,23 +224,15 @@ else
+ fi
+
+ if test "$internal_blas" = "no"; then
+- AC_CHECK_LIB([blas], [daxpy_], [],
+- AC_CHECK_LIB([blas], [daxpy], [],
+- AC_CHECK_LIB([blas], [DAXPY_], [],
+- AC_CHECK_LIB([blas], [DAXPY], [],
+- [AC_MSG_RESULT(not found, trying to use -lblas anyway.)]))))
+- LDFLAGS="${LDFLAGS} -lblas"
++ PKG_CHECK_MODULES([BLAS],[blas])
++ CPPFLAGS="${CPPFLAGS} ${BLAS_CFLAGS}"
+ else
+ AC_DEFINE([INTERNAL_BLAS], [1], [Define to 1 if you use the internal BLAS library])
+ fi
+
+ if test "$internal_lapack" = "no"; then
+- AC_CHECK_LIB([lapack], [dlarnv_], [],
+- AC_CHECK_LIB([lapack], [dlarnv], [],
+- AC_CHECK_LIB([lapack], [DLARNV_], [],
+- AC_CHECK_LIB([lapack], [DLARNV], [],
+- [AC_MSG_RESULT(not found, trying to use -llapack anyway.)]))))
+- LDFLAGS="${LDFLAGS} -llapack"
++ PKG_CHECK_MODULES([LAPACK],[lapack])
++ CPPFLAGS="${CPPFLAGS} ${LAPACK_CFLAGS}"
+ else
+ AC_DEFINE([INTERNAL_LAPACK], [1], [Define to 1 if you use the internal LAPACK library])
+ fi
+@@ -248,16 +241,14 @@ if test "$internal_arpack" = "no"; then
+ if test "$tls_support" = "yes"; then
+ AC_MSG_ERROR([Thread-local storage only supported with internal ARPACK library])
+ fi
+- AC_CHECK_LIB([arpack], [dsaupd_], [],
+- AC_CHECK_LIB([arpack], [dsaupd], [],
+- AC_CHECK_LIB([arpack], [DSAUPD_], [],
+- AC_CHECK_LIB([arpack], [DSAUPD], [],
+- [AC_MSG_RESULT(not found, trying to use -larpack anyway.)]))))
+- LDFLAGS="${LDFLAGS} -larpack"
++ PKG_CHECK_MODULES([ARPACK],[arpack])
++ CPPFLAGS="${CPPFLAGS} ${ARPACK_CFLAGS}"
+ else
+ AC_DEFINE([INTERNAL_ARPACK], [1], [Define to 1 if you use the internal ARPACK library])
+ fi
+
++PKG_CHECK_MODULES([CS],[cxsparse])
++
+ glpk_support=no
+ if test "$internal_glpk" = "no"; then
+ AC_CHECK_LIB([glpk], [glp_read_mps], [
+@@ -270,7 +261,8 @@ if test "$internal_glpk" = "no"; then
+ ], [
+ AC_DEFINE([HAVE_GLPK], [1], [Define to 1 if you have the GLPK library])
+ glpk_support=yes
+- LDFLAGS="${LDFLAGS} -lglpk"
++ GLPK_LIBS="-lglpk"
++ AC_SUBST(GLPK_LIBS)
+ ])
+ ])
+ ])
+diff --git a/examples/simple/igraph_arpack_rnsolve.out b/examples/simple/igraph_arpack_rnsolve.out
+index ec38497..47b1a6b 100644
+--- a/examples/simple/igraph_arpack_rnsolve.out
++++ b/examples/simple/igraph_arpack_rnsolve.out
+@@ -17,6 +17,7 @@
+ 22.0483 0
+ -21.3281 0
+ -3.00735 -19.2957
++-3.00735 19.2957
+ ---
+ 0.373224 0.226696 0.204213 0.0473383
+ -0.289145 -0.296079 -0.0479785 0.156365
+@@ -32,6 +33,7 @@
+ -21.3281 0
+ -12.4527 0
+ -3.00735 -19.2957
++-3.00735 19.2957
+ ---
+ -0.226696 0.695866 -0.204213 -0.0473383
+ 0.296079 0.120213 0.0479785 -0.156365
+@@ -47,6 +49,7 @@
+ -3.00735 19.2957
+ -3.00735 -19.2957
+ 12.1099 6.27293
++12.1099 -6.27293
+ ---
+ 0.0768616 -0.195028 -0.152389 0.21912
+ 0.147607 0.0704569 0.346547 0.125122
+diff --git a/examples/simple/igraph_layout_merge2.out b/examples/simple/igraph_layout_merge2.out
+index dfe2c22..9fe81bf 100644
+--- a/examples/simple/igraph_layout_merge2.out
++++ b/examples/simple/igraph_layout_merge2.out
+@@ -1,13 +1,13 @@
+--2.73912 -2.95429
+--0.479512 -4.00008
+-1.96326 -3.51798
+-3.65613 -1.69214
+-3.95248 0.780051
+-2.73912 2.95429
+-0.479512 4.00008
+--1.96326 3.51798
+--3.65613 1.69214
+--3.95248 -0.780051
++-2.55311 -3.13964
++-0.22007 -4.0407
++2.19703 -3.39835
++3.77493 -1.45795
++3.91094 1.03935
++2.55311 3.13964
++0.22007 4.0407
++-2.19703 3.39835
++-3.77493 1.45795
++-3.91094 -1.03935
+ -1.6061 6.30088
+ -4.92661 5.80435
+ -3.69637 8.92826
+diff --git a/examples/simple/igraph_sparsemat2.c b/examples/simple/igraph_sparsemat2.c
+index 296e52e..3abd0e3 100644
+--- a/examples/simple/igraph_sparsemat2.c
++++ b/examples/simple/igraph_sparsemat2.c
+@@ -21,7 +21,7 @@
+
+ */
+
+-#include <cs/cs.h>
++#include <cs.h>
+ #include <igraph.h>
+ #include <igraph_sparsemat.h>
+ #include <igraph_blas_internal.h>
+diff --git a/examples/simple/igraph_sparsemat3.c b/examples/simple/igraph_sparsemat3.c
+index 630bf1a..b23cbe1 100644
+--- a/examples/simple/igraph_sparsemat3.c
++++ b/examples/simple/igraph_sparsemat3.c
+@@ -21,7 +21,7 @@
+
+ */
+
+-#include <cs/cs.h>
++#include <cs.h>
+ #include <igraph.h>
+ #include <igraph_sparsemat.h>
+
+diff --git a/examples/simple/igraph_sparsemat4.c b/examples/simple/igraph_sparsemat4.c
+index 4d85bde..7497faf 100644
+--- a/examples/simple/igraph_sparsemat4.c
++++ b/examples/simple/igraph_sparsemat4.c
+@@ -21,7 +21,7 @@
+
+ */
+
+-#include <cs/cs.h>
++#include <cs.h>
+ #include <igraph.h>
+ #include <igraph_sparsemat.h>
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index af7cae7..5db09eb 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -9,9 +9,6 @@ AM_YFLAGS = -d
+
+ lib_LTLIBRARIES = libigraph.la
+
+-include lapack/blas.inc
+-include lapack/lapack.inc
+-include lapack/arpack.inc
+ include plfit/plfit.inc
+
+ F2C = f2c/abort_.c f2c/dolio.c f2c/r_sin.c\
+@@ -99,8 +96,6 @@ if INTERNAL_ARPACK
+ ARPACK_LIB = libarpack.la
+ endif
+
+-include ../optional/glpk/glpk.inc
+-
+ if INTERNAL_GLPK
+ libglpk_la_SOURCES = $(GLPK)
+ libglpk_la_CFLAGS = -I$(top_srcdir)/optional/glpk
+@@ -247,7 +242,7 @@ libigraph_la_SOURCES = $(HEADERS_PRIVATE) \
+ drl_layout_3d.cpp drl_graph_3d.cpp \
+ DensityGrid_3d.cpp \
+ foreign-dl-parser.y foreign-dl-lexer.l \
+- $(CS) sparsemat.c mixing.c bigint.c bignum.c \
++ sparsemat.c mixing.c bigint.c bignum.c \
+ version.c optimal_modularity.c \
+ igraph_fixed_vectorlist.c separators.c \
+ igraph_marked_queue.c igraph_estack.c st-cuts.c \
+@@ -263,8 +258,8 @@ libigraph_la_SOURCES = $(HEADERS_PRIVATE) \
+ libigraph_la_CFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include $(WARNING_CFLAGS)
+ libigraph_la_CXXFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include $(WARNING_CFLAGS)
+ libigraph_la_LDFLAGS = -no-undefined
+-libigraph_la_LIBADD = -lm $(XML2_LIBS) $(F2C_LIB) $(BLAS_LIB) \
+- $(LAPACK_LIB) $(ARPACK_LIB) $(GLPK_LIB) $(PLFIT_LIB)
++libigraph_la_LIBADD = -lm $(XML2_LIBS) $(F2C_LIB) $(BLAS_LIBS) $(GMP_LIBS) \
++ $(LAPACK_LIBS) $(ARPACK_LIBS) $(GLPK_LIBS) $(PLFIT_LIB) $(CS_LIBS)
+
+ if INTERNAL_GLPK
+ libigraph_la_CFLAGS += -I$(top_srcdir)/optional/glpk
+diff --git a/src/sparsemat.c b/src/sparsemat.c
+index 2cbdab1..b78b88d 100644
+--- a/src/sparsemat.c
++++ b/src/sparsemat.c
+@@ -23,7 +23,7 @@
+
+ #include "config.h"
+
+-#include "cs/cs.h"
++#include <cs.h>
+
+ #include "igraph_sparsemat.h"
+ #include "igraph_error.h"
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 6d0ba59..af9bca9 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -13,7 +13,7 @@ $(srcdir)/package.m4: $(top_srcdir)/configure.ac
+ echo 'm4_define([AT_PACKAGE_BUGREPORT], [@PACKAGE_BUGREPORT@])'; \
+ } >$(srcdir)/package.m4
+
+-EXTRA_DIST += package.m4
++#EXTRA_DIST += package.m4
+
+ TESTSUITE_AT = \
+ testsuite.at \
+diff --git a/tests/mt.at b/tests/mt.at
+index 050974a..e1496ac 100644
+--- a/tests/mt.at
++++ b/tests/mt.at
+@@ -29,5 +29,5 @@ AT_CLEANUP
+ AT_SETUP([Thread-safe ARPACK:])
+ AT_KEYWORDS([thread-safe ARPACK])
+ AT_COMPILE_CHECK([simple/tls2.c], [simple/tls2.out], [], [internal],
+- [-lpthread])
++ [-lpthread $(${PKG_CONFIG} --libs arpack)])
+ AT_CLEANUP
+diff --git a/tests/types.at b/tests/types.at
+index f80a6a2..45087e8 100644
+--- a/tests/types.at
++++ b/tests/types.at
+@@ -133,7 +133,7 @@ AT_CLEANUP
+ AT_SETUP([Sparse matrix, multiplications (igraph_sparsemat_t): ])
+ AT_KEYWORDS([sparse matrix igraph_sparsemat_t])
+ AT_COMPILE_CHECK([simple/igraph_sparsemat2.c], [simple/igraph_sparsemat2.out],
+- [], [INTERNAL], [-lblas])
++ [], [INTERNAL], [$(${PKG_CONFIG} --libs blas)])
+ AT_CLEANUP
+
+ AT_SETUP([Sparse matrix, indexing (igraph_sparsemat_t): ])
diff --git a/dev-libs/igraph/igraph-0.6.5.ebuild b/dev-libs/igraph/igraph-0.6.5.ebuild
new file mode 100644
index 000000000000..73c3c76cf3d0
--- /dev/null
+++ b/dev-libs/igraph/igraph-0.6.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/igraph/igraph-0.6.5.ebuild,v 1.1 2014/04/18 20:58:32 mrueg Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils toolchain-funcs
+
+DESCRIPTION="Creating and manipulating undirected and directed graphs"
+HOMEPAGE="http://igraph.sourceforge.net/index.html"
+SRC_URI="mirror://sourceforge/project/${PN}/C%20library/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug gmp static-libs"
+
+RDEPEND="
+ dev-libs/libxml2
+ >=sci-libs/arpack-3
+ virtual/blas
+ virtual/lapack
+ >=sci-libs/cxsparse-3
+ sci-mathematics/glpk
+ gmp? ( dev-libs/gmp )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-unbundle.patch )
+
+src_prepare() {
+# rm -rf src/{cs,f2c,lapack,f2c.h} optional/glpk || die
+# rm -rf src/cs optional/glpk || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ tc-export PKG_CONFIG
+ local myeconfargs=(
+ $(use_enable gmp)
+ $(use_enable debug)
+ --disable-tls
+ --with-external-arpack
+ --with-external-blas
+ --with-external-lapack
+ --with-external-f2c
+ --with-external-glpk
+ )
+ autotools-utils_src_configure
+}