summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-03-10 16:30:06 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-03-10 16:30:06 +0000
commit06837010546694a88908988172e2947a5bd1c457 (patch)
treeb35494cc6eeceabcde97c5f38db01bd8c2ec6541 /dev-libs/jemalloc
parentAdd missing rdepend on bitescript. EAPI bump. (diff)
downloadgentoo-2-06837010546694a88908988172e2947a5bd1c457.tar.gz
gentoo-2-06837010546694a88908988172e2947a5bd1c457.tar.bz2
gentoo-2-06837010546694a88908988172e2947a5bd1c457.zip
added multilib-build version (bug 503628), thanks to grknight
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'dev-libs/jemalloc')
-rw-r--r--dev-libs/jemalloc/ChangeLog8
-rw-r--r--dev-libs/jemalloc/jemalloc-3.5.1-r1.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-libs/jemalloc/ChangeLog b/dev-libs/jemalloc/ChangeLog
index dc1f9bcf1094..aaf79fc63710 100644
--- a/dev-libs/jemalloc/ChangeLog
+++ b/dev-libs/jemalloc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/jemalloc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/jemalloc/ChangeLog,v 1.36 2014/03/10 14:39:41 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jemalloc/ChangeLog,v 1.37 2014/03/10 16:30:06 axs Exp $
+
+*jemalloc-3.5.1-r1 (10 Mar 2014)
+
+ 10 Mar 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org>
+ +jemalloc-3.5.1-r1.ebuild:
+ added multilib-build version (bug 503628), thanks to grknight
*jemalloc-3.5.1 (10 Mar 2014)
diff --git a/dev-libs/jemalloc/jemalloc-3.5.1-r1.ebuild b/dev-libs/jemalloc/jemalloc-3.5.1-r1.ebuild
new file mode 100644
index 000000000000..7b2f963ab737
--- /dev/null
+++ b/dev-libs/jemalloc/jemalloc-3.5.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jemalloc/jemalloc-3.5.1-r1.ebuild,v 1.1 2014/03/10 16:30:06 axs Exp $
+
+EAPI=5
+
+inherit autotools-multilib eutils
+
+DESCRIPTION="Jemalloc is a general-purpose scalable concurrent allocator"
+HOMEPAGE="http://www.canonware.com/jemalloc/"
+SRC_URI="http://www.canonware.com/download/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86 ~x64-macos"
+IUSE="debug static-libs stats"
+HTML_DOCS=( doc/jemalloc.html )
+PATCHES=( "${FILESDIR}/${PN}-3.5.1-strip-optimization.patch"
+ "${FILESDIR}/${PN}-3.5.1-no-pprof.patch"
+ "${FILESDIR}/${PN}-3.5.1_fix_html_install.patch"
+)
+MULTILIB_WRAPPED_HEADERS=( /usr/include/jemalloc/jemalloc.h )
+# autotools-utils.eclass auto-adds configure options when static-libs is in IUSE
+# but jemalloc doesn't implement them in its configure; need this here to
+# supress the warnings until automagic is removed from the eclass
+QA_CONFIGURE_OPTIONS="--enable-static --disable-static --enable-shared --disable-shared"
+src_configure() {
+ myeconfargs=(
+ $(use_enable debug)
+ $(use_enable stats)
+ )
+ autotools-multilib_src_configure
+}
+
+src_install() {
+ autotools-multilib_src_install
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # fixup install_name, #437362
+ install_name_tool \
+ -id "${EPREFIX}"/usr/$(get_libdir)/libjemalloc.1.dylib \
+ "${ED}"/usr/$(get_libdir)/libjemalloc.1.dylib || die
+ fi
+ use static-libs || find "${ED}" -name '*.a' -delete
+}