summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-06-11 17:48:09 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-06-11 17:48:09 +0000
commit3572060e8196bcfb2b5d23c1ec6a270be59da430 (patch)
tree1c32986042dfcadb453aca594335fe8750de3d68 /dev-libs/libRocket
parentCommit Manifest, hung GPG password prompt (diff)
downloadgentoo-2-3572060e8196bcfb2b5d23c1ec6a270be59da430.tar.gz
gentoo-2-3572060e8196bcfb2b5d23c1ec6a270be59da430.tar.bz2
gentoo-2-3572060e8196bcfb2b5d23c1ec6a270be59da430.zip
fix build wrt #512956
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'dev-libs/libRocket')
-rw-r--r--dev-libs/libRocket/ChangeLog6
-rw-r--r--dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild5
-rw-r--r--dev-libs/libRocket/libRocket-9999.ebuild5
3 files changed, 11 insertions, 5 deletions
diff --git a/dev-libs/libRocket/ChangeLog b/dev-libs/libRocket/ChangeLog
index 8c39af5cbca4..81bfc7256851 100644
--- a/dev-libs/libRocket/ChangeLog
+++ b/dev-libs/libRocket/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/libRocket
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libRocket/ChangeLog,v 1.10 2014/04/28 17:31:41 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libRocket/ChangeLog,v 1.11 2014/06/11 17:48:08 hasufell Exp $
+
+ 11 Jun 2014; Julian Ospald <hasufell@gentoo.org>
+ libRocket-1.2.1_p20130110-r1.ebuild, libRocket-9999.ebuild:
+ fix build wrt #512956
28 Apr 2014; Michał Górny <mgorny@gentoo.org>
libRocket-1.2.1_p20130110-r1.ebuild, libRocket-9999.ebuild:
diff --git a/dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild b/dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild
index 8d0bc846ccdf..f4e283335835 100644
--- a/dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild
+++ b/dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild,v 1.5 2014/04/28 17:31:40 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild,v 1.6 2014/06/11 17:48:08 hasufell Exp $
EAPI=5
@@ -66,11 +66,12 @@ multilib_src_configure() {
multilib_src_compile() {
cmake-utils_src_compile
+ local abi_build_dir=${BUILD_DIR}
if multilib_is_native_abi ; then
if use python ; then
buildpybind() {
- cp "${S}-${ABI}"/{libRocketCore*,libRocketControls*} "${python_BUILD_DIR}-${EPYTHON}"/ || die
+ cp "${abi_build_dir}"/{libRocketCore*,libRocketControls*} "${python_BUILD_DIR}-${EPYTHON}"/ || die
BUILD_DIR="${python_BUILD_DIR}-${EPYTHON}" cmake-utils_src_make _rocketcontrols/fast _rocketcore/fast
}
einfo "compiling python binding"
diff --git a/dev-libs/libRocket/libRocket-9999.ebuild b/dev-libs/libRocket/libRocket-9999.ebuild
index 2dce85a5d53b..90b0c5a7b226 100644
--- a/dev-libs/libRocket/libRocket-9999.ebuild
+++ b/dev-libs/libRocket/libRocket-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libRocket/libRocket-9999.ebuild,v 1.7 2014/04/28 17:31:40 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libRocket/libRocket-9999.ebuild,v 1.8 2014/06/11 17:48:09 hasufell Exp $
EAPI=5
@@ -67,11 +67,12 @@ multilib_src_configure() {
multilib_src_compile() {
cmake-utils_src_compile
+ local abi_build_dir=${BUILD_DIR}
if multilib_is_native_abi ; then
if use python ; then
buildpybind() {
- cp "${S}-${ABI}"/{libRocketCore*,libRocketControls*} "${python_BUILD_DIR}-${EPYTHON}"/ || die
+ cp "${abi_build_dir}"/{libRocketCore*,libRocketControls*} "${python_BUILD_DIR}-${EPYTHON}"/ || die
BUILD_DIR="${python_BUILD_DIR}-${EPYTHON}" cmake-utils_src_make _rocketcontrols/fast _rocketcore/fast
}
einfo "compiling python binding"