summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-19 15:41:31 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-19 15:41:31 +0000
commitd7c521b7fb630eb4f28915f2fa52fdc87161544f (patch)
tree8ec29995079042afd3e9d0af32f648e224d8d8aa /dev-libs/libchewing
parentVersion bump. (diff)
downloadgentoo-2-d7c521b7fb630eb4f28915f2fa52fdc87161544f.tar.gz
gentoo-2-d7c521b7fb630eb4f28915f2fa52fdc87161544f.tar.bz2
gentoo-2-d7c521b7fb630eb4f28915f2fa52fdc87161544f.zip
Introduce static-libs USE flag to avoid building the static archive for libchewing; remove .la file that is never required (no dependencies for the static archive); ncurses is not a runtime dependency but rather only a test dependency (with libncursesw which is provided by the unicode USE flag). Drop the pkg_postinst as the old libraries are not preserved, so they cannot be there unless user did copy them manually.
(Portage version: 2.2.0_alpha17/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libchewing')
-rw-r--r--dev-libs/libchewing/ChangeLog13
-rw-r--r--dev-libs/libchewing/libchewing-0.3.2-r1.ebuild32
2 files changed, 23 insertions, 22 deletions
diff --git a/dev-libs/libchewing/ChangeLog b/dev-libs/libchewing/ChangeLog
index 608a92e03548..b2028a706409 100644
--- a/dev-libs/libchewing/ChangeLog
+++ b/dev-libs/libchewing/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-libs/libchewing
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libchewing/ChangeLog,v 1.20 2010/12/12 09:00:11 flameeyes Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libchewing/ChangeLog,v 1.21 2011/01/19 15:41:31 flameeyes Exp $
+
+ 19 Jan 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ libchewing-0.3.2-r1.ebuild:
+ Introduce static-libs USE flag to avoid building the static archive for
+ libchewing; remove .la file that is never required (no dependencies for the
+ static archive); ncurses is not a runtime dependency but rather only a test
+ dependency (with libncursesw which is provided by the unicode USE flag). Drop
+ the pkg_postinst as the old libraries are not preserved, so they cannot be
+ there unless user did copy them manually.
*libchewing-0.3.2-r1 (12 Dec 2010)
diff --git a/dev-libs/libchewing/libchewing-0.3.2-r1.ebuild b/dev-libs/libchewing/libchewing-0.3.2-r1.ebuild
index 27848cf931be..73f9ce573bad 100644
--- a/dev-libs/libchewing/libchewing-0.3.2-r1.ebuild
+++ b/dev-libs/libchewing/libchewing-0.3.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libchewing/libchewing-0.3.2-r1.ebuild,v 1.1 2010/12/12 09:00:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libchewing/libchewing-0.3.2-r1.ebuild,v 1.2 2011/01/19 15:41:31 flameeyes Exp $
EAPI=2
@@ -13,12 +13,15 @@ SRC_URI="http://chewing.csie.net/download/libchewing/${P}.tar.bz2"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="debug test"
+IUSE="debug test static-libs"
-RDEPEND="sys-libs/ncurses"
+RDEPEND=""
DEPEND="${RDEPEND}
dev-util/pkgconfig
- test? ( >=dev-libs/check-0.9.4 )"
+ test? (
+ sys-libs/ncurses[unicode]
+ >=dev-libs/check-0.9.4
+ )"
src_prepare() {
epatch "${FILESDIR}"/0.3.2-fix-chewing-zuin-String.patch
@@ -29,7 +32,8 @@ src_prepare() {
src_configure() {
export CC_FOR_BUILD="$(tc-getBUILD_CC)"
- econf $(use_enable debug) || die
+ econf $(use_enable debug) \
+ $(use_enable static-libs static) || die
}
src_test() {
@@ -41,19 +45,7 @@ src_test() {
src_install() {
emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README TODO || die
-}
+ find "${D}"/usr/$(get_libdir) -name '*.la' -delete || die
-pkg_postinst() {
- if [[ -e "${ROOT}"/usr/$(get_libdir)/libchewing.so.1 ]] ; then
- elog "You must re-compile all packages that are linked against"
- elog "<libchewing-0.2.7 by using revdep-rebuild from gentoolkit:"
- elog "# revdep-rebuild --library libchewing.so.1"
- fi
-
- if [[ -e "${ROOT}"/usr/$(get_libdir)/libchewing.so.2 ]] ; then
- elog "You must re-compile all packages that are linked against"
- elog "<libchewing-0.3.0 by using revdep-rebuild from gentoolkit:"
- elog "# revdep-rebuild --library libchewing.so.2"
- fi
+ dodoc AUTHORS ChangeLog NEWS README TODO || die
}