summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-10-27 11:43:17 +0000
committerPacho Ramos <pacho@gentoo.org>2012-10-27 11:43:17 +0000
commite6ecf0760bf3b9e279690acdacb7f07c4fbadba6 (patch)
treea926a23313764aa6822639702bcdfe646a16c996 /dev-libs/libcroco/libcroco-0.6.8.ebuild
parentStable on alpha, bug #439734 (diff)
downloadgentoo-2-e6ecf0760bf3b9e279690acdacb7f07c4fbadba6.tar.gz
gentoo-2-e6ecf0760bf3b9e279690acdacb7f07c4fbadba6.tar.bz2
gentoo-2-e6ecf0760bf3b9e279690acdacb7f07c4fbadba6.zip
Version bump, drop old.
(Portage version: 2.1.11.30/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-libs/libcroco/libcroco-0.6.8.ebuild')
-rw-r--r--dev-libs/libcroco/libcroco-0.6.8.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/libcroco/libcroco-0.6.8.ebuild b/dev-libs/libcroco/libcroco-0.6.8.ebuild
new file mode 100644
index 000000000000..df6161a7d922
--- /dev/null
+++ b/dev-libs/libcroco/libcroco-0.6.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcroco/libcroco-0.6.8.ebuild,v 1.1 2012/10/27 11:43:17 pacho Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Generic Cascading Style Sheet (CSS) parsing and manipulation toolkit"
+HOMEPAGE="http://git.gnome.org/browse/libcroco/"
+
+LICENSE="LGPL-2"
+SLOT="0.6"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="test"
+
+RDEPEND="dev-libs/glib:2
+ >=dev-libs/libxml2-2.4.23"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig"
+
+src_prepare() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README TODO"
+ G2CONF+=" --disable-static"
+
+ if ! use test; then
+ # don't waste time building tests
+ sed 's/^\(SUBDIRS .*\=.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed failed"
+ fi
+
+ gnome2_src_prepare
+}